hi everyone,

i am new to this linux thing so i was looking for the answer on several forums but their solution did not help...
i installed smoothwall express 2.0 it works fine. i enabled squid and dansguardian in this machine.
and it is in transparent mode... thus port 80 is redirected to dansguardian port and dansguardian points to squid: squid port is block from internal and external access... only the localhost is allowed to access squid port. this setting works well until i tried to specify a proxy in my browser, when a proxy is specified in the browser it bypasses my filtering which defeats my purpose that all internet surfing must pass through my filter. And this is my problem I want all internet access filtered, how can i do this? smootwall express is using iptables.

here is what i want... All internet surfing must pass through my filter by maintaining a transparent proxy.

thank you for your help,
ocavid