ok i will start with the 411, im slowly learning linux/bsd im on the http://melbournewireless.org.au network

we use a 10.10.X.X ip network

my home network is 192.168.1.X

this is a ifconfig of my gateway

eth0 Link encap:Ethernet HWaddr 00:01:02:7F:09:EF
inet addr:192.168.1.207 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:26736 errors:0 dropped:0 overruns:416 frame:0
TX packets:21099 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:3471177 (3.3 MiB) TX bytes:21262965 (20.2 MiB)
Interrupt:9 Base address:0xd880

eth1 Link encap:Ethernet HWaddr 00:10:B5:0F:BF:AA
inet addr:192.168.1.77 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 cool.gif TX bytes:0 (0.0 cool.gif
Interrupt:10 Base address:0x5400

eth2 Link encap:Ethernet HWaddr 00:40:96:29:67:30
inet addr:10.10.144.55 Bcast:10.10.144.63 Mask:255.255.255.240
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1880093 errors:112736 dropped:0 overruns:0 frame:112736
TX packets:154404 errors:41 dropped:0 overruns:0 carrier:41
collisions:46311 txqueuelen:1000
RX bytes:105952363 (101.0 MiB) TX bytes:14470978 (13.8 MiB)
Interrupt:6 Base address:0xdf00

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:5267 errors:0 dropped:0 overruns:0 frame:0
TX packets:5267 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:341170 (333.1 KiB) TX bytes:341170 (333.1 KiB)

wifi0 Link encap:UNSPEC HWaddr 00-40-96-29-67-30-00-00-00-00-00-00-00-00-00-00
inet addr:10.10.144.55 Bcast:10.10.144.63 Mask:255.255.255.240
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1880093 errors:112736 dropped:0 overruns:0 frame:112736
TX packets:154404 errors:41 dropped:0 overruns:0 carrier:41
collisions:46311 txqueuelen:100
RX bytes:105952363 (101.0 MiB) TX bytes:14470978 (13.8 MiB)
Interrupt:6 Base address:0xdf00

wlan0 Link encap:Ethernet HWaddr 00:02:6F:04:0F:A5
inet addr:10.10.144.129 Bcast:10.10.144.143 Mask:255.255.255.240
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:33622 errors:0 dropped:53631 overruns:0 frame:0
TX packets:46675 errors:0 dropped:786 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:22945513 (21.8 MiB) TX bytes:7005342 (6.6 MiB)
Interrupt:11 Base address:0x100

root@totoro:~: 09:25 PM $


keep in mind eth2 and wifi0 are the same card

i have a ftp on 192.168.1.130 that i want people to be able to use thru the 10.10.X.X network


i tryed this
iptables -t nat -A PREROUTING -i eth2 -p tcp --dport 21 -j DNAT --to 192.168.1.130:21
to no luck


any ideas?