Help - Search - Members - Calendar
Full Version: X Unable To Boot
Linuxhelp > Support > Technical Support
Kousu
Good day smile.gif

I've got a computer with mandrake 8.1 sitting in my room. It worked well enough (but only just) for a while, but then one day all of the sudden it refused to boot. When I turn on the computer and let lilo boot into "linux" (as opposed to "linux-nonfb" or "failsafe") it seems to work for a few seconds (the screen is lit up, though it is black), but then the screen goes dark. Then it gets into a loop where it alternates between lit up and not lit up black screens.

Eventually I figured out that I could switch into a different console, and found that what's happening it's trying to boot X, gets up to the mouse, but exits when it tries to load the fixed font. The message is just something like "error: could not load font "fixed"". I assume that the reason for the loop is that mandrake just tries again if the window manager doesn't boot once.

So, my question is what do I need to do to replace the broken fixed font? I tried looking in /usr/X11R6/lib/X11/fonts/ but none of those files seems to be the one I'm looking for.

Thanks in advance and all that.
Hemant
Make sure that xfs is started before loading X.
My guess is you might have disabled xfs somehow to start during the booting sequence.

Thus switch to textmode and login as root and enter command
# setup

and select xfs to start during booting.

But this is only a guess...try it.
Kousu
Perhaps you mean a different command, because my system doesn't seem to have a "setup".

Nevertheless, I don't think that that is the problem. I did try starting xfs while logged in as root on tty1, then going to tty2 and trying startx, although that shouldn't make a difference anyway...

But this time I grabbed the log. Here's the last few lines:

QUOTE
Error loading keymap /var/tmp/server-0.xkm
Couldn't load XKB keymap, falling back to pre-XKB keymap
Could not init font path element unix/:-1, removing from list!

Fatal server error:
could not open default font 'fixed'

When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to xfree86@xfree86.org.
Kousu
*bump*

Can nobody point me in any direction at all?
Hemant
Ahh....certainly there is some problem with xfs unsure.gif

There may be different reasons for this:

Somewhere (pretty much at the beginning of the log) there is a message:
CODE
  Could not init font path element unix/:7100, removing from list!

This message tells that the Xserver is trying to contact a font server which appearantly isn't running. So you need to get your font server up and running before you start X. How this is done depends heavily on the OS and/or the distribution you use. Please contact your vendor support on how to do this!
Please note: The use of the font server xfs is deprecated due to several bugs in it. It is recommended that the Xserver loads the fonts directly. To do so add at least the lines:
CODE
       FontPath     "/usr/X11R6/lib/X11/fonts/misc/"
       FontPath     "/usr/X11R6/lib/X11/fonts/Speedo/"
       FontPath     "/usr/X11R6/lib/X11/fonts/Type1/"
       FontPath     "/usr/X11R6/lib/X11/fonts/CID/"
       FontPath     "/usr/X11R6/lib/X11/fonts/75dpi/"
       FontPath     "/usr/X11R6/lib/X11/fonts/100dpi/"

to the "Files" section of your XF86Config file.

If you see a messages like:
CODE
(WW) The directory "/usr/X11R6/lib/X11/fonts/100dpi" does not exist.
       Entry deleted from font path.

it means that this font path element either does not exist or isn't readable. Normally it is no problem if some font path elements listed in your XF86Config are missing. However if /usr/X11R6/lib/X11/fonts/misc/ is missing the cursor and the fixed fonts are missing, too, therefore the server cannot start. Therefore please make sure that this directory exists and is readable. To have a good selection of standard fonts you should have at least the directories listed above. If you need non-latin character sets more fonts may be required.
Please also check for messages like:
CODE
(WW) `fonts.dir' not found (or not valid) in "/usr/X11R6/lib/X11/fonts/local/"
.
     Entry deleted from font path.
     (Run 'mkfontdir' on "/usr/X11R6/lib/X11/fonts/local/").
...
Could not init font path element /usr/X11R6/lib/X11/fonts/misc/, removing from list!

These tell you that the fonts were probably not installed correctly. Please do as suggested and run
mkfontdir /usr/X11R6/lib/X11/fonts/local/
Please replace /usr/X11R6/lib/X11/fonts/local/ with the directories listed in your log file. You should do this for every directory listed.

Some additional resources:
http://feenix.burgiss.net/ldp/fdu/
http://www.xfree86.org/4.3.0/xfs.1.html
http://www.redhat.com/docs/manuals/linux/R...s1-x-fonts.html
http://www.xfree86.org/4.3.0/XFree86.1.html

Hope this helps!!!!! biggrin.gif
Hemant
And in Redhat and Fedora series..setup is a nice command for system configuration in text mode.
I think Mandrake doen't comes with this...
Kousu
Thank you very much Hemant! biggrin.gif I have solved my problem and my computer is usable once more.

I checked out XF86Config and tried adding the lines you suggested, but that didn't help. Then I changed the line
FontPath "unix/:-1"
to
FontPath "unix/:7100"
(I was assuming that the file had become corrupt during a hard shutdown or something and X had rewritten it using a null value instead of the proper port)

However this still didn't help. But then I realized that it said "Using config file XF86Config-4" at the top of the log, for some reason. So I went and made the same change to that file... still no luck. However, then I added FontPath "/usr/X11R6/lib/fonts/misc/" and tah dah, I could get into KDE!

Thank you ever so much, it's been out of commission for like a year by now. Have a great day!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.