I am quit new to Linux and very inexperienced. My P4 1.7 Mhz system currently has XP Pro and SuSE 9.0 (dual boot). That part works fine. I can boot to either OS. (It uses the SuSE boot option.)

I am trying to upgrate to SuSE 9.1 Developer version using the installation CDs. After selecting "English" language the "Installation Settings" are presented. I select "Update an existing System".

Problem: The installation procedure looks for and finds my SuSE 9.0 (Ext3) partition and asks if I want to upgrade onto this partition. When I answer "Yes" it responds with:

"Partition could not be mounted. Check log file /var/log/YaST/y2log"

Yet:
1) SuSE still 9.0 boots fine.
2) A Knoppix (3.4?) CD can boot and view my Ext3 partition.
3) Partition Magic 8.0 gives all partitions a clean bill of health.

It is unclear to me why I cannot upgrade. I don't know how to look at the "y2log" log during installation. I have been unable to find any mention of these issues on the SuSE web site.

My drive is an EIDE Maxtor 80 GB partitioned basically as follows:

XP Boot FAT32 8 GB Active Primary
Extended 28.9 GB Primary
FAT16 FAT 2 GB Logical
XPNTFS NTFS 22.2 GB Logical
unallocated 4.7 GB Logical
Swapspace2 LinuxSwap 1 GB Primary
Linux Ext3 40 GB Primary
unallocated 7.8 GB

Please, does anyone have an idea of what's going on???

Unfourtnately SuSE's support hours are during my work hours. I just cannot afford to take a day off to phone them.

Thank you in advance!