Help - Search - Members - Calendar
Full Version: 3d Acceleration Very Slow On Xfree86 4.4
Linuxhelp > Support > Technical Support
Oxyd
When I run chromium, I get very slow FPS (unplayable). I'm trying to fix it for some time already and in order to do it, I also updated to XF 4.4 (from 4.3). I've got Radeon 9000, XFree 4.4, Mandrake 9.1 (Kernel 2.4.21). I am not using Ati's drivers since they didn't release XFree 4.4 drivers yet (and I get the same results with XFree 4.3 drivers). The X's log doesn't say anything strange...

Oxyd
Robert83
Hi,

please read this : http://www.linuxhelp.ca/forums/index.php?a...t=ST&f=7&t=3070

Sincerely
Robert B
hughesjr
The XFree drivers are NOT able to do any 3D .... that is what the ATI drivers do.

If you want to to 3D, you have to install the ATI proprietary drivers...
Oxyd
QUOTE
If the result is:

CONFIG_AGP_NVIDIA=y

You have the kernel patch installed (and it is enabled) ... you should be able to use 3D drivers from NVIDIA right now ... if you have ATI, to use their 3D drivers, you have to check one other thing in the config file ...


The result is that grep can't find CONFIG-AGP_NVIDIA so I guess I don't have the patch installed... But there's not written where should I find it and install it!

If I installed the ATI drivers, it didn't work either (I tried it before on XFree 4.3 and now on XFree 4.4 too).

Oxyd
hughesjr
That specific advise (about CONFIG_AGP_NVIDIA) is only applicable to motherboards that use the NFORCE2 NVIDIA chipset. If your PC doesn't use that chipset, it isn't required.
Oxyd
QUOTE
That specific advise (about CONFIG_AGP_NVIDIA) is only applicable to motherboards that use the NFORCE2 NVIDIA chipset. If your PC doesn't use that chipset, it isn't required.


Ironically - It is nforce2 chipset.

Oxyd
Robert83
Hi,

then you can use this guide on how to install Ati Drivers on a nforce2 board, it should be easy, just try it, if you fail at a step ask and we'll be glad to help you out. smile.gif

http://www.linuxhelp.ca/forums/index.php?a...t=ST&f=7&t=3070

Sincerely
Robert B
Robert83
Hi,

it is CONFIG_AGP_NVIDIA and NOT CONFIG-AGP_NVIDIA

Sincerely
Robert B
Oxyd
So - I again installed the Xfree 4.3 ati drivers on Xfree 4.4 and again it didn't work! The ending of my Xfree log:

(II) Loading sub module "drm"
(II) LoadModule: "drm"
(II) Loading /usr/X11R6/lib/modules/linux/libdrm.a
(II) Module drm: vendor="The XFree86 Project"
compiled for 4.3.99.12, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension XFree86-DRI
(II) LoadModule: "fglrx"
(II) Loading /usr/X11R6/lib/modules/drivers/fglrx_drv.o
(II) Module fglrx: vendor="Fire GL - ATI Research GmbH, Germany"
compiled for 4.3.0.1, module version = 3.7.6
Module class: XFree86 Video Driver
ABI class: XFree86 Video Driver, version 0.6
(II) UnloadModule: "fglrx"
(II) Unloading /usr/X11R6/lib/modules/drivers/fglrx_drv.o
(EE) Failed to load module "fglrx" (module requirement mismatch, 0)
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
compiled for 4.4.0, module version = 1.0.0
Module class: XFree86 XInput Driver
ABI class: XFree86 XInput driver, version 0.4
(EE) No drivers available.

Fatal server error:
no screens found

So?

Oxyd
hughesjr
Did you follow the directions in the link that robert posted to build the fglrx module?
Oxyd
http://www.linuxhelp.ca/forums/index.php?a...t=ST&f=7&t=3070 <- this link? Well - I looked at my config file to see wheter I had CONFIG_AGP_NVIDIA there. I didn't. Then I turned off the DRM. Recompiled the kenel and modules, typed 'lilo' and rebooted. Then I installed the fglrx-4.3.0-3.7.6.i386.rpm downloaded from ATI site. Ran fglrxconfig. Configured X and rebooted. The X didn't start (see the log above).

I don't know wheter I didn't miunderstand something in the instructions, so if yes, then please correct me, but I did this with a good hope it was correct.

Oxyd
hughesjr
I apologize, you wrote Mandrake 9.1 ... but I read Mandrake 9.2. Mandrake 9.1 has a 2.4.21 kernel, but NFORCE2 GART wasn't added to the kernel until 2.4.22.

Since the 2.4.21 kernel doesn't include the NVIDIA NFORCE 2 chipset agpgart patch, which is required to use any 3D drivers from either nvidia or ATI, you must patch the kernel and rebuild or somehow build a nvidia gart kernel module.

You can try to install the RPM to your current kernel by downloading it from here:

http://www.nvidia.com/object/linux_nforce_1.0-0261

If you already have installed the RPM to get the audio and network card working, then the GART is not installed via the RPM (which is what I think happens)

The GART kernel patch (see the readme) is for the 2.4.20 kernel and I don't know if it will patch a 2.4.21 kernel if the NVIDIA RPM driver doesn't do it.

So, try to install the RPM for mandrake 9.1 and see if that will add the required modules, if it doesn't ... you can try to build a new RPM from the source rpm with the command:

rpmbuild --target athlon --rebuild NVIDIA_nforce-1.0-0261.src.rpm

However, I don't think the GART driver is even installed with that RPM ....
-------------------------
BUT, Mandrake 9.2 and the latest kernel upgrade (2.4.22-30mdk) does have the NFORCE2 GART patch already built into the kernel (As do the Mandrake 10 Community and Mandrake 10 Official kernels). Your best bet to get 3D performance from the NFORCE2 board is to install Mandrake 9.2 or higher (if you want to stick with Mandrake) or Fedora Core 1 or 2, or SUSE 9.1, or Slackware 9.1, or Debain Sarge/SID ... all of which have a 2.4.22 or higher kernel that has the NFORCE2 GART patch already built-in.
LuckyLuke
The problem is not the 3D drivers I guess. I've been trying to run chromium for the last few years (7 maybe) on my last 3 machines, p120, pIII-500 and p4-2.8 with different graphics cards, a non 3d one, a voodoo 3-2000 and an fx5700le td, on different oses, redhat, slackware, mandrake, knoppix with the latest updates. It was sometimes starting at a good speed, and sometimes it was being hard to close the program because it was too slow and was making it hard to wait the main menu to open, in order to choose the 'quit' menu item. When the program was run, it was taking about 10-20 secs for the main menu to open. On an installation of RedHat, I was able to run it at normal speeds a few times, and not anymore. I did no change on the system, but it totally stopped working at normal speed, or maybe I'm not doing as many tries as did in the past.

First, when it was starting at an ultra slow speed, I was closing it and trying again. But as I said, it will never start at a normal speed now. If the problem was the graphics config, I would never be able to play it. Today I tried it on knoppix again, and wondered if the problem was discovered, so I made a search for "linux chromium slow" again and found this site. And I think it was also having problems with the sound drivers. Ah by the way, I never had a problem with another 3d game, they were utilizing my 3d hardware&drivers well. I guess chromium has a bug for a long time through the versions, and it needs to be discovered. My only comment would be "try again and again till it starts at a normal speed or you get tired".

PS: Not talking about "chromium bsu.", a shooter game I saw on search results now, I'm talking about the one installed with some OS'es, a snake type 3D game featuring two motorbike-like vehicles which were seen in an old disney movie. People should make a search before giving a name to a software to see if something with the same name exists.
Oxyd
So - I installed the source .rpm (the binary one didn't work), rebuilt it and installed it. At bootup it says it can't find module nvaudio. The I tried to install the ATI driver, but again, it didn't work.

Maybe I should give it up... What are the alternatives to patch the kernel and try to aggresively and without any regrets jam in the ATI drivers?

Oxyd
Termina
Have you followed ATI's instructions?

http://ati.com/support/infobase/linuxhowto-ati.html

rpm -Uh --force <ati_package_name>.rpm
^^^
Is the command you should use, which should install it successfully.
Robert83
Hi,

If I remember it correctly when I installed the Ati RPM drivers I had to use rpm --force *.rpm to install it , since it was always complaining about some conflict with some other rpm...


Sincerely
Robert B
Oxyd
Well - if I simply told you, I installed the package correctly, you wouldn't be much pleased, would you? =). Yes - I installed it via rpm, I used --force so the command was "rpm -Uvh --force <package>.rpm" and it was installed correctly. I then ran fglrxconfig and configured and didn't start the X-server... That's all... If I was supposed to call upon the God of rpm packages to bless my feat, then I'm sorry, I didn't do it (though it might help wink.gif ).

Oxyd
Termina
Do you see "fglrx" anywhere in your XF86Config file?

Try 'modprobe fglrx' and see if that helps any. =(
hughesjr
If you upgrade to either Mandrake 9.2 or 10 ... the NVIDIA agpgart patch is already part of the kernel ... and the RPM should install without to many problems...
Oxyd
Alright. So - I have the Mandrake 10.0 Official with kernel 2.6.3-7mdk. (Updgraded from my old Mdk 9.1). I reinstalled the ati drivers and found the 3d not working (what a surprise). So, I looked to the config and found I've had enabled DRM. Disabled DRM in menuconfig, recompiled the kernel, reinstalled the ati driver and ... guess what =).

I personally think, the problem is in my kernel recompilation - I'm not any guru in compiling kernels and this was the first time I was compiling the 2.6 kernel... When I look at /boot/config now, there is CONFIG_DRM=y, however in menuconfig it's disabled and uname -v shows I'm really running my recompiled kernel.

Oxyd
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.