Help - Search - Members - Calendar
Full Version: Acpi For A Newbie
Linuxhelp > Support > Technical Support
cflyguy
i thought i knew so much about computers...then i found linux...
but thats a different thread, what i want to know is how to get Linux to recogonize ACPI functions on my toshiba tecra 8200, i've read some stuff, but it involves messing w/ the kernel, i'm a super neewbie and doing stuff like that scares me so if anyone would like to help that would be great.
Jim
what distro of linux are you trying to put on your system and what kernel version are you using. If you don't know what kernel version your using type the command uname -r that will tell you.
cflyguy
SuSE 9.0 Pro w/ KDE, kernel 2.4.21-215
hughesjr
http://www.buzzard.org.uk/toshiba/

I don't know if they work with SUSE.
cflyguy
i think your right, when i try to install the 'toshiba tools' it keeps giving me an error, any other ideas, other patches?
Jim
what error did it give you? Hit up goole with the key words toshiba tecra 8200 and linux and maybe ACPI and see what comes up, I got lots of tutorials on how to configure the systems. See if any of those are helpful.
cflyguy
this is the error it gives me:

loading cache ./config.cache
checking host system type... i686-pc-linux-gnu
checking whether make sets ${MAKE}... no
checking for gcc... gcc
checking whether the C compiler (gcc -s) works... yes
checking whether the C compiler (gcc -s) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking for a BSD compatible install... /usr/bin/install -c
checking how to run the C preprocessor... gcc -E
checking for X... no
checking for bison... no
checking for byacc... no
checking for flex... lex
checking for yywrap in -ll... no
checking for xmessage... /usr/X11R6/bin/xmessage
checking for wall... /usr/bin/wall
checking for yywrap in -lfl... no
checking for X... (cached) no
configure: error:
*** X libraries or include files not found. Check 'config.log' for
*** more details.

i think it is missing some files that it it expecting to be installed w/ the distro, but i can't figure out what it is missing. the only other ACPI hits i'm finding are for the project at sourceforge, and i'd need to update my kernel to use those, and i don't think i'm up for that unless i can get a good walk through or a installer.
hughesjr
Load Yast ....

Go to Install and remove software

On the Filter dropdown box, select Package Groups.

Open Developement and then Libraries in the left Window and click on X11.

In the right window, check (or verifiy checked) XFree86-devel, XFree86-Mesa-devel, xforms-devel, gtk2-devel, qt3-devel...then install them.

Then try again and post any errors....
cflyguy
WOW, HOW DO U DO THAT? this is why i swiched, the linux community is so much better, i'd spend a week going through KB articles looking for how to fix something like this in windows...
cflyguy
now if only my printer would work, then yall really would be computer gods....
hughesjr
Glad you got it working smile.gif

Linux isn't that hard (If you have been doing it since 1995). I have a multiple boot test machine that has most of the major distros loaded (at least the lastest versions of them ... SUSE, RedHat 9, Fedora Core 1 & 2, Slackware, Gentoo, Debian, WhiteBoxEL, CentOS, Mandrake 9.2 & 10, FreeBSD 5.2.1) ... so I can usually load the OS and see the problems.
cflyguy
off acpi topic but i need a printer driver, and its reall hard to find, b/c its a fairly new printer (HP PSC 2410xi) anyone know where to look?
Jim
I just flipped through the list of supported printers in Mandrake and it had the PSC 2400 but not the 2410 so this must be a really new printer.

Have you tried having your system auto configure it? It might be close enough to some of the other drivers that it would work (or at least mostly) untill new drivers come out, because I am not seeing any drivers.
cflyguy
YaST found it and a 2200 series driver worked ok
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.