Help - Search - Members - Calendar
Full Version: Mbr Lilo/grub Problems
Linuxhelp > Support > Technical Support
Termina
I've installed Gentoo, and everything should work fine... if I could boot into it.

Sadly, I seem unable to get lilo or grub working fine.
(Note: I have to type this from my Windows computer, since I can't get into linux, so I can't give all the information I wish I could)
Here are my partitions:

hda:
hda1 - Windows XP (NTFS)

hdc:
hda2 - Swap
hda3 - Root

So I made a good lilo.conf (ran lilo to write it to mbr, with one error being that my map file is hdc while my MBR is hda).


I'll try to put it here from memory:
QUOTE
boot = hda
vga = 791

kernel = /boot/kernel-2.6.5-gentoo-r1
label = gentoo
root = /dev/hdc3

other = /dev/hda1
label = winxp


Then I run lilo.

When I restart, I get 01 01 01 01 01 across the screen. =/


I tried Grub as well, but got Grub Error 21. >_<

I have a 98 floppy disk, which I use to 'fdisk /mbr' since I don't know the command to fix mbr in linux. =D



Is there a way to install lilo to a floppy disk? If so, how can I do this?
Jim
The linux rescue CD (which has pretty much the same tools as included on any distro) has a tool for re-installing the bootloader. You could take another distro's boot disk and type rescue, or you could find the Linux Rescue cd and download that. Either one should alow you to install a boot loader and configuer it. That should get you started.
Termina
I've been using the rescue disk to (basically) enter into the enviornment I created, and I've tried reinstalling lilo/grub several times.

Is that any diffrent from using the linux rescue disk?
Jim
The linux Rescue disk has a few more tools on it. I doubt you would have much success though.

So you have been able to boot into Gentoo but you just can't get a bootloader to work?

A couple things, first, use grub, its better and you will be happy you did later. Second, is getnoo the only linux system on the system. If it's not your going to have to chainload into it. Third, you said you had a swap and root partition, did you make a boot partition like they recomended?

I would try getting grub up and running than you can custom create boot comands on the fly to figure out how to get into your system.
Termina
I have Windows on hda, and linux on hdc

No boot partitions

I can get into my gentoo install by:

mount /dev/hdc3 /mnt/gentoo
swapon /dev/hdc2
chroot /mnt/gentoo /bin/bash
env-update


I've tried grub, withno success. =/


I guess I'll just reinstall it on hda some other time
Jim
is Gentoo the only linux on the drive though? Because if it isn't sometime boot over from hda is hard. What you could do is install grub to the MBR of hdb and than chain load to it, that might work better, especially if gentoo is the only linux on that drive. Try that, and see what happens.
Termina
It's the only linux distro on that drive (though there is an NTFS partition on it as well). What do you mean by chainload it? smile.gif
hughesjr
OK .... use grub ... not lilo.

after you get into the chroot do this:

grub

root (hd1,2)

setup(hd0)


inside grub.conf type this:


title Gentoo 2004.1 2.6.5-gentoo-r1
root (hd1,2)
kernel (hd1,2)/boot/kernel-2.6.5-gentoo-r1 root=/dev/hdc3 vga=0x317


title WinXP
rootnoverify (0,0)
chainloader +1
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.