Help - Search - Members - Calendar
Full Version: Help With Java Virtual Machine
Linuxhelp > Support > Technical Support
Venom
This may be an easy one, but for me it has almost driven me insane. I have tried to install j2re1.4.2 without any browser detection. It seems to install fine using the downloadable RPM from Java. My problem arises after i run the rpm; I dont know what to do next, and the Java website is very difficult to understand.

running Fedora Core 1.

Thanks in advance.
hughesjr
What was the name of the RPM you installed?
Venom
The RPM file was

j2re-1_4_2_04-linux-i586-rpm.bin
hughesjr
I normally don't use the RPM for java, although that appears to be the correct one.

Here is what I normally do:

To install this way, you would need to remove your current rpm.

rpm -qa | grep j2re

remove the resulting rpm with the command (substitute the output above for rpm:

rpm -e rpm

Download the latest java from www.blackdown.org, HERE is the latest file right now.

After it is downloaded, do this to make it executable (all steps to take place from a terminal as root, inside the directory where you downloaded the file to):

chmod 755 j2re-1.4.2-rc1-linux-i586-gcc3.2.bin

Then run it like this:

./j2re-1.4.2-rc1-linux-i586-gcc3.2.bin

(press the space bar until the more dissappears and type yes to install)

You will get a directory called j2re1.4.2 that contains the Java Runtime Environment. We now need to move it to it's final place ... I use /usr/lib, so do this...

mv j2re1.4.2/ /usr/lib/

Now let's create a symbolic link to the name /usr/lib/java (which is where a lot of programs expect java to be) like this:

ln -s /usr/lib/j2re1.4.2/ /usr/lib/java

Now let's link the executable java file to /usr/bin so it is in our path like this:

ln -s /usr/lib/java/bin/java /usr/bin/java

Now let's see if we did everything right...issue the command:

java -version

If all went well, it will say:
java version "1.4.2-rc1"
Java™ 2 Runtime Environment, Standard Edition (build Blackdown-1.4.2-rc1)
Java HotSpot™ Client VM (build Blackdown-1.4.2-rc1, mixed mode)


Now we need to setup the web browser, I use mozilla and/or FireFox ... and this should work for both.

Link the mozilla plugin for jave to the mozilla plugin directory like this...

ln -s /usr/lib/java/plugin/i386/mozilla/libjavaplugin_oji.so /usr/lib/mozilla/plugins/

Now if you open mozilla, and Select from the Help menu item, the About Plug-ins, you should now see the java plugin installed....
Venom
Dude! you have no idea how long I've read and followed directions to get this to work. Your way worked EXACTLY as you said it would! I think your reply should be a pinned item for the newbies like myself. Learning Linux will take time, but people like you make the learning process less stressful. Sometimes reaching a snag can hinder the ability to want to learn.

Thanks for your time, and for getting Java to work on my system.

Venom...
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.