Help - Search - Members - Calendar
Full Version: Help Installing Lego Usb Tower
Linuxhelp > Support > Hardware Support
smbell
Hello and Thanks ahead of time for any help I may get here.
I'm fairly new to Linux (only been running for a couple of months) and I can't seem to fix this problem.

System:
Slackware 9.1
Kernel 2.6.5
Swaret upgraded all to Slackware current

I am trying to get the Lego Mindstorm USB Tower to work. Currently I have compiled the driver into the kernel (tried as module before)

When I plug it in I get the message:
usb.agent[number changes]: ... no modules for USB product 694/1/100
in /var/log/messages

as suggested on another site I tried
mknod /dev/usb/lego0 c 180 160
but that didn't seem to help

when It was compiled as a module I would get the message during boot that it was connected to /dev/usb/lego0 but that file didn't exist.

I would appreciate any help or suggestions on this. I am using the Lego System with the BrickOS and that appears to be installed properly. I need to get this to work for a robotics class. Thank You again.
smbell
Update:

I recompiled the kernel and changed the Lego Driver from compiled to module.

now in the /var/log/message I see
usb 4-2: new low speed USB device using address 4
usb 4-2: configuration #1 chosen from 4 choices
drivers/usb/misc/legousbtower.c: LEGO USB Tower device now attached to /dev/usb/lego0

However /dev/usb/lego0 does not exist and if I create it with mknod c 180 160
I get the message
/dev/usb/lego0 not a tty
when I run the firmdl3 program (this program connects to the tower to download the firmware)
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.