Help - Search - Members - Calendar
Full Version: Mandrake Help With A Few Questions
Linuxhelp > Support > Technical Support
beuy
1. How do I change the lilo boot program to boot to my windows xp installtion? Below is the lilo.conf file outlining what I have tried to do, and it still boots to linux by default.

boot=/dev/hda
map=/boot/map
default=NT
keytable=/boot/uk.klt
prompt
nowarn
timeout=100
message=/boot/message
menu-scheme=wb:bw:wb:bw
ignore-table
other=/dev/hda1
label=NT
table=/dev/hda
image=/boot/vmlinuz
label=linux
root=/dev/hda6
initrd=/boot/initrd.img
append="devfs=mount hdd=ide-scsi quiet"
vga=788
read-only
image=/boot/vmlinuz
label=linux-nonfb
root=/dev/hda6
initrd=/boot/initrd.img
append="devfs=mount hdd=ide-scsi"
read-only
image=/boot/vmlinuz
label=failsafe
root=/dev/hda6
initrd=/boot/initrd.img
append="devfs=nomount hdd=ide-scsi failsafe"
read-only

other=/dev/fd0
label=floppy
unsafe

2. How do I change my login session to KDE instead of ICEWm.

3. How do I change shortcut keys, my 2 key is currently set it " instead of @ (which is set to my " key) confusing no?

Ty for any help.
Robert83
Hi,

please do a backup of the lilo config file before you change stuff, I don't use lilo, but I bet that this will work.

default=NT

see this ? this means that the default is NT which is on /dev/hda

and there is a label linux which starts linux on /dev/hda6
CODE
initrd=/boot/initrd.img
append="devfs=mount hdd=ide-scsi quiet"
vga=788


so basicaly all you need to do in order to make it boot to linux by default is change that
default=NT
to
default=linux

as for the rest, well I'm writing from a WinXP computer and I'm kinda tired so please forgive me, I will look at it tomorrow , but most probably by then someone will surely answer the other 2 questions.

Sincerely
Robert B
beuy
Ah ty for the help, but im trying to make it boot to !Windows XP! by default, even though I have changed it to NT it still boots to linux by default sad.gif
Jim
So here is something thats really pissing me off with Mandrake right now. It doesn't seem to like it when you edit the files by yourself. Do this. Go to your start center and go System|Configuration|Configuer Your Computer than go to boot than boot loader just click next and it will alow you to see all your different boot option. Configure your windows one and select the defualt box. That should work for you.

Than in the same boot menu. Open up AutoLogin and you can change the defualt desktop.

As for the keyboard issue thats wiered. Is that the only mapping error? Make sure you have US set as your keyboard language.
beuy
Ty for the help, I have fixed the auto login in and keyboard mapping problems (you where correct, it was the keyboard setting) But im still having trouble with lilo, it keeps saying it cant boot my win xp image. Im told grub is better, any help?
hughesjr
From everything I read, your LILO setup is correct....

try the command:

lilo -v -v
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.