Help - Search - Members - Calendar
Full Version: No More Smbadduser Command In Fedora?
Linuxhelp > Support > Technical Support
Nigam
No more smbadduser command in Fedora?

Guys, when I try to add user from samba on my Fedora how come there's no command of smbadduser? what's the alternative for this when your in the shell terminal.
Corey
I don't use fedora, however, are you sure the command doesn't exist somewhere? Do a "su -" (su space minus) and do a "whereis smbadduser". If nothing is found then, update your locate database with "updatedb" then do a "locate smbadduser". I can't imagine fedora taking out the command, unless they want to force you to use some sort of graphical tool, however, as i said, i've never used Fedora, so I can't comment on that.
Robert83
Hi,

that command is
CODE
smbpasswd -a USER


read this :

http://www.redhat.com/archives/fedora-list...h/msg00939.html


Sincerely
Robert B
Corey
d'oh, i should have remembered that, i used it yesterday. I think i was reading "smbadduser" but interpretty it as 'smbpasswd -a'.

My mind is mush since the leafs lost last night sad.gif
petterg
I'd like to add a followup question to this smbuseradd / smbpasswd thing - as the smbuseradd and smbuserdel are no longer available, how are we supposed to remove smbusers?
smbpasswd got the -a option to add users, but there are no options to delete users!
Robert83
Hi,

CODE
man smbpasswd


Output :
CODE
OPTIONS
      -a     This option specifies that  the  username  following  should  be
             added  to  the local smbpasswd file, with the new password typed
             (type <Enter> for the old password). This option is  ignored  if
             the  username following already exists in the smbpasswd file and
             it is treated like a regular change password command. Note  that
             the default passdb backends require the user to already exist in
             the system password file (usually /etc/passwd), else the request
             to add the user will fail.

             This option is only available when running smbpasswd as root.

      -x     This  option  specifies  that  the  username following should be
             deleted from the local smbpasswd file.

             This option is only available when running smbpasswd as root.

      -d     This option specifies that the username following should be dis-
             abled in the local smbpasswd file. This is done by writing a 'D'
             flag into the account control space in the smbpasswd file.  Once
             this  is  done  all  attempts to authenticate via SMB using this
             username will fail.


so -x is to remove usernames

Sincerely
Robert B
petterg
Guess i'm blind.
Thanx
Robert83
Hi,

it can happen to anyone,

I was trying to mount /dev/hdb5 , and I forgot that it was removed .. smile.gif , thing like this will happen to all of us smile.gif


Sincerely
Robert B
hughesjr
I spent 3 days trying to figure out why my citrix changes weren't taking effect ... the last step of the procedure I was following said reboot to have the changes take effect .... 3 days later when I finally rebooted, they did indeed work.

We all have bad days smile.gif

Good thing I get paid by the hour and not by work accomplishments laugh.gif
Nigam
Yes, that's correct even me I forgot to do man smbpasswd but after that I got it. Thank you guys.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.