Help - Search - Members - Calendar
Full Version: Where Did My Windows Drive Go?
Linuxhelp > Support > Technical Support
Jim
So I don't realy know why, or what I did to cause this, but the last time I booted up my windows drive didn't mount. So I have tried my best to get it to mount with no success. I have tried using ever vartiation of mount I can think of, edited my fstab file, used HardDrake, tried just about everything I can.

I can run a mount command like mount -o dev hda1 and it will run with out giving me an error but nothing will be in the folder. And yes, I checked to makes sure my windows drive wasn't empty. So here is the fstab file. I am stumped, I have been trying for half the afternoon.

CODE
/dev/hdb5 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hdb7 /home ext3 defaults 1 2
/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,sync,codepage=850 0 0
none /mnt/hda1 supermount dev=/dev/hda1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,kudzu,codepage=850 0 0
none /mnt/removable supermount dev=/dev/scsi/host0/bus0/target0/lun0/part1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,kudzu,codepage=850 0 0
none /mnt/zip supermount dev=/dev/hdd4,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,sync,codepage=850 0 0
none /proc proc defaults 0 0
/dev/hdb6 swap swap defaults 0 0


hda1 is the windows drive and hdb is the linux drive just for information.
Jim
Of course as soon as I make a post things change. I rebooted and now hda is at least showing up in my GKrellM monitor, it wasn't before. There is still nothing in the folder, but if I tried to mount it, it says access denied, and if I try to un-mount it it says it busy. Great.
michaelk
QUOTE
none /mnt/hda1 supermount dev=/dev/hda1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,kudzu,codepage=850 0 0

You do not need supermount, its purpose is to elliminate the need to use the mount / umount commands for removable media like floppies and CDs. Thus supermount causes errors when trying to mount or umount the drive. In addition you do not need kudzu either. kudzu is for new hardware detection.

I suspect your problems are related to supermount. Try this for the fstab entry:
/dev/hda1 /mnt/hda1 vfat umask=000,users,noauto 0 0

The drive will not be mounted at boot up. To mount the drive:
mount /mnt/hda1.

If you want mounted at boot up then delete the noauto option. The users option allows any regular to mount or unmount.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.