Help - Search - Members - Calendar
Full Version: Ps/2 Mouse Module Problem
Linuxhelp > Support > Technical Support
moon
I have a ps/2 USB Intellimouse plugged into the ps/2 mouse port with the USB-PS/2 adapter that comes with the mouse. All works OK in Windows so there doesn't appear to be a hw problem.

When I run Linux the mouse does not work. Also if I cat /dev/mouse the keyboard locks. I can reboot several times plugging the mouse into the PC's USB port then back into the PS/2 adapter/port and kudzu removes the Intellimouse PS/2 and if I set to USB all is OK. Mouse works and keyboard doesn't lock.

Just to test the effect of the /etc/X11/XF86Congig file I removed it. Without this file I got EXACTLY the same results as before. During the boot process kudzu never saw the mouse when plugged into the PS/2 port, though it lights up. If plugged into the USB port kudzu finds it on boot and when you cat /dev/mouse you get output. If you shutdown, plug mouse into PS/2 port, reboot, then run mouseconfig and set as a Intellimouse PS/2 and try and cat /dev/mouse you don't get output and the keyboard locks. If you shutdown plug into USB rebot run mouseconfig and setup as a USB Intellimouse you get mouse output from a cat /dev/mouse and the keyboard does not lock. This is all without a XF86Config file. In fact mouseconfig never prompts you if you want to update your XF86Config file.

There doesn't appear to be an interrupt problem because IRQ12 is linked just to PS/2 mouse when the mouse is configured as a PS/2 mouse.

This all seems like a module problem. How would I know. Should I load a special module with switches set?

Could the Celeron in the slocket board I'm running that is faster then the old PII cause timing issues with PS/2 modules and hw?

ANY SUGGESTIONS???
Corey
The only thing I can think of is, did you check and make sure your symbolic like was set for /dev/mouse to point to /dev/psaux when it was plugged into the ps/2 port? As well, when it was plugged into the usb port, was the link setup for /dev/mouse to point to /dev/input/mice ? I've never experienced a problem with PS/2 mouse protocol before. As well, I would kill any console mouse services you got running, i find those a pain in the ass, and i have really never had the need to have a mouse in console.
moon
hi tourettes,

I stopped gpm with a gpm -k and the problems remainded. It appears that the symbolic links from /dev/psaux (special character file mknod /dev/psaux c 10 1) to /dev/mouse and /dev/input/mice are all correct. If you could suggest a way to determine this correctly I would be most greatful.

The problem is that whenever I cat /dev/mouse or /dev/psaux or /dev/input/mice all I get is keyboard input on the screen from the cat. If I move the mouse (configured as a ps/2 intellimouse) then all locks up. If I telnet in and kill the cat process then we get the keyboard back.

Whenever I cat /dev/mouse with the mouse plugged into the USB port and configured as a USB mouse then mouse output appears on the screen.

Also why wouldn't kudzu find the mouse on the ps/2 port? Kudzu can find the mouse when its plugged into the USB port.

I know we are close and this is not a XF86Config problem.

thanks


chris
Corey
If the mouse works while plugged into the usb slot, then why don't you keep it like that?

You can find out what file /dev/mouse links to with the command "ls -l /dev | grep mouse". You pretty much know how to diagnose the problem, it maybe just one of those weird things that happens. I know that my logitech mouse has similar queer problems. It works fine with /dev/psaux, but it is contrary with /dev/input/mice .
moon
hi tourettes,

Good question on why not keep the Intellimouse USB. I failed to mention that the PC is a dual boot PC with Redhat 8.0 and Win95. BTW this is why I know its not a hw issue as all works fine under Win95 with the Intellimouse plugged into the ps/2 port. Everytime I boot Grub handles the sw but I have to get on my hands and knees before BIOS stops to switch the mouse ports. Not pretty. Win95 doesn't support USB Intellimouse mice ;-) .

I will keep at the link issues and try and get more info for you. Here is some info that may help too.

- Running a slocket processor with a Coppermine 766.
- When I installed Redhat 8.0 (running Anaconda?) the sw found the PS/2 Intellimouse and it worked all through the installation. Only after the reboot did the problems occur.

There must be a symbolic link from /dev/keyboard? or /dev/input/keyboard? to one of the mouse dev's or why else would I get keyboard output to the screen when I cat /dev/mouse ? Also if the mouse moves at all the keyboard locks and I must kill the cat from a telnet as I mentioned.

What I should do is look at all the symbolic links when the mouse is setup as a USB and all is fine and try and duplicate this when setup as a ps/2.

Also do you know if you can plug a mouse into the ps/2 port after PC has booted and get it to work running mouseconfig. The USB sees the interrupt but I don't know if the ps/2 hw is setup to do this, except at boot time?
chrisw
if you cat /dev/mouse
you should see output from the file

you can unplug the ps2 mouse and plug it back it but for some reason..
it wont work if you start kde or gnome....i have done this before
and it really pisses me off...but oh well.....though you might
try running the config for your mouse...but i doubt it will work
moon
hi tourettes,

Well you must be tried of me by now.

Things are pretty messed up on the mouse side now. With all my ln's and rm's I have broken the USB mouse sw too. The good side of this is that the mouse behaves the same way whether plugged into the USB port or the ps/2 port.

This is how I setup my symbolic links for the ps/2 port (which doesn't work):

As root I typed in:

mknod --mode=664 /dev/psaux c 10 1
ln -s /dev/psaux /dev/mouse
ln -s /dev/input/mice /dev/mouse

The symptoms are that whenever I start gpm or x windows the keyboard and mouse locks up. If I cat /dev/psaux or any of the others I get keyboard output to the console only. Once I move the mouse the keyboard loacks and I never get any output to the screen from the mouse. The only way to get the console back is to telnet in and kill the process.

Do you have any suggestions?
What is the best way to remove a link?
Is ps/2 support built into the redhat 8.0 kernel or is it though a module?

Another issues that might help is that now after I setup mouse through mouseconfig as a ps/2 mouse I do NOT see IRQ 12 in /proc/interrupts. This is not good.

When I do a lsmod I see input with keyb?, mouse, and hid processes attached(?). There are no processes attached (?) to mouse or keyb - I'm going by memory.

Help,

chris
moon
hi tourettes and all,

Well we got the USB mouse back and all it took was some mknod /dev/input/mice c 13 63 and ln -s commands. Seems there is a pretty involved scripts in the rc.sysinit file to load keyboard amd mouse USB modules. BTW I removed them all in the script and to make sure they had not effect.

Seems that IRQ12 links to ps/2 mouse never appears unless you run gpm or startx. However, once you do the keyboard locks. Same effect if you cat /dev/psaux and move the ps/2 mouse. What appears different is the use of the ps/2 mouse by the cat application only loack when the mouse is moved. gpm and startx locks too but does so without moving the mouse.

How would I determine is ps/2 mouse support is built into the kernel. It appears to be there only because the messages file has ps/2 mouse messages in it.

BTW I do all the correct symbolic links and create psaux before I run x or gpm so I'm pretty sure the symbolic links are OK.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.