Help - Search - Members - Calendar
Full Version: Audio Help!
Linuxhelp > Support > Technical Support
maveric
I just finished installing college linux i havent dabled in any linux in over 5 years and i was just looking for some help on getting my audio to work in linux this was the last error i recived from one of my audio applications:

MPlayer 1.0pre2-3.2.3 © 2000-2003 MPlayer Team
CPU: Intel Celeron 2/Pentium III Tualatin 723.1 MHz (Family: 6, Stepping: 1)
Detected cache-line size is 32 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
Compiled with Runtime CPU Detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetection
Reading config file /etc/mplayer/mplayer.conf
Reading config file /home/maveric/.mplayer/config
Reading /home/maveric/.mplayer/codecs.conf: Reading /etc/mplayer/codecs.conf: 61 audio & 157 video codecs
Can't open '/home/maveric/.mplayer/codecs.conf': No such file or directory
font: can't open file: /home/maveric/.mplayer/font/font.desc
Font /usr/share/mplayer/font/font.desc loaded successfully! (206 chars)
Using usleep() timing
Input config file /opt/kde/share/apps/kplayer/input.conf parsed: 56 binds
Playing /home/maveric/My Downloads/Dave Matthews Band - Everyday.mp3
Audio file detected.
Clip info:
Title: Everyday
Artist: Dave Mathews Band
Album: Everyday
Year:
Comment:
Track: 12
Genre: Rock
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
MP3lib: init layer2&3 finished, tables done
AUDIO: 44100 Hz, 2 ch, 16 bit (0x10), ratio: 16000->176400 (128.0 kbit)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
Checking audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 44100 hz, little endian signed int
AF_pre: 44100Hz 2ch Signed 16-bit (Little-Endian)
SDL: Samplerate: 44100Hz Channels: Stereo Format Signed 16-bit (Little-Endian)
SDL: using esd audio driver
ALSA lib pcm_hw.c:1055:(snd_pcm_hw_open) open /dev/snd/pcmC0D0p failed: Permission denied
SDL: Unable to open audio: No available audio device
Could not open/initialize audio device -> no sound.
Audio: no sound
Video: no video
Exiting... (End of file)[B]

Thanks for any help or advice
Termina
ALSA lib pcm_hw.c:1055:(snd_pcm_hw_open) open /dev/snd/pcmC0D0p failed: Permission denied
SDL: Unable to open audio: No available audio device


From that error message, I'm going to recommend a few things.

chmod -R 777 /dev/snd

Retry

If that fails, what sound hard do you use (If it's onboard, are you able to give us the motherboard model?) since if that didn't work, it's probally a driver problem.
maveric
Thanks termina .... well i have strong reason to belive its a driver problem ... not compleatly sure but im gonna find out ... i dont think its the permissions ....

Crystal CS4205 (this looks like its my audio component) I looked for drivers from dell no go

I dont have much documentation on my laptop any more .... and the ol'device manager from windows isnt here so ... heres what i got on my orginal configuration i havent changed anything but memory:

1 4E912 Processor, Pentium III, TUL, 1G, 512K, UPGA 1 2K446 Assembly, Documentation, Cable, Technical Sheet, Cover, Latitude
1 9364U Adapter, Alternating Current, External, 20V, 70W, 3W, Bell Atlantic
1 1164X Assembly, Liquid Crystal Display, W/INVRTR, SMSNG, 14.1
1 1H778 Assembly, Cable, Flexible, XGA LCD, Dorado/Athens/Tualatin/Almodor
1 1H817 Bezel, Liquid Crystal Display, Latitude, C610
1 1H821 Assembly, Palmrest, Latitude, C610
1 6P823 Assembly, Base (Assembly or Group), Notebook, Original Equipment Mfgr., Dorado/Athens/Tualatin/Almodor, V2
1 71PXH Assembly, Floppy Drive, INT/EXT, Notebook, Light Weight
1 3C048 Keyboard, 87, US/ENG, C600/I4K, R2
1 4K174 Kit, Advanced Port Replicator, CPORT2, V.3, 90W, Dell Americas Organization
1 0F437 Case, Carrying, NYL, Notebook, CLASSIC
2 6H259 Dual In-Line Memory Module, 128, 133M, 16X64, 8K, 144
1 2M400 Battery, Primary, 14.8V, 8C, Lithium, SANYO
1 3J956 Battery, 59W, Second, 14.8V, 8CELL, SONY
1 1N010 Kit, DOC/DSK, SWDVD, INTERVIDEO, 3.0.58.6
1 0G639 Subassembly, Compact Disk Read Write, Digital Video Disk Drive, 8X, Samsung, Notebook
1 0E828 Modem, 56K, Internal, Modem Daughter Card, PCTel, GVC
1 1C464 Subassembly, Hard Drive, 20GB, IDE (Integrated Drive Electronics), #2, HITACHI
1 2M629 Hard Drive, 20GB, IDE (Integrated Drive Electronics), 2.5" Form Factor, 9.5MM, TSHBA-STN
1 480WV Carrier, Hard Drive, C600/I4000
1 8267R Connector, Header, 2X22, Female, 2, S, Gold, 35K, Third Height, Chip Set
1 1F756 Kit, Software, Overpack, Windows 2000 Professional, SP2, 5.25" Form Factor, England/English
Jim
Ok, lets start for the top for a second. What distro are you using? What kernel are you using? What audio programs have you tried? When do you get the error? And what is the model number off your lap top?
maveric
Distro.. College linux ... (slackware based so i hear)


Kernel .. Well no idea im trying to find out as i write here ... good question!


Audio programs ... Kaboodle, kplayer,Noatun, i have tried all of them that are packaged with this distro

I get the error when attempting to play in certain players ... not all players now that i think of it. But some read out the error as i wrote in my first display and others show that they are playing and no sound.

My model of my laptop is a Dell Latitude C610
Jim
You college has their own linux distro, thats cool.

Ok, I am going to go dig up stuff on your lap top. You do this

uname -r

and give me the results, that tells me what kernel version your running.
Jim
run the command

lsmod

and see if snd-intel8x0 is running. If its not run

modprobe snd-intel8x0

and see if your sound fires up, if it does, come back and tell me so I can tell you how to make the module load at boot time so you don't have to type it in every time.
maveric
maveric@ISIS:~$ uname -r
2.4.23
maveric@ISIS:~$

maveric@ISIS:~$ lsmod
Module Size Used by Not tainted
radeon 99968 19
snd-pcm-oss 37316 0
snd-mixer-oss 11760 0 [snd-pcm-oss]
uhci 24508 0 (unused)
snd-intel8x0 17896 0
snd-ac97-codec 43276 0 [snd-intel8x0]
gameport 1420 0 [snd-intel8x0]
snd-pcm 56132 0 [snd-pcm-oss snd-intel8x0]
snd-timer 13476 0 [snd-pcm]
snd-page-alloc 5972 0 [snd-intel8x0 snd-pcm]
snd-mpu401-uart 3072 0 [snd-intel8x0]
snd-rawmidi 12704 0 [snd-mpu401-uart]
snd-seq-device 3888 0 [snd-rawmidi]
snd 30180 0 [snd-pcm-oss snd-mixer-oss snd-intel8x0 snd-ac97-codec snd-pcm snd-timer snd-mpu401-uart snd-rawmidi snd-seq-device]
soundcore 3396 4 [snd]
ds 6612 2
yenta_socket 10304 2
pcmcia_core 39872 0 [ds yenta_socket]
ide-scsi 9360 0
3c59x 25648 1
keybdev 1956 0 (unused)
mousedev 4212 1
hid 21092 0 (unused)
input 3200 0 [keybdev mousedev hid]
usbcore 59276 1 [uhci hid]
agpgart 43972 3
apm 9612 2
ntfs 51264 1 (autoclean)

DOSENT SEEM TO BE RUNNING >>>>

maveric@ISIS:~$ modprobe snd-intel8x0
-bash: modprobe: command not found
maveric@ISIS:~$ modprobe snd-intel8x0
-bash: modprobe: command not found
maveric@ISIS:~$
maveric
acutaly im sorry in another review ... alot of sound stuff seems to be running ... and i cant make heads or tails of it
Jim
sorry, in order to do the command modprobe you have to have root privilage. Type su at the command line, than enter your password, that try it again.

CODE
[jim@x84-99-17-dhcp jim]$ su
Password:
[root@x84-99-17-dhcp jim]# modprobe snd-intel8x0
[root@x84-99-17-dhcp jim]#
maveric
maveric@ISIS:~$ su
Password:
root@ISIS:/home/maveric# modprobe snd-intel8x0
root@ISIS:/home/maveric#


seems to have worked
Jim
Ya, but does your audio work? Thats the question. This is about as close to live support as I have ever done. Ya for not doing homework.
maveric
no no audio ... <not doing homework either ... somany betterthings to do !
Jim
Ya, and I have finals in two weeks. Heck ya. Ok, so the snd thing didn't do it. Humph, ok, give me a min, that was suposed to work.

So just so I am clear, your getting sound from some programs but not others? I am not so sure we aren't barking up the wrong tree, it might be the programs that aren't configured right, not the sound card.
maveric
No sound at all... there is an onboard speaker...(sucks) and a headphone out ... used to plug in aux speakers ... im not getting even a beep with any speekers
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.