Help - Search - Members - Calendar
Full Version: Working With Apache + Mod_proxy
Linuxhelp > Support > Technical Support
amihay_t
hi
i am working with apache 1.3.27
Code:
./configure --prefix=/etc/httpd/ --activate-module=src/modules/php4/libphp4.a --enable-module=ssl --disable-module=cgi --enable-module=proxy

my problem is when apache need to proxy a page with broken path
"<img src="images/6.jpg" width="100" height="100" /> "
but if the page has full path it work good.
"<img src="http://10.0.1.250/EDS_ATP/images/6.jpg" width="100" height="100" />"

my http.conf (proxy section)
Code:

#<IfModule mod_proxy.c>
ProxyRequests Off

# <Directory proxy:*>
# Order deny,allow
# Deny from all
# Allow from .your-domain.com
# </Directory>

#
# Enable/disable the handling of HTTP/1.1 "Via:" headers.
# ("Full" adds the server version; "Block" removes all outgoing Via: headers)
# Set to one of: Off | On | Full | Block
#

ProxyVia On
#ProxyRemote * http://194.133.187.227:8080

ProxyPass /pn http://www.hamakor.org.il/
ProxyPassReverse /pn http://www.hamakor.org.il/

ProxyPass /p http://212.117.156.55/index.html
ProxyPassReverse /p http://212.117.156.55/index.html

ProxyPass /pin http://10.0.1.50
ProxyPassReverse /pin http://10.0.1.50

ProxyPass /pini http://10.0.1.250/EDS_ATP/
ProxyPassReverse /pini http://10.0.1.250/EDS_ATP/
#
# To enable the cache as well, edit and uncomment the following lines:
# (no cacheing without CacheRoot)
#
# CacheRoot "/usr/local/apache/proxy"
# CacheSize 5
# CacheGcInterval 4
# CacheMaxExpire 24
# CacheLastModifiedFactor 0.1
# CacheDefaultExpire 1
# NoCache a-domain.com another-domain.edu joes.garage-sale.com

#</IfModule>
# End of proxy directives.


10x
hughesjr
I think you need to change:

<img src="images/6.jpg" width="100" height="100" />

to

<img src="/images/6.jpg" width="100" height="100" />
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.