Help - Search - Members - Calendar
Full Version: Problems Loading Slackware.
Linuxhelp > Support > Technical Support
Im running a dual-boot setup (win xp-fat32, and slackware 9.1- ext2). The installation went very smoothly. I have however run into a little problem. When Slackware is loading it freezes. The last two lines are as follows:

cs: port probe 0x0c00-0x0cff: clean
cs: port probe 0x0800-0x08ff

I've let this run for hours and still nothing. When I try to restart with Ctrl-Alt-Del, it does nothing. What could be causing this problem???

i found some possible solutions to your Slackware problem :

Whitehat OK, I should have done WAY more research before posting. I feel like a fool biggrin.gif

Here is what I did:

First after installing Slackware 9.1 and putting LILO on the MBR, I rebooted and booted off of the Slackware CD.

I then mounted my HD stuff as skog stated to do above:

make the dirs in /mnt u need
mount them in /mnt
cd to them
chroot /mnt/hd /bin/bash

After this I was able to edit my lilo.conf in the /etc folder. Which worked nicely smile.gif

I then decided to modify the /etc/pcmcia/config.opts as follows:

from include port 0x100-0x4ff, port 0x800-0x8ff,port 0xc00-0xcff to include port 0x100-0x4ff,port 0xc00-0xcff (credit to Mark Holbrook from here )

I then added hdparm -d1X66 -c3 -m16 /dev/hda to my rc.local file using pico (my favorite editor) wink.gif

Now I boot this bad boy and I get my Options of Windows XP Pro and Slackware Linux 9.1

Dang.... Slack is sure a fine OS I must say.

and from
Reading the release notes of the the latest PCMCIA tools I found a reference to a enhancement to support the "Texas Instruments PCI4451 PC card Cardbus Controller" which the command lspci had returned. I downloaded pcmcia utils rev 3.1.22 on another computer, put them on a floppy (luckily they fit) and moved them to the Dell. I followed the instructions and config-ed, compiled, and installed the pcmcia utils. When I loaded the pcmcia modules, the kernel would hang. A tip from a fellow Linux missionary suggested I remove the pcmcia modules directory (/lib/modules/2.2.16/pcmcia) and re-install the utils. I did this and pcmcia modules would load without a kernel hang.

Update 11/18/10: I have installed SuSE7.2 on my laptop and found that to get the PCMCIA utils to work there must be a change to the file "/etc/pcmcia/config.opts". The line "include port 0x100-0x4ff, port 0x800-0x8ff, port 0xc00-0xcff" works when changed to "include port 0x100-0x4ff, port 0xc00-0xcff". It has also be reported to me that the PCMCIA system works if this line is completely removed from the file.

Robert B
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.