Help - Search - Members - Calendar
Full Version: Installing 2jsdk On Suse 9.0
Linuxhelp > Support > Technical Support
ryagami12
installed the Sun J2SDK on my SuSe 9.0 Linux and tried to run a simple Java progam without success at step 2 below.

HelloWorld.java Program:

public class HelloWorld {
public static void main(String[] args) {
System.out.println("Hello World!");
}
}

Step 1: ran ./javac HelloWorld.java successfully
Step 2: unsuccessful at running ./java HelloWorld

Error Message: Exception in thread "main" java.lang.NoSuchMethodError: main

Also tried to load J2SDK on Windown XP and got the same error message.

Tried loading Java library in SuSe, but didn't help.
Jim
I don't think the code is getting compiled right. Your code is good, thats not the problem, but I think you know that. Where there any errors durring the install? How did you install it? Source or RPM?

The java error you are getting back it the kind of error you would get it the method hadn't been declaired right, but you did so it doesn't help us figuer out whats wrong with the install.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.