Help - Search - Members - Calendar
Full Version: Server Behind Router
Linuxhelp > Support > Technical Support
mrdee27
I have earthlink DSL w/static IP address. I just switched to a new Linksys router and set up my linux ver 9 server to a static IP from the router, but nothing goes through. I can access my server with 10000, or the domain from inside, but the router won't pass the address on. I didn't have this problem with my old D-link. Is there some address I'm not setting right in the server? Is there anything I have to do in the Apache module?
Jim
My guess is that you don't have the right ports open on the linksys router, or the router is assinging you a new IP adress. The static IP that you get from earthlink is probably taken by the router, and than the router passes a new IP to the computer. Either way, the problem is probably in the linksys router.

Almost all of the new linksys routers have build in firewalls, you will need to go into the configuration panel for the router and open up the incomming ports so that requests will get through.
hughesjr
What you want to do is probably called port forwarding in the router guide....

Here is an FAQ for a LinkSys router:

http://www.linksys.com/support/top10faqs/b...a%20BEFSR41.asp
mrdee27
QUOTE (hughesjr @ Apr 15 2004, 06:56 PM)
What you want to do is probably called port forwarding in the router guide....

Here is an FAQ for a LinkSys router:

http://www.linksys.com/support/top10faqs/b...a%20BEFSR41.asp

Ah, but I already have all the necessary ports forwarded. I even tried DMZ. The router is 192.168.1.1 - the server is - 1.9, which is below the DHCP limit (this is what Linksys said to do.) I've forwarded ports 80, 21,23,10000, 1720, 443 to the 1.9 address. I've turned off the firewall. I've done just about everything I can with the router. I've called Linksys, they tell me it's Earthlink. E/L tells me it's Linksys. I've exchanged the router.
So, I'm convinced it's the Linux. I'm least familiar with those settings.
There must be something in the Network configuration setting - interface or routing and gateways.
My web page is in the /Home directory. Do I have to make any settings in Apache to tell it where the index files are?
Also, I'm not sure what my default route and local routes settings should be.
hughesjr
OK ... the first thing I would try is to turn off iptables on the Linux machine ... it is a firewall.

The command to try this is:

/etc/init.d/iptables stop

then make sure httpd is running with this command:

/etc/init.d/httpd start

then try to access the website from outside ... it should give you the default apache page.
------------------------------------------------
You said you have linux ver 9 server ... does that mean RedHat Linux 9? If so, as root, run this command:

redhat-config-securitylevel and open http (and ssl if required) to the server.

Also you will need either move your website pages to /var/www/html OR change the info in /etc/httpd/conf/httpd.conf for:

DocumentRoot "/var/www/html"

to where your website starts....
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.