Help - Search - Members - Calendar
Full Version: Found A Possible Network Monitoring Tool
Linuxhelp > Support > Technical Support
Robert83
Hi,

I found something that should be able to monitor download / upload per IP adress
the website can be found here

I have installed mrtg with apt-get install mrtg
I have installed net-snmp with apt-get install net-snmp, and I've configured it, with public private [should be good enough for LAN, or maybe not[?]]
my snmpd.conf
CODE
####
# First, map the community name "public" into a "security name"

#       sec.name  source          community
com2sec local     localhost       private

####
# Second, map the security name into a group name:

#       groupName      securityModel securityName
group   privateGroup   any           local

####
# Third, create a view for us to let the group have rights to:

# Make at least  snmpwalk -v 1 localhost -c public system fast again.
#       name           incl/excl     subtree         mask(optional)
view    systemview    included   .1.3.6.1.2.1.1
view    systemview    included   .1.3.6.1.2.1.25.1.1
view    all           included   .1                  80

####
# Finally, grant the group read-only access to the systemview view.

#       group          context sec.model sec.level prefix read   write  notif
access  privateGroup   ""      any       noauth    0      all    all    all


And I've started taking the steps here http://www.snert.com/Software/mod_watch/#Installation

And ran into the following problem, and don't know howto resolve it
CODE
[root@demon mod_watch-4.3]# make -f Makefile.dso install
/home/apache2/bin/apxs -c  -DSTATEDIR='"/var/lib/mod_watch/"'  mod_watch.c
make: /home/apache2/bin/apxs: Command not found
make: *** [mod_watch.lo] Error 127


I don't have a /home/apache2/bin/apxs , but I do have apache2 installed, how to locate this file where to change
the path in Makefile.dso?

Can anyone help me with this, if this works the way it is said to , it would be a superb network monitoring tool for watching up download per client IP adress


Sincerely
Robert B
chrisw
it should be apxs2 for apache2

look for that

then try to recompile mod_watch

when i compile a module i usually do it this way
cd to where module is and do the following:

/path/to/apxs -c mod_foo.c
/path/to/apxs -i -a -n foo mod_foo.so

but first you need to see if there is apxs2 instead of apxs
Robert83
Hi,

thanx the problem was solved, I downloaded httpd-devel [with apt-get], I got past that step , but here is another
that made me stop again

CODE
cd (path to)/apache_2.0.43
mkdir -p modules/com/snert
mv (path to)/mod_watch-4.3 modules/com/snert/watch
./buildconf      # This step can take a long time.
./configure
   --enable-watch=static
   ... (your other configuration options) ...
make install


I copied the mod_watch-4.3 to /etc/httpd/modules/com/snert
and when I type ./buildconf
I get a error
CODE
[root@demon watch]# ./buildconf
bash: ./buildconf: No such file or directory


what to do?


Sincerely
Robert B
Robert83
Hi,

I've setup MRTG to work, it goes ok when I run the cfgmaker for 127.0.0.1
but when I try to do the same for 192.168.0.102 it wont work, this is normal? [see my snmpd.conf file above]


And please can anyone help me with that configuration for snert, I don't know what to do?

Sincerely
Robert B
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.