Help - Search - Members - Calendar
Full Version: Nvidia Unified Driver
Linuxhelp > Support > Technical Support
Ok, so I never installled the unified driver on my new Manrake system. I only ever installed the video drivers. I didn't ever bother with the unified driver before my NIC card and audio were working fine, or so I thought.

I need to install the NVIDIA unified driver so I can get my sound working the way its suposed to. It works more or less, somethings read it, every now and than somethign doesn't, but I usualy just reload the module and it works fine.

So I tried installing the unified driver from NVIDIA using the source tar.gz and this is what I get.
[root@x nforce]# make install
make -C  nvnet install
make[1]: Entering directory `/home/jim/nforce/nvnet'
mkdir -p //lib/modules/2.6.3-7mdk/kernel/drivers/net
install -b -m 644 -o root nvnet.o //lib/modules/2.6.3-7mdk/kernel/drivers/net
install: cannot stat `nvnet.o': No such file or directory
make[1]: *** [install] Error 1
make[1]: Leaving directory `/home/jim/nforce/nvnet'
make: *** [nvnet_install] Error 2
[root@x nforce]#

What am I doing wrong, I followed the NVIDIA readme exactly, I am guessinng its a problem with either Mandrake 10 or the new 2.6 kernel. Any ideas?

so you have the same kernel source as your current kernel version ?
you removed "custom" from the Makefile ?
your network card is enabled in bios ?

you did it like this

1.make mrproper
2.cp /boot/config-kernel-version /usr/src/linux-kernel-version/.config
3.make oldconfig
4.make dep /home/nvidia/nforce
7.make install

it should work
just make sure that the Makefile [/usr/src/linux-kernel-version] does not containt custom after the kernel version

Robert B
I got the same error again. Did everything, it all worked, untill I did the make install in the nforce folder. Any other ideas?
I don't have one of these boards to test this on, but the Nforce 2 drivers are supposed to be built into the 2.6 kernel. You shouldn't need the unified driver...

There is a module named i2c-nforce2 ... see if that is loaded via the command:

(that is a lowercase L)

What is the sound and network drivers you have listed in /etc/modules.conf?
First off, let me start by saying I think there is something screwed up with my modules.conf file. I tried changing it the other day and it screwed up, so I put my back up back in place and now it doesn't load my nvidia video modules at start. I tried adding it back in, but it doesn't seem to want to work.

My current modules.conf file looks like this

probeall usb-interface usb-ohci ehci-hcd
alias sound-slot-0 snd-intel8x0
probeall scsi_hostadapter imm ppa
above snd-intel8x0 snd-pcm-oss
alias eth0 3c59x

It is using the snd-intel8x0 modules to run sound, which is suposed to be compatible with the nvidia audio chipset. However, it doesn't work at start up like it should, I have to monkey with it, and some programs don't recognize it, namely xmms and kmix.
That is probably because the system is using ALSA sound ... but the OSS emulator isn't loaded ... try adding this to the bottom of modules.conf:

alias char-major-14 soundcore
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
How come my problems are never simple fixes? I added the lines and it didn't work. It actually crashed the first time I booted, but now it works fine.

Sound still wont work unless I go into harddrake, change the audio driver, and than change it back to snd-intel8x0. Than sound will work in things like xine and totem, but not xmms. xmms gives me the error
Please check that:
Your soundcard is configured properly
You have the correct output plugin selected
No other program is blocking the soundcard.

I could live with out xmms, although I would like it, and the problem very well may just be with xmms, but sound doesn't load on start up for anything. Both totem and xine wine and cry if I try to play something before I funk around with the drivers.

So whats the next idea?
Ok, I am stupid (check the time difference in these posts) I got xmms working, but sound still doesn't work on boot. Thats still what needs to be fixed.
is i2c-nforce2 running? .... do:

it wasn't so I added i2c-nforce2 and i2c-core to my modules file so they will load on boot, and nothing happened. It didn't load. So I just tried loading them with modprobe and it didn't help either. Maybet they weren't suposed to be loaded, I don't know. All I I did was suceded in knocking out my X system.

Does mandrake keep something things in different files that they shoud? Because I just had to type modprobe nvidia to get the X system working again, but nvidia is usually loaded at start up. So even with it in the mdoules file it doesn't load at start up. Am I totally wack or isn't that where modules you want start and the begning go? Just a thought.
OK ... the i2c-nforce2 doesn't have to load for the sound card (sorry) smile.gif ... it is ok to load it though.
for the 2.4 kernel use the /etc/modules file to load modules ... for the 2.6 kenerl, use /etc/modprobe.preload
I have a sound blaster pro and here is what is in my modules.conf to make it work in mandrake 10:
above snd-emu10k1 snd-pcm-oss
alias sound-slot-0 snd-emu10k1

and here is what is in my modprobe.conf:
alias sound-slot-0 snd-emu10k1

install snd-emu10k1 /sbin/modprobe --first-time --ignore-install snd-emu10k1 && { /sbin/modprobe snd-pcm-oss; /bin/true; }

remove snd-emu10k1 { /sbin/modprobe -r snd-pcm-oss; }; /sbin/modprobe -r --first-time --ignore-remove snd-emu10k1
So I added the line nvidia to my modprobe.preload file and now at least my X is working right.

Heck ya, and than I added the line snd-intel8x0 to it as well and now sounds works at start up.

Ok, so now I just a quick question thats sort of unrelated. Is it a bad idea for me to read my MP3s of my NTFS drive all the time? I mean I run music pretty much constantly wile I am at my computer, and I just want to know if its going to be problematic to be loading it of my NTFS drive all the time. Thanks.
It shouldn't be a problem to read from an NTFS drive. The 2.6 kernel even has the ability to write to NTFS drives ... but the write capability is fairly limited, and not really ready for regular use.

I would just make sure that the mount is done read only if NTFS write is enabled in your kernel.

In the kernel .config file, it is the value:


that sets NTFS write ... in the standard Mandrake kernel it is turned off.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.