I've made a htpc out of some old junk(t-bird 1.4, gf2 mx, 10gb hdd). Ok, I thought, fedora is simple and I already got it on a dvd somewhere and gentoo(which I usually use) takes too long time to install, pluss I'd found some mythtv rpm's. I installed it and the nvidia drivers, edited the XF86Config file so it could handle the TV(hz, resolution etc). Plugged in the s-video cable and bang, just flimmer, didn't work. Looked like it was something with the refresh rate, I went through the XF86Config file again, searching for erros, and added some new options. Still didn't work. Took the gf4mx card from my server and tried, same problem.
Then I wiped away fedora and installed slackware, still the same problem. I downloaded knoppmyth, and it still didn't work, even if I started with the tv setting. Ok, now it must be the TV I thought and deleted everything and installed win2k just to test, plugged in the cable, and everything worked perfectly.

I can of course run windows, but my goal is to run linux with mythtv since it's much easier to configure to my needs.

But why? why can't linux handle my tv? (thomson 28" widescreen)