Help - Search - Members - Calendar
Full Version: Lilo Problems
Linuxhelp > Support > Technical Support
Ax3
I'm having a somewhat common problem with Slackware7.1(Outdated... I know). I have my partitions set up as follows:
(I kept them all under the 1024th cylinder to keep LILO happy.)

/dev/hda1 linux native (/)
/dev/hda2 HPFS/NTFS (win xp)
/dev/hda3 swap
/dev/hda4 linux native (/usr)

I've tried installing LILO to the root partition and making it bootable, I've tried putting it on the MBR, I've tried using the Windows boot manager(pressin F8, selecting the OS) linux doesn't even show up. All I keep getting is an error saying that LILO isn't installing. What am I doing wrong??? (I'm starting to think I have a bad copy.) Should I put Windows on /hda1? I'm doing all this on a Dell laptop. The only a: I have is an external one so I can't even make a boot disk. Any segestions?? Anyone??? I'm desperate for help, and any is greatly appreciated!! Also... whats up with FAT32? It sounds nice to be able to trade files between my two OS's(would save me alot of memory.) Can I do this? If so should I make this an extended partition? What do I "mount" it as???
chrisw
if i remember correctly...if your partition for windows is ntfs linux cannot install lilo in the mbr because writing to an ntfs partition is dangerous from linux....you might try putting it on the first sector of the partition you are installing linux to....its the other option besides installing it to the mbr...i dont remember the wording exactly for the other option....also please make a bootdisk also that way you can at least boot with the disk if the other option of booting without a bootdisk doesnt work..
Ax3
Thanks for your reply, but I already tried to install LILO in the root partition... it wont work. I keep getting either "error #1" or "error #38". I have no idea what either of these mean.
chrisw
i know it wont install....but will it install using the other option...
The other way to install lilo is this way, is to install the bootloader in a partition where you installed Linux, not in the master boot record (MBR). There should be another option during the install, to setup lilo in such a way.
Ax3
Dude I tried that... I've tried evey possible option I can think of. It won't install period. Not to MBR or the root partition. Today I went back and wiped the drive clean. I wanted to see if I could get slackware running as the only OS. Still no luck. LILO WILL NOT install. I keep getting that dreadfull "error #1. What does it mean any way?

Quick question... If I delete(not create) Windows partitions with the fdisk command, or visa versa, could I mess anything up?? Would this be contributing to my problem?
chrisw
the next thing to do is do a search on google for the error you are getting....i have never gotten that error so im not exactly sure what could be causing it
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.