Help - Search - Members - Calendar
Full Version: Kernel Panic
Linuxhelp > Support > Technical Support
neax
hi guys and gals,

I just built a new computer, and installed red hat 9.

Upon rebooting the system, it came up with the message:

<0> Kernel panic : attempted to kill init!

Thinking that i may have screwed up the install, i reinstalled red hat. No luck.

I tried loading with the boot disk, still no luck.

Anybody seen this before? Any feedback would be greatly appreciated.
Jim
Ok, let me guess, Soyo motherboard on board RAID? Ok, well even if I am wrong about the mother board I am going to guess on board RAID. (Look at my signature and you will understand a little).

What ever it is, I will put money on it being a hard drive issue. Tell me what drives you have plugged in, where and whats on them. Also tell me if I am right about the RAID and what kind of motherboard and chip set you have and I might be able to help you.
hughesjr
Normally hard drive raid ... or the initrd image doesn't have the driver in it for the root partiton file type.
neax
it's a gigabyte socket A GA-7VT600-P(-L) motherboard, that *does* have onboard RAID, which I am not using.

I have one hard drive, seagate 120gb IDE, connected as primary master, one 24X Diamond CD-ROM as primary slave, one generic FDD.

When i tried reinstalling it, i managed to catch one of the messages that came through the initialisation stuff :

e2-fs checktime reached : recommend running e2fsck


I greatly appreciate any feedback anybody has.
Jim
If your not using your RAID go into the BIOS and turn it off. See if that will do it. I think it might. If it doesn't ..... humm.... Put in your Red Hat disks and when you get that first prompt type rescue. If that works that we know its a problem with your install. If it doesn't than we should know its a hardware issue.
neax
I couldn't find anything in the BIOS about RAID, however in the windows drivers package that came with the motherboard is something about RAID; I now have a 'VIA RAID tool' icon in my taskbar with windows.

To extend on the error message that it's giving me is the following:

*pde : 00000000
Oops : 0000

CPU : 0
EIP : 0060 [<c010ab2c>] Not tainted
EFLAGS : 00010002
EIP is disabled at disable_irq [kernel] 0x4c (2.4.20-6)

code : ff 50 10 eb d0 eb 0d 90 90 90 90 90 90 90 90 90 90 90 90 90

<0> kernel panic : Attempted to kill init!


when i go into red hat rescue mode, i'm able to get to the shell prompt and throw commands at it. I tried the e2fsck command, as recommended during the install, but had little luck.. i tried unmounting the partitions (umount /dev/hda1 etc) but wasn't able to.

Have i been foolish with the install? As you could probably tell, i'm just a newbie who only knows what he's managed to find through google, and a SAMS linux manual.

Once again, I appreciate any help given.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.