Help - Search - Members - Calendar
Full Version: Second Hard Drive Issue
Linuxhelp > Support > Hardware Support
hohner
Hi,

I have Redhat 9 installed on my pc, I also have a second hdd installed which was previously used with windows and is formatted using NTFS.
This second drive is purely for data and as such has no operating system installed.
I would like to access this drive from Linux but as I'm a newbie I have no idea how to go about it.
I know you have to mount drives, I have tried but not sure if I tried correctly... it returned the drive is already mounted.
I'm pretty confused as to what to do, I'd like to learn more about Linux as I don't want to have to return to Windows.

Thanks in advance
Jim
If the drive was in the computer when you installed Red Hat it is probably automatically mounted for you at each boot.

Go to your /mnt folder and it should be in there somewhere. I don't know how Red Hat assings names so I can't tell you exactly where.

If you want it to be loaded somewhere else, you will need to edit your fstab file. For help with that come back and ask.
hohner
Thanks for replying so soon....

I went to /mnt but there are only two items there... cdrom and floppy.
Perhaps the second hdd is not mounted? If not how would I go about mounting it?

Thanks
hohner
I have ran the hardware browser and the hdd is listed as /dev/hdb so I would assume it is mounted already? I was present during installation of Linux Redhat9
Jim
your slave drive on the first IDE channel is usually refered to as hdb.

To mount the drive first make a folder to mount it to
# mkdir Slave or what ever
than
# mount /dev/hdb /mnt/slave

That should work, if it tells you that its mounted already post your fstab file. You can find it in /etc from there I can tell you where its mounted.
hohner
I created the slave directory, then tried to mount using the command line you supplied but it said I must specify file system type..

here is the fstab..
LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hda3 swap swap defaults 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0


I tried the following command line... [root@localhost root]# mount -t ntfs /dev/hdb /root/slave
but it returned ntfs not supported by kernal.
thanks again
hughesjr
OK ... you put an NTFS drive in the system.

RedHat doesn't read NTFS drives. You have to install kernel modules to read NTFS drives ... but you won't be able to write to the ntfs drive.

Does this drive need to be NTFS, or do you want to truly use it for linux?

If you want to use it for linux, you have to partition it with fdisk, then create a file system on the drive. (Anything on the drive will be lost when you do this).

SO ... do you need to read the NTFS info off the drive, or do you want to make it just a second drive for linux to use?
hohner
well, I was hoping to leave the drive as a ntfs and access the data with linux. However I've been reading a lot of tutorials and I've tried various suggestions. I have altered the partition table so I think I've probably lost all the data on it now anyway.
hohner
Well, I think I've really messed up my hard drive, my computer reports it as being a 32G hdd when it should be a 40G. Just so happens that there was approx. 8G of data on it prior to the partition table mess up. I've tried fdisk and numerous hdd managing programs but I can't restore it to it's original size.
Does anyone have any suggestions?
hughesjr
Your shouldn't be able to do anything to the drive via the partition table that will mess up the bios detection.

Make sure you have the BIOS set for AUTO size detection and it should be OK ... if you remove all partitons in fdisk and add some new linux partitons, you should be OK.
hohner
My bios is set to auto. I have even tried a low level format utility but it still only detects the drive as being 33GB instead of 40G.
hughesjr
Are you positive that it used to show up as 40gb?

I can see 40gb (40,000,000,000 bytes) being about 36 gb if you divide by (1024*1024*1024) instead of (1000*1000*1000) .....
Jim
Drives are rarely ever extly what they say they are on the box. If you read the box when you buy a 40 gig hard drive it will probably tell you that the actual size is somewhere around 35 gigs, or less.

If you have altered the partition table its probably going to be very difficult to recover the data. You may be able to revocer the data using tools that try to recover the original partition table. However, I only know of these tools, not how to use them. Try the Ultimate Bootdisk hit google, you will find it. It has tools for browsing NTFS drives and attempting to restore data and partition tables. Best of luck.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.