Help - Search - Members - Calendar
Full Version: Sound Card Doesn't Work
Linuxhelp > Support > Technical Support
ok normally my sound works fine but one day it just stopped working this is what i got

SNDCTL_DSP_SETFRAGMENT: Inappropriate ioctl for device
Audio device open for 44.1Khz, stereo, 16bit failed
Trying 44.1Khz, 8bit stereo.
SNDCTL_DSP_SETFRAGMENT: Inappropriate ioctl for device
Audio device open for 44.1Khz, stereo, 8bit failed
Trying 48Khz, 16bit stereo.
SNDCTL_DSP_SETFRAGMENT: Inappropriate ioctl for device
Audio device open for 48Khz, stereo,16bit failed
Trying 22.05Khz, 8bit stereo.
SNDCTL_DSP_SETFRAGMENT: Inappropriate ioctl for device
Audio device open for 22.05Khz, stereo, 8bit failed
Trying 44.1Khz, 16bit mono.
SNDCTL_DSP_SETFRAGMENT: Inappropriate ioctl for device
Audio device open for 44.1Khz, mono, 8bit failed
Trying 22.05Khz, 8bit mono.
SNDCTL_DSP_SETFRAGMENT: Inappropriate ioctl for device
Audio device open for 22.05Khz, mono, 8bit failed
Trying 11.025Khz, 8bit stereo.
SNDCTL_DSP_SETFRAGMENT: Inappropriate ioctl for device
Audio device open for 11.025Khz, stereo, 8bit failed
Trying 11.025Khz, 8bit mono.
SNDCTL_DSP_SETFRAGMENT: Inappropriate ioctl for device
Audio device open for 11.025Khz, mono, 8bit failed
Trying 8.192Khz, 8bit mono.
SNDCTL_DSP_SETFRAGMENT: Inappropriate ioctl for device
Audio device open for 8.192Khz, mono, 8bit failed
Trying 8Khz, 8bit mono.
SNDCTL_DSP_SETFRAGMENT: Inappropriate ioctl for device
Sound device inadequate for Esound. Fatal.

can someone help me please ? I have an intergrated sound card and
this is my modprobe.conf

include /etc/modprobe.conf.dist
alias eth0 8139too

but this is my modprobe.conf.dist
# default modutils aliases
alias binfmt-204 binfmt_aout
alias binfmt-263 binfmt_aout
alias binfmt-264 binfmt_aout
alias binfmt-267 binfmt_aout
alias binfmt-387 binfmt_aout
alias binfmt-332 iBCS
alias binfmt--310 binfmt_java
alias block-major-1 rd
alias block-major-2 floppy
alias block-major-3 ide-probe-mod
alias block-major-7 loop
alias block-major-8 sd_mod
alias block-major-9 md
alias block-major-11 sr_mod
alias block-major-13 xd
alias block-major-15 cdu31a
alias block-major-16 gscd
alias block-major-17 optcd
alias block-major-18 sjcd
alias block-major-20 mcdx
alias block-major-22 ide-probe-mod
alias block-major-23 mcd
alias block-major-24 sonycd535
alias block-major-25 sbpcd
alias block-major-26 sbpcd
alias block-major-27 sbpcd
alias block-major-29 aztcd
alias block-major-32 cm206
alias block-major-33 ide-probe-mod
alias block-major-34 ide-probe-mod
alias block-major-37 ide-tape
alias block-major-44 ftl
alias block-major-46 pcd
alias block-major-47 pf
alias block-major-56 ide-probe-mod
alias block-major-57 ide-probe-mod
alias block-major-58 lvm-mod
alias block-major-88 ide-probe-mod
alias block-major-89 ide-probe-mod
alias block-major-90 ide-probe-mod
alias block-major-91 ide-probe-mod
alias block-major-93 nftl
alias block-major-97 pg
alias block-major-113 viocd
alias char-major-4 serial
alias char-major-5 serial
alias char-major-6 lp
alias char-major-9 st
alias char-major-10-0 busmouse
alias char-major-10-2 msbusmouse
alias char-major-10-3 atixlmouse
alias char-major-10-130 wdt
alias char-major-10-131 wdt
alias char-major-10-135 rtc
alias char-major-10-139 openprom
alias char-major-10-144 nvram
alias char-major-10-157 applicom
alias char-major-10-175 agpgart
alias char-major-10-184 microcode
alias char-major-10-200 tun
alias char-major-10-250 hci_vhci
alias char-major-13 input
alias char-major-13-0 joydev
alias char-major-13-32 mousedev
alias char-major-14 soundcore
alias char-major-19 cyclades
alias char-major-20 cyclades
alias char-major-21 sg
alias char-major-22 pcxx
alias char-major-23 pcxx
alias char-major-27 zftape
alias char-major-34 scc
alias char-major-35 tclmidi
alias char-major-36 netlink
alias char-major-37 ide-tape
alias char-major-48 riscom8
alias char-major-49 riscom8
alias char-major-57 esp
alias char-major-58 esp
alias char-major-63 kdebug
alias char-major-90 mtdchar
alias char-major-96 pt
alias char-major-99 ppdev
alias char-major-107 3dfx
alias char-major-108 ppp_generic
alias char-major-109 lvm-mod
alias char-major-161 ircomm-tty
alias char-major-171 raw1394
alias char-major-195 NVdriver
alias char-major-200 vxspec
alias char-major-206 osst
alias char-major-216 rfcomm
alias dos msdos
alias dummy0 dummy
alias dummy1 dummy
alias iso9660 isofs
alias md-personality-1 linear
alias md-personality-2 raid0
alias md-personality-3 raid1
alias md-personality-4 raid5
alias md-personality-7 multipath
alias net-pf-1 unix
alias net-pf-2 ipv4
alias net-pf-4 ipx
alias net-pf-5 appletalk
alias net-pf-15 af_key
alias net-pf-17 af_packet
alias net-pf-31 bluez
alias netalias-2 ip_alias
alias irlan0 irlan
alias irda-dongle-0 tekram
alias irda-dongle-1 esi
alias irda-dongle-2 actisys
alias irda-dongle-3 actisys
alias irda-dongle-4 girbil
alias irda-dongle-5 litelink
alias irda-dongle-6 airport
alias irda-dongle-7 old_belkin
alias bt-proto-0 l2cap
alias bt-proto-2 sco
alias bt-proto-3 rfcomm
alias bt-proto-4 bnep
alias plip0 plip
alias plip1 plip
alias tunl0 ipip
alias cipcb0 cipcb
alias cipcb1 cipcb
alias cipcb2 cipcb
alias cipcb3 cipcb
alias ppp0 ppp
alias ppp1 ppp
alias slip0 slip
alias slip1 slip
alias tty-ldisc-1 slip
alias tty-ldisc-3 ppp_async
alias tty-ldisc-11 irtty
alias tty-ldisc-14 ppp_synctty
alias tty-ldisc-15 hci_uart
alias ppp-compress-18 ppp_mppe
alias ppp-compress-21 bsd_comp
alias ppp-compress-24 ppp_deflate
alias ppp-compress-26 ppp_deflate
alias parport_lowlevel parport_pc
alias usbdevfs usbcore
alias xfrm-type-2-50 esp4
alias xfrm-type-2-51 ah4
alias xfrm-type-2-108 ipcomp
alias xfrm-type-10-50 esp6
alias xfrm-type-10-51 ah6
alias xfrm-type-10-108 ipcomp6
alias cipher_null crypto_null
alias digest_null crypto_null
alias compress_null crypto_null
alias sha384 sha512
options sb io=0x220 irq=7 dma=1 dma16=5 mpu_io=0x330
install binfmt-0000 /bin/true
install binfmt_misc /sbin/modprobe --ignore-install binfmt_misc && { /bin/mount -t binfmt_misc none /proc/sys/fs/binfmt_misc > /dev/null 2>&1 || :; }
install char-major-10 /bin/true
install char-major-10-1 /bin/true
install dummy0 /sbin/modprobe -o dummy0 --ignore-install dummy
install dummy1 /sbin/modprobe -o dummy1 --ignore-install dummy
install eth0 /bin/true
install hid /sbin/modprobe --ignore-install hid && { /sbin/modprobe keybdev; /sbin/modprobe mousedev; /bin/true; }
install net-pf-10 /bin/true
install net-pf-19 /bin/true
install net-pf-3 /bin/true
install net-pf-6 /bin/true
install ov518_decomp { /sbin/modprobe ov511; } ; /sbin/modprobe --ignore-install ov518_decomp
install scsi_hostadapter /bin/true
install usbmouse /sbin/modprobe --ignore-install usbmouse && { /sbin/modprobe hid; /bin/true; }
install wacom /sbin/modprobe --ignore-install wacom && { /sbin/modprobe evdev; /bin/true; }
remove binfmt_misc { /bin/umount /proc/sys/fs/binfmt_misc > /dev/null 2>&1 || :; } ; /sbin/modprobe -r --ignore-remove binfmt_misc
remove hid { /sbin/modprobe -r keybdev; /sbin/modprobe -r mousedev; } ; /sbin/modprobe -r --ignore-remove hid
remove ov518_decomp /sbin/modprobe -r --ignore-remove ov518_decomp && { /sbin/modprobe -r ov511; /bin/true; }
remove usbmouse { /sbin/modprobe -r hid; } ; /sbin/modprobe -r --ignore-remove usbmouse
remove wacom { /sbin/modprobe -r evdev; } ; /sbin/modprobe -r --ignore-remove wacom

so i would be vert glad if anyone could help me

what kindo of a intergrated sound card do you have?

what does lspci(I think, sorry writing from a WinXP computer) show?

Robert B
thnx for the fast response
im using a 845GE integrated sound chipset.
this is what i get when i type lspci :
00:00.0 Host bridge: Intel Corp. 82845G/GL[Brookdale-G]/GE/PE DRAM Controller/Host-Hub Interface (rev 03)
00:01.0 PCI bridge: Intel Corp. 82845G/GL[Brookdale-G]/GE/PE Host-to-AGP Bridge (rev 03)
00:1d.0 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #1 (rev 02)
00:1d.1 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #2 (rev 02)
00:1d.2 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #3 (rev 02)
00:1d.7 USB Controller: Intel Corp. 82801DB (ICH4) USB2 EHCI Controller (rev 02)00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB/EB/ER Hub interface to PCI Bridge (rev 82)
00:1f.0 ISA bridge: Intel Corp. 82801DB (ICH4) LPC Bridge (rev 02)
00:1f.1 IDE interface: Intel Corp. 82801DB (ICH4) Ultra ATA 100 Storage Controller (rev 02)
00:1f.3 SMBus: Intel Corp. 82801DB/DBM (ICH4) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corp. 82801DB (ICH4) AC'97 Audio Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation NV17 [GeForce4 MX 440] (rev a3)
02:0a.0 ATM network controller: STMicroelectronics ST70137 [Unicorn] ADSL DMT Transceiver (rev 10)
02:0b.0 Communication controller: Conexant HSF 56k HSFi Modem (rev 01)
02:0c.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
02:0d.0 FireWire (IEEE 1394): NEC Corporation: Unknown device 00f2 (rev 01)
I hope that you can do something with this.


To enable the onboard audio for the Intel® 845G/GL Chipset go to the following URL and follow these instructions. URL: File Name: oss397b-linux-v2x.tar.gz Instructions: 1. Select Download from the left column. 2. In the search string type "Intel ich4" 3. Keep the default O/S selection. 4. Press "Submit". 5. Select "Click here to download OSS for Linux 2.2.x/2.4.x (x86)". 6. Download to a folder of your choice. 7. Once the download is complete "cd" to your download folder and complete these steps: a. Uncompress file: tar -xvf oss397b-linux-v2x.tar b. Run installation ./oss-install c. Follow the remaining instructions. d. Reboot e. at the command console type: "soundconf" f. Enable OSS to load at boot time. g. Save and Exit. h. Reboot to O/S/Xwindows. Audio is now fully configured.

Robert B
It said that it haven"t found any precompiled modules for my kernel version ( im using fedora core 1 kernel version 2.4.22-1.2174) There weren't available modules to donwload so what should i do unsure.gif
thnx for the help


you must download the kernel source [same version as your current kernel]

apt-get install kernel-source , and select the kernel source that matches you kernel version number.

Robert B
It worked !!! biggrin.gif biggrin.gif biggrin.gif thnx for your time
correction It worked for a time but then it said 20 minute evalution time has elapsed please reload the driver
can you help me?

Hi...i have the same..chipset and my sound card is working fine...
I won't suggest using OSS drivers..Rather why not try alsa...
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.