I would appreciate any help that can given regarding the following issue:

I run a small school network and use red hat 8.0 as the OS for the firewall box. It uses IPTABLES and two nics (realtek) and an adsl modem. It has been working very well for some months and yesterday both nics became unable to be pinged either from inside the LAN or from the internet. The adsl modem was switched to another machine and reconnected with no issues. All switch gear between the friewall and the network was removed and a single known good unit used to connect to my my laptop. Neither the laptop (known to be stable) or the firewall could ping the other.

IFCONFIG reveals that both nic interfaces are up and correctly configured as is the adsl connection.

We have even tried swapping the HDD tgo another identical machine knwon to have a good hardware set. As a linux newbie I am left with the conclusion that there is some OS daemon not running which is required and yes I have shutdown and restarted as per a good windows instal.

Any help here would be most greatfully received.

regards to all,
Duncan