Help - Search - Members - Calendar
Full Version: Installing Ati Driver Mandrake 10
Linuxhelp > Support > Technical Support
simonau
I have download ati driver for my radeon 8500 but when I try to install it I get the following message.

file /usr/X11R6/lib/libGL.so.1.2 from install of fglrx-4.3.0-3.7.6 conflicts with file from package libxfree86-4.3-30mdk

After reference to ATI website I try rpm -Uh --force fglrx-4.3.0-3.7.6.i386.rpm
with the follown errors
error: cannot open lock file ///var/lib/rpm/RPMLOCK in exclusive mode
error: cannot open Packages database in /var/lib/rpm

Please help this noob

I have mandrake 10
Hemant
You are using what version of linux...you will have to update your rpm database..before doing any installtion...
Robert83
Hi,

you are doing this drive installation as root right?

Sincerely
Robert B
simonau
Am doing istalation as root
Am using Mandrake 10 download edition.
How do I update rpm database ?
Thanks
Jim
Read this thread

http://www.linuxhelp.ca/forums/....

That updates all the packages, now run these commands to get the kernel
CODE
# wget http://mirrors.usc.edu/pub/linux/distributions/mandrake-devel/stable/i586/Mandrake/RPMS/kernel-2.6.3.7mdk-1-1mdk.i586.rpm

# rpm -Uvh kernel-2.6.3.7mdk-1-1mdk.i586.rpm

# wget http://mirrors.usc.edu/pub/linux/distributions/mandrake-devel/stable/i586/Mandrake/RPMS/kernel-source-2.6.3-7mdk.i586.rpm

# rpm -Uvh kernel-source-2.6.3-7mdk.i586.rpm


Now you have both the latest kernel, and kernel source. Reboot into the new kernel and try again.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.