Help - Search - Members - Calendar
Full Version: Via Chipset & 2.6
Linuxhelp > Support > Technical Support
Jim
So installing chipset drivers seems to just be my thing. This time I am trying to install the chipset drivers for a VIA system. Specifically a VIA KT600 / 8237 chipset. So I tried, for about the last three hours to do it. I downloaded some drivers, and tried to follow the directions, but it didn't seem to work.

So nothing is working now, especially the onboard NIC which is probably the most important thing. The sight I found that had the drivers had them all brokem up, video, lan, usb, what ever. So if someone could point me twords a sight with the VIA drivers on them, and a quick hint on how to get them installed that would be great.

Thanks a ton.

O ya, note, this is with 2.6.3-7mdk.
Hemant
I really doubt...the drivers..you have downloaded is for kernel...2.6
Robert83
Hi,

So you got the same kernel source , removed the "custom" from the Makefile [in the kernel source dir]...and it still wont do it?

1.make mrproper
2.copy the config file from /boot to /usr/src/linux-xxxx-xxxx
3.make oldconfig
4.make dep
5.cd drivers dir
6.make install [or something]


Sincerely
Robert B
Jim
Idealy is your compiling the drivers from source code it shouldn't matter what kernel you have. Ya I moved the files to the directory and tried the make file and all sorts of wierd crap and it didn't seem to want to work.

I don't know.
hughesjr
OK,

I downloaded the source file rhinefet.tgz (the ethernet driver VT8237 southbridge chips) and I can build it fine on 2.4.x kernels (I built it on 2.4.21 Whitebox, 2.4.22 FedoraCore, 2.4.20 RedHat 9) ... I can not get it to build on 2.6.4 gentoo kernel.

My other PC with 2.6 kernels (Mandrake 10, Debian SID) is busy rihgt now with a Gentoo install. When I get a chance, I will see if I can build it on a 2.6 kernel.

There are differences in the include structures between 2.4 and 2.6 kernels ... so lots of source code that builds under 2.4 kernels won't build on a 2.6 Kernel.

I can't find any 2.6 specific code for that NIC....but I'll look again later.
Jim
Screw it, I am taking him back to 2.4 right now. So if you could just tell me how to get it installed on 2.4 that would be awsome. Sorry if you spent the time figuering out 2.6 already. We ran into a couple other problems and I think its just best to stay at 2.4 for now. That will teach me to upgrade with out keeping the old version around. Ok. Thanks. Sorry again if you already figuered it out.
hughesjr
Download any of the Linux Ethernet files for the VT8237 SouthBridge from this page (I did the FedoraCore1 file...it had the latest date).

Create a temp directory and untar the file.
-------------------------
To make it work with 2.4.x kernel, make sure you have the kernel source installed and prepared....

Install kernel source

edit /usr/src/linux-xxxx/Makefile and remove the custom from the EXTRAVERSION= line

do (from within /usr/src/linux-xxxx/)

make mrproper

copy the config-xxxxx file from /boot to .config (in /usr/src/linux-xxxx/)

make oldconfig

make dep

now go to /usr/src

copy the file rhinefet.tgz from the temp directory where you untarred it to /usr/src

tar -xvzf rhinefet.tgz

cd rhinefet

make

make install


Then follow the instructions in the linux.txt file in the rhinefet to make it work....(insmod rhinefet).

If it works, add the line:

alias eth0 rhinefet

to /etc/modules.conf.
Jim
So I went through all the mumbo jumbo and didn't get any errors. Rebooted, and started her up and it doesn't seem to want to work. Now I am getting the error
QUOTE
ismod'ing module via-rhine failed at /us/lib/libDrakeX/modules.pm line 61


Of course line 61 is useless because its just the output code for the error message. So I don't know what to do. I am a little concerned that I didn't get rhinefet.o comiled correctly because the instructions say to compile to driver files to make rhinefet.o but I couldn't figuer out how to do that so I just used the generic one that was there.

I am going to go try again and see what happens, but I don't think that will work. I am running low on ideas. On the bright side, it fails right away during the boot up sequence which is nice because it saves me time testing to see if I have fixed it yet, instead of waiting for it to fail for a long time.
Jim
So I still can't get it to work. I am probably going to go work on it again some time tonight, so if anyone has any ideas of things I should try, I would love it. Thanks.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.