Help - Search - Members - Calendar
Full Version: Usb Floppy
Linuxhelp > Support > Technical Support
gjhicks
Hello,

I am trying to get a USB floppy that is seen by the system to be actually useful, on an IBM Thinkpad and using Mandrake 9.

I have tried lots of suggestions from the web but had no success. After the good luck I had with my last post here, I thought I should have another go!

As I realise that probably everyone else knows more about Linux than me, I have pasted a few system responses below.

Thanks,

Geoff.


results of: cat /proc/scsi/scsi
-----------------------------------------------------------------------------------------------
Attached devices:
Host: scsi0 Channel: 00 Id: 00 Lun: 00
Vendor: Y-E DATA Model: USB-FDU Rev: 3.12
Type: Direct-Access ANSI SCSI revision: 02


selected results of: lsmod
-----------------------------------------------------------------------------------------------
Module Size Used by Not tainted
ide-cd 28712 0 (autoclean)
cdrom 26848 0 (autoclean) [ide-cd]
floppy 49340 0
vfat 9588 3 (autoclean)
fat 31864 0 (autoclean) [vfat]
supermount 14340 2 (autoclean)
ext3 73736 1 (autoclean)
jbd 38608 1 (autoclean) [ext3]
usb-storage 51952 0
scsi_mod 90372 1 [usb-storage]
usb-uhci 21676 0 (unused)
usbcore 58304 1 [usb-storage usb-uhci]
rtc 6560 0 (autoclean)


results of: mount
-----------------------------------------------------------------------------------------------
/dev/hda7 on / type ext3 (rw,noatime)
none on /proc type proc (rw)
none on /proc/bus/usb type usbdevfs (rw)
/dev/hda6 on /boot type ext3 (rw,noatime)
none on /dev/pts type devpts (rw,mode=0620)
none on /mnt/cdrom type supermount (ro,dev=/dev/hdc,fs=auto,--,iocharset=iso8859-1,codepage=850,umask=0)
none on /mnt/floppy type supermount (rw,sync,dev=/dev/fd0,fs=auto,--,iocharset=iso8859-1,codepage=850,umask=0)
/dev/hda1 on /mnt/win_c type vfat (rw,iocharset=iso8859-1,codepage=850,umask=0)
/dev/hda5 on /mnt/win_d type vfat (rw,iocharset=iso8859-1,codepage=850,umask=0)
/dev/hda9 on /mnt/win_e type vfat (rw,iocharset=iso8859-1,codepage=850,umask=0)[
Robert83
Hi,

mount /dev/usb/fd0 /mnt/floppy

Try this and hopefully that will work. If the usb modules aren't loaded, you would run:
modprobe usb (usb-uhci;usb-ohci;usb-core if usb doesn't work alone).

if this does not work try :
mount /dev/sda /mnt/floppy

Sincerely
Robert B
Robert83
Hi,

if you still have troubles :

First, try installing the usbmgr program (apt-get install usbmgr), which
might automatically load all the modules once it detects the floppy
plugged in, if doesn't, you can either mess with /etc/usbmgr/usbmgr.conf and
preload.conf, or add them to modules.conf.

goto this site : http://apt.freshrpms.net/
download apt-get for your distro to /home
cd /home
rpm -Uvh apt-[blablablablabla].rpm
apt-get update
apt-get install usbmgr

Sincerely
Robert B
gjhicks
Thanks for your suggestion. I got the USB floppy to work fine.

But now I have another odd problem.

My IBM TP 600X has only one USB port built-in.

I am trying to use both the USB floppy (as mentioned earlier) and a USB Hard Drive.

I have tried various combinations in the 'fstab' file but to no avail. It seems to depend on which device is plugged in first in a session:

If the USB Hard Drive is plugged in first -

The only command that gets access to the USB HDD is: mount -t vfat /dev/sda1 /mnt/uhdd

Ater umounting the USB FDD and plugging in the USB Floppy it can be accessed via: mount -t msdos /dev/sdb /mnt/uflop

If the USB Floppy is plugged in first -

The only command that gets access to the floppy is: mount -t msdos /dev/sda /mnt/uflop

After unmounting the floppy and plugging in the USB HDD it can be accessed via: mount -t vfat /dev/sdb1 /mnt/uhdd

In both cases the other variations of sda or sdb or sda1 or sdb1 did not work.

As the dev/sd?? seems to change depending on the order first used, it would seem that adding info to the 'fstab' file is pointless.

Any ideas on this?

I have noticed that 'supermount' is used for the CD and standard floppy in my 'fstab' file. Is 'supermount' a solution? if so, how is it used?

Regards,

Geoff.
Hemant
what about...

#mount -t vfat /dec/sda1 /mnt/usbfloppy(for accessing floppy)

#mount -t vfat /dev/sdb1 /mnt/usbhd(for accessing hrd drive)

make sure that module...usb-storage is loaded

# modprobe usb-storage
gjhicks
Hello,

Once again, thanks to you guys for helping a beginner.

I have put the following in the 'fstab' file:

/dev/sda1 /mnt/uhdd vfat noauto,rw,users,umask=0 0 0
/dev/sdb /mnt/uflop msdos noauto,rw,users,umask=0 0 0

Now, as an ordinary user, I can mount the USB HDD and Floppy with [mount /dev/sda1] and [mount /dev/sdb] repsectively.

Great!!

On the modprobe question:

On running [locate modprobe] I got:
/usr/share/man/man8/modprobe.8.bz2
/sbin/modprobe

I tried to run [/sbin/modprobe usb-storage] (as both ordinary and root) but got a blank line as the result.

Does this mean that 'modprobe' is not installed/configured?

Regards,

Geoff.
Hemant
What do you mean by "a blank line"...i think you would have just got your prompt back after entering that command...

Which means that command was successful...
gjhicks
Yes, new to Linux and lots to learn!

I presumed that the return of the prompt without a message meant that nothing had happened!

Thanks again for you help.

Regards,

Geoff.
gjhicks
One more thing.............

Now that I have got the USB Harddrive and Floppy to mount and function correctly, is there a way to get them to mount automatically when connected?

I notice that when I plugin either device there is activity on both the PC and the device - is there a way to "use" this activity to automatically mount the devices?

Regards,

Geoff.
Hemant
I think...one solution..is to have a bash script..so that you can mount both the devices..with a single..command..and similarly umount..them.

I am not sure..though...CD drives..can be mounted automatically in Linux..If similar thing can be done in Linux for USB devices..also..
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.