Help - Search - Members - Calendar
Full Version: Clock Error On Rhel Ver 3
Linuxhelp > Support > Technical Support
nifflerX
Hi,

The clock in my menubar (I think that's the best thing to call the bar at the bottom of my screen that has the quick links to Mozilla, the redhat menu, etc) shows the incorrect time. However, when I go to adjust the settings the time is correct inside the settings panel. I've tried the terminal as well, and when I enter `date` into the terminal I get the correct time, not the time shown on the menubar. Does anyone know where the menubar is reading the time, and why it's the only one getting it wrong? I'm running kernel 2.4.21-9.0.1.ELsmp. Thanks so much.


-NifflerX
hughesjr
Have you checked that the timezone is set correctly (not set to display in GMT)?
nifflerX
Yep,

The time zone is set correctly and the 'System clock uses UTC' is not checked. As far as I can tell everything inside the Date & Time properties box is correct, the only place where the time is wrong is on the applet in the menu bar. Thanks so much for all your help.


-NifflerX
nifflerX
So I'd already tried logging out and and back in a couple of times, but I did a complete shut down, waited a few seconds and then rebooted and now the time in the menubar is correct. Hope this helps someone out.



-NifflerX
hughesjr
do you have it set to use NTP? Just for the heck of it, I recommend that if you aren't using NTP that you give it a try.

I've had problems with the redhat.com time servers ... but you can pick a stratum 1 or 2 time server from here ... then right click on the clock applet and pick Adjust Date & Time.

Click the Enable Network Time Protocol block and paste in the name of a server from the above list that is close to you...then click OK. If it accepts the input, you have connected that time server.

After about 10 - 15 minutes, issue the command ntpq from the command prompt ... inside the ntpq prompt, issue the command peers ... the result should look similar to this:

CODE
ntpq> peers
    remote           refid                 st t when poll reach   delay   offset  jitter
==============================================================================
192.168.0.4     navobs1.wustl.e  2 u   51   64    3    0.351   -0.037   0.047

Except that your server that you used will be in the remote column. I have one server on my network that touches 3 outside time sources (192.168.0.4) ... then all my other computers use it as a time source.

After about 30 minutes do the following commands:

date <----will show your date/time within your time zone

date -u <----will show UTC date/time

do both of these show the correct time?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.