Help - Search - Members - Calendar
Full Version: Can't Initialize Eth0 In Mandrake 10.0c
Linuxhelp > Support > Technical Support
GTS
sorry if i'm going over old ground but i'm new to all this..... was told i needed linux for a masters project, so i called a friend that knows a little more and he suggested mandrake 10.0c. he's how overseas smile.gif, what a useful bloke....

install went OK though i'm having issues with the internet. i use cable internet, so playing with the mandrake configuration tool got me about 10 minutes of internet use before it'd drop out (something about heartbeat packets particular to this ISP that I have to adress). i dl'd a login client rpm, set that up and things worked ok for a bit, but same problem.

someone advised i had to get a DHCP program running on the OS not thinking that mandrake had the facility to do this itself - so i did this, internet went great until i rebooted - now i'm having problems getting just about anything right.

on verbose boot it starts my network cards first (two, one for the internet, one for the LAN), then the internet connection, then the login client. the internet connection had always failed, but now eth0 (the NIC it's on) fails too. regularly. the login client still loads ok. selecting DHCP for the network adapter (in the network setup utility (drakconfig?)) isn't amending this either, neither is swapping this network card out for a different one, or running just the one card.

interestingly when i check "monitor connections" and try to connect, it can recieve data but can't connect to anything. running "ifup eth0" fails too.

if anyone can help with this it would be very, very appreciated. this is my first exposure to linux and i've got to say that this aside.... impessive to say the least.

again, hope i haven't overlooked something that hasn't been covered, and thanks in advance.
Robert83
Hi,

I have a cable modem to , connected to my ethernet card, using DHCP for both private and public internet...
The only thing I needed to do was install the ethernet card correctly, plugin to it the Cable Modem, use the DHCP and it would give me a IP adress.
But unfortunately it happened to me once that it was not giving IP adresses to me nomatter what, later I found out that my ISP set the CABLE MODEM IP lease[?] limit to 1 cards, and the moment I changed the card to another it wouldn't work, also please note, I think that the cable modem actualy will collect the other ethernet card MAC adresses from you're computer in it's database and count them in , so if you're cable modem is set to lease a max of 2 or 1 IP adresses, and you have 3 in your computer I think it would not work.[At least this was a problem with me, with my ISP , cable modem company...].
As for that other heartbeat thing, I think you mean by that the ISP is constatntly trying to access some ports on you're computer to see are you on or off , [by me it's happening to , but I drop them,...offcourse I've talked with them about this, and they agreed that I can do this]. I think if you use iptables to filter packets incoming and outgoing from your computer you could have a look in /var/log/messages and search for you're ISP's ipadress from which they are trying to access some ports [better to ask them what to allow, what not to, in order to get around that heartbeat problem], and you can accept connections from that IP:port to you're IP:port.

Sincerely
Robert B
Robert83
Hi,

you should check you're var/log/messages for anything regarding you're eth0 [if that is you're ethernet card atached to the cable modem]

also you can check you're /etc/sysconfig/network-scripts/ifcfg-eth0 and you could post that here.[if eth0 is the card that uses eth0]

you can also check /etc/modules.conf [or /etc/modprobe.conf] and search for the eth0 alias

and post that here to.

Sincerely
Robert B
dmex
I had the same problem with my mandrake 10. try setting a static ip address if possible that might work.
GTS
ok..... have played around with a few things and come to a few conclusions.....

modules.conf aliases the adapter as such:
alias eth0 8139too
alias eth0 8139too

this is expected because it's the same chip on both adapters, though one's built in to the motherboard and the other's on an SMC card.

ifcfg.eth0:
DEVICE=eth0
BOOTPROTO=dhcp
NETMASK=255.255.255.0
ONBOOT=yes
MII_NOT_SUPPORTED=no
DHCP HOSTNAME=(my DNS host in 1.2.3.4 format)
NEEDHOSTNAME=yes

i'm not sure where it pulled my ISP's DNS host from. please excuse any typos as i can't cut and paste from linux to my working internet connection in windows on the same machine.

messages brings up what i think closer to the cause:
getting DHCP up on eth0 fails with return value 1 (yet to find out what that means, searching, if anyone knows, post it please!!)
eth1 is static at this stage so it seems to load ok.

getting into a terminal window and running dhclient eth0:
DHCPDISCOVER on eth0 to 255.255.255.255 port 67
no such device
no DHCP offers recieved.

when i enable DHCP on both cards, both fail. when i run static addresses, they boot with flying colours, but my ISP doesn't like it and the internet connection fails regardless. kill the firewall and no difference (don't know why i tried this).

the ISP hasn't locked the number of network cards. rang, asked, no. they did say the DHCP hostname wasn't my DNS host, that if you put it in the 1.2.3.4 format it's the same but the name is different (they gave me this).

so i guess there's a little more information. another issue may be that the internet client loads after the NIC's and linux's attempt to load the internet. should i re order this and how?

should i be traing to get updates to 10.0C? ow can you get these without having internet access under linux?

thanks in advance for any help.... i'm quietly tearing my hair out here because this aside it's a blisteringly quick system, and everything else everyone said wouldn't work (like a dual boot, etc) works perfectly...

as said, thanks in advance.
Robert83
Hi,

I'm not sure that this would help but...

my ifcfg-eth1 for my realtek 8139/8139C/8139C+
looks like this :

CODE
DEVICE=eth1
ONBOOT=yes
BOOTPROTO=dhcp


this is my ethernet card wich is connected to the cable modem [I recieve my public IP adress from it]
you could try this in you're ifcfg-eth0 instead of yours ...

Sincerely
Robert B
GTS
no dice

this is turning out to be less than a picnic...... why won't DHCP work..... i remember when i installed i didn't configure the internet thinking that i'd do it later, and that following the instructions on the login client's site that i had to install a dhcp client/program/daemon/thing not thinking that 10.0c may have already had one.... could i have broken something?

the windows user in me says "ask these people how to remove linux so that you can reinstall it" and some of the forum answers i'm seeing here would say "do not learn the answer, understand the question" ie fix (don't kill) linux you damn newbie.

ideas?
GTS
A-HA

uninstalled DHCP. reinstalled the version that came with 10.0c. eth0 works - takes a bit to settle on an IP at startup, but it works. essentially i created this problem myself it would seem.

now if only i could get my ISP working and it's dce-server talking to my pc. it will come. for the moment i'm getting a good 5 mins useage before the net drops out - that's the aforementioned heartbeat thing and nothing to do with linux.

linux is beautiful, linux is back. thanks for your help and patience guys.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.