Help - Search - Members - Calendar
Full Version: Fun With Paths!
Linuxhelp > Support > Technical Support
jeff_brown
I run all kinds of wonderful software with Gtk or G or Gnome in the title. I've had RPMs called gtkxxxx, libgtkxxxx, and many variants thereof, all installed since last fall. Yet my recent attempts at installing yarec are making me wonder whether I really have Gtk installed. It's creepy.

As has happened before, I found RPM packages for yarec but was unable to download them, so I did it the old fashioned way (./configure, make, make install). I got this warning at ./configure:

checking for GTK - version >= 1.0.1... no
*** The gtk-config script installed by GTK could not be found
*** If GTK was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GTK_CONFIG environment variable to the
*** full path to gtk-config.
configure: warning: Test for GTK failed.

That's the only complaint it ever gave me.

After installing, calling yarec (with or without arguments) from the command line yields no effect. I thought maybe it was failing to create a window, and if I find Gtk it would work. This hunch led to the following discoveries:

Searching for *bin*gtk* yields nothing, as does evaluating GTK_CONFIG or searching for *gtk-config*. I have all kinds of stuff for gtk, perhaps most notably in /etc/gtk/ and /usr/lib/gtk/. But neither of those directories is a bin, therefore the executable for GTK must be somewhere else, correct?

Once, somewhere, somebody with this problem had to add /opt/gnome/bin to their path. I have no such directory. Is this a succession of unrelated setbacks, or is there some theme here?


Eagerly,
Jeff Brown
Hemant
Well..it seems that the error is more related to gtk version incompatiblity rather that gtk is not installed or something....

Anyway i have just successfully tried to download yarec from http://rpmfind.net
just search for yarec and in the search result...try all the links mentioned there...
hughesjr
Jeff

yarec is very old (hasn't been updated since Oct. 30th, 2001)... use Audacity instead.

You should be able to install audacity (in mandrake 9.2) with the command:

urpmi audacity

(if you have a contrib or Disk_2 in your urpmi sources).
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.