Help - Search - Members - Calendar
Full Version: New With Suse 10.0 ...need Help Updating Drivers
Linuxhelp > Support > Technical Support
i just got suse linux 10.0 personal just to mess around with, i really know nothing about linux at all. I want to update my ati raedon 9700 pro, so i download the rpm file off of ati's website. I cannot figure out how to install it. i clicked the file and at the top there was a button that said click if you want to install in yast or something of that sort so i did that, then i restarted and all i get is commands now and i have no idea where to go. any help would be aprriciated, because i have no idea what to do, thanks
Um ... SUSE has release up to version 9.0 and their upcoming release is going to be 9.1.

Since you are talking about YAST ... it must be SUSE (8.2 or 9.0).

Here is the page that tells you how to install the drivers;

and here is the FAQ:
sorry i meant 9.0 not 10.0, but yeah I have been checking that page out and I still can't figure it out, I'm not sure what "cd to the directory containing the ati driver rpm package" means, and i also don't know where i try the command or what to do with the command "rpm -Uh --force <ati_package_name>.rpm" and what i did was download the file onto my desktop and then i opened the file up and a window came up that said, install with yast, or something of that sort, so i did that and when i restarted i get all text and i have to login, but there is no graphical stuff, it's all prompts and what not?...I'm lost with linux
OK ...

cd is a terminal command, which means to change your current directory .... when you downloaded the file, you saved it in a directory...that is where they want you to go.

If you logged in as the same user you were when you downloaded the file, you are currently in that users home directory ... if you are the root user that is probably /root ... if you are another user, you are probably in /home/username.

Issue the command:


to print your current working directory .... the output will be where you currently are.

If you type the command ls you can list files (and subdirectories) inside your current directory ... one directory is probably Desktop ... if so, issue this command to go to that directory:

cd Desktop

Now do ls again and see if the file fglrx-4.3.0-3.7.6.i386.rpm shows up ... if it does, then try the commands from the help page.
Ahhhhhh, I still can't figure this thing out, nothing happens when i type Is, and also on command prompt it says my name@linux then i did pwd and it said i was in /home/username then i try to add desktop because that is where the file is and that dosent work. Ahhhh ....
on ati's web site it says you have to be logged on as root user and i dont think that I am, and i am not sure how to do that either, i've tried tons of different commands too and nothing seems to work, i get an error that says cannot open file, file or directory does not exist... is there a way in the actual graphic interface or a program where i can run these commands instead so maybe i can try that if i re-install linux...

you can type in a terminal

su {hit ENTER}
type in you're root password {hit ENTER}

Robert B
still have no idea what I'm doing, i read somewhere that the .rpm files are linux version of the .exe file in windows. Has anybody ever installed this driver that could give me a step by step of what to do? here is what i did, i downloaded the 4.3 version to my linux desktop which is kde 3. something i think. then i clicked the rpm file that downloaded on the desktop and at the top of the window that opens is a button that says, install with yast, so i clicked that and it installs. then what i usually did was restart, but when i restart, there is no grapical interface, it tells me to login and put my password then it gives me a prompt. i also tried to run the install then i ran the fglrxconfig in a terminal window and restarted and that didnt work. when i installed linux, my monitor dosent show up and the wrong video card shows up. i have a raedon 9700 pro and my monitor is a dell 1702fp. the card that comes up isnt the 9700 it says like raedon300n or something like that, could that be the problem?...I have no clue, i have tried a lot it cant be that hard, i dont think...thanks for all the help already, if anybody has anything else, send it please
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.