Help - Search - Members - Calendar
Full Version: Vsftpd
Linuxhelp > Support > Technical Support
kingpin
How can I setup a user in Vsftpd, I just rented a dedicated server with RedHat 9, with Webmin installed and When I try to login I get the message :
CODE
500 OOPS: vsftpd: cannot locate user specified in 'ftp_username'


Any Help is appreciated. I looked thru So many tutorials and being the "uber Noob" smile.gif that I am I didnt figure it out. again I would appreciate any replies.
Robert83
Hi,

just installed vsftpd to see how it looks like...

I've just finished reading /etc/vsftpd/vsftpd.conf

have a look in that file [it has lot of info] on what things do.


and also check /etc/vsftpd.ftpusers that you're client is listed
and /etc/vsftpd.userlist


Sincerely
Robert B
Robert83
I think the problem is that

webmin is not listed in the user allow list /etc/ in either of those vsftpd user list ...etc files...


Sincerely
Robert B
Robert83
just checked

again

I think you'll need to remove if webmin is present in either of those files, since those are the users that are not allowed


you should do the following


/etc/vsftpd/vsftpd.conf

search for this line

user_list deny Yes

if you find it comment it out like this

#user_list deny Yes

then add the following line

user_list enable yes


Sincerely
Robert B


ps.: this might be unsafe...
Robert83
also please
have a look at these


in a terminal type :

man vsftpd

[you can use the up and down arrow to scroll up / down and press CTRL-Z to exit]

also see

man vsftpd.conf [for detailed configuration options, with good explanation ]

Sincerely
Robert B
kingpin
Wow thanx for all the replies so quickly. I will go try this right now.
kingpin
Im sorry but I tried to use SSH to login and here is what I got fromwebmin :
CODE
Failed to lookup IP address for linux to test telnet or SSH server.

I also tried using putty to login and it asked my my username I put it in then it asked my password I put that it and then It just shutoff, I tried this multiple time with same results. I been searching around on the net but the putty site or other sites I went to had no info on this behavior.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.