Help - Search - Members - Calendar
Full Version: Winex3 Source Code Installation
Linuxhelp > Support > Technical Support
Robert83
Hi,

I've had WineX3.x.x [rpm] installed on my previous RH9 system, but after I messed up the system I couldn't back it up.

I've donwloaded some WineX3.x.x RPM's [i586] , but I have problems running them, either they won't start at all...or no game will run at all....[like warcraft 3 played perfectly with WineX3.x.x]

Now I've decieded on downloading the source files from www.transgaming.com , go them : and installed them
like it was told to.... goto source dir of WineX and type ./tools/wineinstall

but after the installation is done, at the part where it's trying to do that registry thingie...

Preparing to install default Wine registry entries...
Installing default Wine registry entries...

wine: chdir to /root/.wine/wineserver-demon : No such file or directory
Registry install failed.

[root@demon winex]#

this is the error I get, anyone installed winex from source ? , what am I doing wrong here?

Sincererly
Robert B

ps.: was installing as root
hughesjr
@robert83 and termina

I don't normally install progams like Wine, WineX and CrossOver office or CrossOver plugin ... because it does things like:

1. Makes your Linux Machine vulnerable to Windows 32 Viruses ... especially if you use outlook, outlook express or IE6.

2. The games don't run as stably on Linux as they do on WinXP ... so I just run all my Windows Games on WinXP.

Since you are both having problems, it might have something to do with the XFree DRM manager to make the ATI card work.

Since I like you guys smile.gif , I will sacrifice my Slackware 9.1 test install and see if I can get WineX 3.3 to install from source...

duende likes games on linux and I think he is a Winex guy too ... maybe he has some insight on this one!
Robert83
Hi,

thanx, you know It's not actualy about playing games on Linux, it's about that I can't live with the knowledge that I succeded once, and now I can't...you know how it is...it's killing me, and by the way the only thing I managed to get playing absolutely good [in game , movies a bit choppy] was Warcraft3.

Sincerely
Robert B

ps.:I've found a cool script , wich looks like the anaconda installer [some console special edition], that is downloading and installing winex for me right now, if It succeds on Fedora Core 1 I will post it here.
Robert83
Hi,

OK!, it works , well I mean it installs and stuff [AND VERY-VERY-VERY Newbie friendly wow, sorta setup.exe next-next-next finish , run the program]

here is the script :
--------------------------------------------------------------------------------------------------------------------------------------------------------------------
CODE
#!/bin/bash

export LauncherVer="3.30"

# Configuration
#########################################################

# Vars
export CompileRootDir="$HOME/temp/cvswinex"
export ErrorLogFile=""
export ConfigurePrefix="/usr/lib/cvswinex"
export ConfigureOptions="--enable-opengl --with-x --enable-pthreads"
export AlwaysRecompile="1"
export ScriptName="cvswinex"
export ConfigDirName=".cvswinex"

export GetWineXLicense="http://www.transgaming.com/license.php?source=1"

export StripBinaries="0" # change to 1 to strip binaries. Disables debugging tho
export PackSource="1"

export CVSPasswordGuess="cvs"
export CVSCheckOutDir="winex"
export OldCVSCheckOutDir="wine"
export CVSoptions="-d :pserver:cvs@cvs.transgaming.org:/cvsroot -z 3 co"
#export DisableCVSrootCheck="1" # use if CVSoptions CVSroot has a space in it
export WineExecName="wine"

export ShowTips="1"

#User install
#export UserOnlyInstall="1"

# Helperscript stuff ... do not edit
#########################################################

if test "$1" = "proxy"
then
    echo "Enter proxy (eg: proxy.pandora.be:8080):"
    read http_proxy
    echo "$http_proxy" > $HOME/.GetWineXproxy && echo "info stored ..."
    exit
fi
http_proxy=`cat $HOME/.GetWineXproxy 2>/dev/null`
test -n "$http_proxy" && export http_proxy

Upgrade="0"
if test "$1" = "upgrade"
then
    echo "Upgrading Helper script ..."
    Upgrade="1"
    shift
fi

export GetWineXName=`basename $0`

function CheckOK ()
{
    if test "$Upgrade" = "1"
    then
 if ! rm -f "$GetWineXFile"
 then
     echo -e "Could not remove $GetWineXFilenAborting..."
     exit
 fi
    elif test -e "$GetWineXFile"
    then
 Test=`tail -n 2 "$GetWineXFile"|grep "#end"`
 if test -z "$Test"
 then
     echo "Helperscript incomplete, getting new"
     if ! rm -f "$GetWineXFile"
     then
   echo -e "Could not remove $GetWineXFilenAborting..."
   exit
     fi
 fi
    fi
}

GetWineXFile=`which GetWineX 2>/dev/null`;CheckOK
if test -e "$GetWineXFile"
then
    GetWineX $@
    exit
fi
GetWineXFile="$HOME/bin/GetWineX";CheckOK
if test -e $HOME/bin/GetWineX
then
    $HOME/bin/GetWineX $@
    exit
fi
GetWineXFile="./GetWineX";CheckOK
if test -e ./GetWineX
then
   ./GetWineX $@
else
    mkdir $HOME/bin/ >/dev/null 2>&1
    cd $HOME/bin/
    echo -e "nnGetting helper script ... please waitn"
    if wget http://ting.homeunix.org/GetWineX
    then
 chmod +x GetWineX
 ./GetWineX $@
    else
 echo -e "nnCouldn't download .. Try again, and/or contact ElmerFudd"
 echo "For manual download:"
 echo "  Goto http://ting.homeunix.org/cvs_wine/changelog.html"
 echo "  Download GetWineX, using the link around the top"
 echo -e "  Put it in <home>/bin/ and chmod +xn"
 echo -e "FEATURE:"
 echo -e "  If you are behind a proxy, try this:"
 echo -e "  $GetWineXName proxy"
 echo -e "  after proxy info is entered, just run again as normal.n"
 rm -f GetWineX
    fi
fi

-----------------------------------------------------------------------------------------------------------------------------------------------------------------
after install run cvswinex and follow the instructions...and then cvswinex again with the game name like this :

cvswinex war3.exe


and here is my problem with war3 , and this is probably my audio card driver problem...

[root@demon Warcraft III]# cvswinex War3.exe
Building font metrics. This may take some time...
Done building font metrics
err:wave:OSS_RawOpenDevice Can't set sample_rate to 48000 (44100) <--the problem I think what do you suggest?
err:wave:OSS_RawOpenDevice Can't set sample_rate to 48000 (22050) <--the problem I think what do you suggest?
err:wave:OSS_RawOpenDevice Can't set sample_rate to 48000 (11025) <--the problem I think what do you suggest ?
wine: Unhandled exception, starting debugger...
err:seh:start_debugger Couldn't start debugger ("programs/winedbg/winedbg 162243000 84") (2)
Read the Wine Developers Guide on how to set up winedbg or another debugger
err:ntdll:MODULE_THREAD_WaitThreadModuleSafe this should never happen. (unless wine crashed)

Sincerely
Robert B

ps.: audio is working fine otherwise , with xine , mplayer and the rest of the things...

------edited by hughesjr to put the script inside a code box ... please check the script to make sure it is right----
hughesjr
I think your audio driver doesn't support 48000 ... if you can get warcraft to run ... go into the multimedia options and see if you can reduce the sound quality (frequency) to a level that is listed (44100 for example).
hughesjr
Robert .. I editied your post to put the script inside a code box ... the http://xxx.xxx.xxx/ stuff was truncating and not showing the entire link ....

I tested the script after I finshed the edit and it installed WineX CVS on my machine...
Robert83
Ok, thanx! smile.gif

I'm still having troubles using that CODE QUOTE thingie...Can't figure it out [to simple maybe smile.gif smile.gif]


Sincerely
Robert B
hughesjr
For people who want to use the above script:

You must have the XFree86-devel tools installed:
--------------
for RedHat / Fedora use:

yum install XFree86-devel

or

apt-get install XFree86-devel

or

up2date XFree86-devel
-------------
I will try to install this on Slackware 9.1, Mandrake 9.2 and 10.0, Debian Sarge/SID and Gentoo. I'll post the results to this thread as I get them complete.
hughesjr
OK, on to Slackware 9.1 (Actually my Slackware is slackware-current ... kind of like Debian Sarge. I did a full install of Slackware 9.1 and I use swaret to keep it updated to Slackware-current. So it has some slightly newer packages than the updated Slackware 9.1 install).

The name of the package you have to install for Slackware 9.1 (if it is not already installed) is xfree86-devel-4.3.0-i486-3.tgz

Anyway ... just like in FedoraCore1, I copied and pasted the above posted script ... and I named it install_winex and saved the file ... then I made it executable with the command;

chmod 755 install_winex

then I ran it like this:

./install_winex

Accept the default paths ... use cvs for the password ... everything started OK and finished OK in Slackware.
hughesjr
On to Mandrake 9.2 ... the package that needs to be installed to allow the the above script to run and compile is:

libxfree86-devel

You can install it via the comamnd:

urpmi libxfree86-devel

The process completed with no errors.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.