Help - Search - Members - Calendar
Full Version: Syskonnect 9821 W/ Enterprise V3
Linuxhelp > Support > Technical Support
nifflerX
Hi,

I've had a linux box running redhat 8.0 with a SysKonnect 9821 (version 1) gigabit ethernet card for some time now. It worked just fine. I recently upgraded my machine to Enterprise WS version 3, and now I can't get my ethernet card to work. I can however get my on-board card to work, the problem with this is that my on-board card tops out at 100Mbps so I'd rather use the gigabit card. I have tried multiple solutions, including disabling the onboard lan via the BIOS at start up. As well as modifying the following files:

/etc/sysconfig/network
/etc/sysconfig/network-scripts/ifcfg-eth0
/etc/sysconfig/network-scripts/ifcfg-eth1
/etc/resolv.conf
/etc/hosts

When this failed I also tried to set up the network via the /usr/bin/redhat-config-network. In that GUI I was able to see the card, and it is configured with the correct drivers (at least that's what the rep from SysKonnect said). Does anyone have any ideas as to how I can get my gigabit ethernet card to work? If you need me to post the output from any files please let me know. Thanks so much.


-NifflerX
Robert83
Hi,

http://www.syskonnect.com/syskonnect/produ...ernet_9821.html
you can get the drivers here

Sincerely
Robert B
nifflerX
Hi,

Thanks for your reply. I've already installed the drivers from this website : http://www.syskonnect.com/syskonnect/suppo...htm/sk98lin.htm but I still wasn't able to get the card to access the network. redhat-config-network sees the card, and if I probe I get the correct hardware address, it even lets me configure the device and tells me everything is running fine, but then when I try and connect I can't. Any special configuration stuff that I might be missing? Thanks so much.


-NifflerX
Robert83
Hi,

well If you haven't updated you're sytem yet, I highly reccomend you do so..

go to the following site and get yum : http://apt.freshrpms.net/

and do a yum update

or update you're system with the Rad Hat updater [you've got a Red Hat enterprise linux right? , not Whitebox ]

Sincerely
Robert B
Robert83
Hi,

also copy paster you're ifconfig here



Sincerely
Robert B
nifflerX
eth0 is the on-board card, eth1 is the SysKonnect card. At the moment, both are configured (according to redhat-config-network) but only eth0 is active.

/sbin/ifconfig -a

eth0 Link encap:Ethernet HWaddr 00:30:48:21:14:78
inet addr:128.135.92.61 Bcast:128.135.92.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1263013 errors:0 dropped:0 overruns:0 frame:0
TX packets:1082288 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1370762645 (1307.2 Mb) TX bytes:669074551 (638.0 Mb)
Interrupt:31 Base address:0xd800 Memory:feaee000-feaee038

eth1 Link encap:Ethernet HWaddr 00:00:5A:98:F3:F4
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:24 Memory:febfc000-0

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:18080 errors:0 dropped:0 overruns:0 frame:0
TX packets:18080 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1518893 (1.4 Mb) TX bytes:1518893 (1.4 Mb)


/sbin/ifconfig
eth0 Link encap:Ethernet HWaddr 00:30:48:21:14:78
inet addr:128.135.92.61 Bcast:128.135.92.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1283558 errors:0 dropped:0 overruns:0 frame:0
TX packets:1100256 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1396190243 (1331.5 Mb) TX bytes:682516312 (650.8 Mb)
Interrupt:31 Base address:0xd800 Memory:feaee000-feaee038

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:18160 errors:0 dropped:0 overruns:0 frame:0
TX packets:18160 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1525473 (1.4 Mb) TX bytes:1525473 (1.4 Mb)


Thanks for helping me out.

-NifflerX
Robert83
Hi,

try this

ifconfig eth1 up

and then again type ifconfig post if something changes...


Sincerely
Robert B
Robert83
You should check your /var/log/messages

and see if any warrnings error are there when eth1 is starting up...
post the errors, warrning here regarding eth1


Sincerely
Robert B
nifflerX
After typing 'ifconfig eth1 up' I ran /sbin/ifconfg, with the results posted below. Then I unplugged the ethernet cord from the on-board port and plugged it in to the SysKonnect ethernet card. Once it was plugged into the SysKonnect card I was unable to access the network. I also checked the messages but the only messages I recieved are:

Mar 22 15:28:53 isaac kernel: e100: eth0 NIC Link is Down
Mar 22 15:29:05 isaac kernel: e100: eth0 NIC Link is Up 100 Mbps Full duplex

which I believe has to do with pulling the ethernet cord out of the on-board card, and plugging it back in. Is there anything else I should try? Thanks so much.

-NifflerX

/sbin/ifconfig

eth0 Link encap:Ethernet HWaddr 00:30:48:21:14:78
inet addr:128.135.92.61 Bcast:128.135.92.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:8936706 errors:0 dropped:0 overruns:0 frame:0
TX packets:7481875 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1601863077 (1527.6 Mb) TX bytes:563183202 (537.0 Mb)
Interrupt:31 Base address:0xd800 Memory:feaee000-feaee038

eth1 Link encap:Ethernet HWaddr 00:00:5A:98:F3:F4
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:24 Memory:febfc000-0

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:69093 errors:0 dropped:0 overruns:0 frame:0
TX packets:69093 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:5877076 (5.6 Mb) TX bytes:5877076 (5.6 Mb)
Robert83
Hi,
------------------------------------------------------------------------------------------
eth1 Link encap:Ethernet HWaddr 00:00:5A:98:F3:F4
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B ) TX bytes:0 (0.0 B )
Interrupt:24 Memory:febfc000-0
------------------------------------------------------------------------------------------

1.ifconfig eth1 up
2.ifconfig eth1 192.168.0.10 [for an example( example ip adress only!]
3.ping 192.168.0.1 [or any machine in the local network (example ip adress only!)]

Sincerely
Robert B
Robert83
So what I meant was

that you bring up eth1 as shown above give it some private ip adress for example 192.168.10 , and ping another computer on you're local network that has a ip adress beggining with 192.168.0.x [x means any number from 1 - 254 except 10 ].


if you succed with this, please tell me, and we will make you're changes permament...


Sincerely
Robert B
nifflerX
I ran what you told me, and here is the eth1 result from ifconfig:

eth1 Link encap:Ethernet HWaddr 00:00:5A:98:F3:F4
inet addr:128.135.92.65 Bcast:128.135.255.255 Mask:255.255.0.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:24 Memory:febfc000-0

When I had the ethernet cord plugged into the on-board ethernet card I was able to ping the address 128.135.92.65 from other machines on the network, but when I moved the ethernet cord into the SysKonnect card I couldn't ping other machines, and I couldn't ping 128.135.92.65 from other machines. It seems as though the ip address was assigned to the ethernet card, because normally 92.65 is an empty IP address, but then I still couldn't connect with the ethernet cord in the SysKonnect card. Any other theories on what I might be able to try? Thanks so much.


-NifflerX
Robert83
Okay let's give it another try...

0.ifconfig eth0 down
1.ifconfig eth1 down
2. goto /etc/sysconfig/network-scripts
and modify the file ifcfg-eth1 so that it has the needed ip adress and the SAME subnet mask as the other computers in you're network so if the rest is 255.255.255.0 use 255.255.255.0 here to , once done modifing save ...

3.ifconfig eth1 up [leave eth0 down]
4.ping yourself [ if success , check the cable]
5.ping some remote computer [if success, well smile.gif have a beer smile.gif ]


Sincerely
Robert B
Robert83
oh and another thing wich I completely

forgat post here you're /etc/modules.conf [or modprobe.conf]


the entry for eth0 and eth1 aliases... [only these, not the complete file, please]

do this first please , can't wait to see it smile.gif


Sincerely
Robert B
nifflerX
/etc/modules.conf

alias usb-controller usb-ohci
alias eth1 sk98lin
alias eth0 e100

Hope this gives you more insight than it does to me smile.gif.


-NIfflerX
Robert83
try doing this


modprobe sk98lin

and try again pinging from eth1 to some local adresses...and pinging itself...


Sincerely
Robert B
nifflerX
Sorry, no beer yet.

I did what you said and I could ping 92.65 (the SysKonnect card) and 92.61 (the on-board card), but I couldn't ping anything else. I tried the 'modprobe sk98lin' but I don't think that's the problem, because when I was working with the SysKonnect guy he had me trying that to get the orange light to turn on, on the SysKonnect card. Since I worked with him, the orange light has been on at every boot up without too much of a problem. So I'm still at the point where if I restart my network services I can access the web, but only through the on-board ethernet card. Any other thoughts? Thanks again for helping me.


-NifflerX
Robert83
hmm...

well If you are willing you could try putting you're gigabit card to a diferent slot...maybe that would help

slot 2,3,4...

you also did the updates right? you've got the latest stable from everything?


I think you should have a modprobe.conf file to [ I've got one with my enterprise linux WhiteBox 3.0 ], make sure that alias eth1 sk98lin is present there to...

but I'm stuck at this right now...I will tommorow take a look at the driver at that site, and see if I can come up with something new [sorry I'm getting tired, it's late 00:29 , please forgive smile.gif ]


Sincerely
Robert B
Robert83
by the way

I've had this strange thing that my onboard card nvnet takes any kind of cable and works with it fine...but my external DLink and Realtek are picky about cable types...perhaps you could try another cable...

Sincerely
Robert B
Robert83
Hi,

what kernel version do you have? [ type uname -r ]

what do you use to update you're system apt-get yum , etc...


Sincerely
Robert B
nifflerX
2.4.21-9.0.1.ELsmp

And I'm using up2date to update and patch my system. I don't have 2.4.21-9.0.1 installed though, because I only intend to run the smp kernel. Also, my /etc/log.d/services/modprobe.conf only has the following uncommented lines:

Title = "ModProbe"
*OnlyService = modprobe
*RemoveHeaders


Should I add one about sk98lin? Thanks so much.


-NifflerX
nifflerX
I don't think it's the cable, because this cable worked before I updated from redhat 8.0 to Enterprise. There is one other slot for an ethernet card I can try if you think it will help. Should I try switching the card's location or something else first? Thanks so much.


-NifflerX
Robert83
try adding the alias for eth1 to modprobe.conf
reboot
and hope that it works...

Sincerely
Robert B
nifflerX
is the format for that additions

alias eth1 sk98lin

also, is there any particular place in the file that it needs to go? Thanks



-NifflerX
Robert83
yes

just try adding that line save it

and reboot


Sincerely
Robert B
nifflerX
added the line and rebooted, but still nothing. On reboot ifconfig yielded all eth0, eth1, and lo were up and running, but I couldn't reach the network, I could only ping the two local IP addresses. Then I switched the ethernet cord to the on-board ethernet port, and went into redhat-config-network. After unchecking "turn on when computer starts up" for the gigabit card and restarting the network I could connect no problems. One thing that may be causing issues is when I muck around with the gigabit card settings in redhat-config-network, Kudzu will come up during a reboot. It tells my my ethernet card (it calls it by name) has been removed should I remove the configuration. If I do, then next thing says that the ethernet card has been found would you like to configure it. I'm not sure if this is helpful, but I thought I should mention it. Is there anything else I should try? Thanks so much.


-NifflerX
nifflerX
So I've been trying different combinations of the two ethernet cards being on and off. When I restart the network services eth0 comes on, but not eth1. When I do that everything works. If I then bring up eth1 via redhat-config-network I can no longer ping the outside world. If I bring down eth1 via ifconfig, then bring down, and back up, eth0 everything still works fine. If I bring eth1 up via ifconfig I can still ping the outside world, but I can't use web browsers (I use Mozilla). So far the best configuration has been eth0 up and eth1 down, and having that be the default so when I restart the network services that is what I'm left with. I don't suppose there is any way to make the linux box completely forget about the on-board ethernet card and be completely dependent on the gigabit card. That would be fine with me, but when I turned off the on-board card in the BIOS, I wasn't able to accomplish anything useful. Maybe I forget some configuration files or something? Thanks for all your help.


-NifflerX
Robert83
I think you should allow kudzu to remove it,

and then to configure it again, maybe something got messed up...I really don't know what else could be the problem...[sorry]

Sincerely
Robert B
nifflerX
That's what I usually do. It removes and then configures the ethernet card, then I enter an IP number, Netmask, etc... Then when I look inside redhat-config-network the ethernet card is there. I suppose I could just ignore next time Kudzu comes up and see what ethernet cards the machine sees.


-NifflerX
Robert83
Hi,

I know this might sound a bit...errr...not professional, but can you please try that Gigabit ethernet card in a Windows
computer , just to see if it works ?


Sincerely
Robert B
Robert83
type

route

and copy paste it here...

Sincerely
Robert B

ps.: read this page , it just might help
http://enpc3240.eas.asu.edu/lxr/linux/http...ing/sk98lin.txt
nifflerX
Here's my route table with the on-board card active and the SysKonnect card inactive (both configured, eth0 = on-board, eth1 = SysKonnect).

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
128.135.92.0 * 255.255.255.0 U 0 0 0 eth0
169.254.0.0 * 255.255.0.0 U 0 0 0 eth0
127.0.0.0 * 255.0.0.0 U 0 0 0 lo
default v92router.uchic 0.0.0.0 UG 0 0 0 eth0

after typing `ifconfig eth1 128.135.92.65` my routing table looks like this (at it takes a lot longer for the last line to come up):

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
128.135.92.0 * 255.255.255.0 U 0 0 0 eth0
128.135.0.0 * 255.255.0.0 U 0 0 0 eth1
169.254.0.0 * 255.255.0.0 U 0 0 0 eth0
127.0.0.0 * 255.0.0.0 U 0 0 0 lo
default 128.135.92.1 0.0.0.0 UG 0 0 0 eth0


after typing `ifconfig eth0 down` my route table looks like this:

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
128.135.0.0 * 255.255.0.0 U 0 0 0 eth1
127.0.0.0 * 255.0.0.0 U 0 0 0 lo

Thanks for all your help.

-NifflerX
Robert83
hi,

after eth1 up
eth0 down

type

route add default gw 128.135.92.1

try ping 128.135.92.1


Sincerely
Robert B
nifflerX
I couldn't ping 128.135.92.1, I got the following error message:

PING 128.135.92.1 (128.135.92.1) 56(84) bytes of data.
From 128.135.92.65 icmp_seq=0 Destination Host Unreachable

My route table from this set up was:

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
128.135.0.0 * 255.255.0.0 U 0 0 0 eth1
127.0.0.0 * 255.0.0.0 U 0 0 0 lo
default 128.135.92.1 0.0.0.0 UG 0 0 0 eth1

I'm not sure if this makes a difference but in my previous post I didn't move the ethernet cable from the on-board card This time, I moved it to the SysKonnect card, since that was the card I'm trying to test. The routing table looks like it has the right entry, but still no dice. Is there anything else you can think of that I can try? Thanks so much for all your help.


-NifflerX
nifflerX
Hi,

I realize this is a lot latter, but I finally got this to work. I had to install kernel-source.*.rpm. After that I was able to run the driver installer from the SysKonnect website and after some warnings I was able to get it working. Thanks again for all your help.


-NIfflerX
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.