Help - Search - Members - Calendar
Full Version: Wget Upgraded Me To 2.4 - Problems
Linuxhelp > Support > Technical Support
Termina
I used the wget ftp://blah/*tgz to get all the slackware security updates.

It also got me 2.4.24, which I thought was cool.

I restarted, and suddenly sound and internet don't work. sad.gif I don't even have an eth0 anymore, according to slackware. =/

Any ideas? happy.gif (Recomiling the kernel doesn't help, and I don't see any options in menuconfig that would help)
Robert83
Hi,

I guess you should try to go to kernel src dir /usr/src/linux-xxxxxxx

make mrproper

then copy the config-[you're kernel version] from /boot/ to /usr/src/linux ,
it should look like this /usr/src/linux-xxxxxxx/.config

then

make oldconfig

change the make , make sure that after the kernel version the custom is deleted...

make dep

make install

/etc/modules you should check this one to! if you're eth0 alias is something else then what it used to be, this could be the problem...

for example my eth0 alias is nvnet , if It would change to something else it would probably not work, or not work correctly....

Sincerely
Robert B
Termina
Holy Zombie Jesus!

It worked, thank you much! happy.gif

Um, what exactly happened? I assume that it just put the kernel image over the old one, and set it to be booted with configuring it? Or did I completely miss the mark. ;-_-
Robert83
I'm glad it worked...

smile.gif

Sincerely
Robert B
hughesjr
Is this on one of those NForce2 machines?

If so, everytime you change the kernel, you will need to recompile and reinstall the nvnet and nvaudio drivers from nforce.

What you did this time, was put the kernel back to the version it used to be...

If you want the new kernel, make sure you have the NFORCE tgz downloaded, download the new kernel-source first .... then download the new kernel.

Reboot on the new kernel ... then go to /usr/src/new-kernel-source

make mrproper

copy down the config file for the new kernel from /boot

make oldconfig

make dep


then go to the NFORCE source directory and do:

make

make install


(for this to work ... you have to be booted up on the new kernel ... and the kernel source has to match the new kernel)

reboot and all should work
----------------
You have to do this everytime you upgrade the kernel....

You can do the command:

uname -r

To see your current kernel version....
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.