Help - Search - Members - Calendar
Full Version: Hi
Linuxhelp > Support > Technical Support
Robert83
So,

I've just reinstalled RH9 since whitebox somehow I can't imagine as a personal desktop at home...

I've got a Gigabyte GA 7N400 Pro2 mb. , so I've installed RH9, updated everything , the kernel was also updated. Old kernel removed, {i've already had the latest kernel runing on this machine for some time}.

So the problem is I needed to remove my Creative Sound Blaster LIVE! since it had no optical output, and I'm using the onboard sound card AC97 [detected by linux as i810 audio], and I don't get any sound, where can I get a sound driver for Red Hat ? , and where on earth is the hardware settings in GNOME? [KDE has one, but I don't seem to find where does GNOME have it? or is it a command from console?].

Can anyone help me with installing this driver for the card? [I need a driver that can run with the optical addon kit with my motherboard....]

Any help would be greatly apriciated. Thank you.


Sincerely
Robert B
hughesjr
OK,

That is an NVIDIA Nforce 2 chipset ... you will need to download the kernel drivers here:

http://www.nvidia.com/object/linux_nforce_1.0-0261

The file you will have to download is the tar file (your kernel is probably newer than the 2.4.20_9.athlon ... if you are using 2.4.20_9.athlon, you can download this file instead and install it via:

rpm -Uvh filename
----------------
If you have to do the tar file driver, you will need to download and configure your kernel source like you did for the ati driver install on the other PC....then follow the directions in the readme file after untaring the tar file.
Termina
I also have the nforce 2 chipset on my motherboard...

How important is the update? Does it only affect the onboard audio/lan?
Robert83
Hi,

I've got 2.40.20-30.9 Kernel , and the nvidia GART driver is for the 2.40.20 Kernel, should I try to install it anyway?


Sincerely
Robert B
hughesjr
The gart driver is builtin to most newer kernels ... I don't have my RedHat 9 reinstalled yet from my hard drive crash to look at. I would think it is already in the latest RH kernel.

That patch is to get agpgart working ... if you can install either the ATI or NVIDIA drivers and get 3D, the driver is already incorporated into the kernel.
Robert83
Hi,

I downloaded the tar.gz file , and extracted it, did a make install on it

it installed [only one error showed up nvnet, but it's ok, since its disabled in BIOS.


I've edited the /etc/modules.conf file

alias sound-slot-0 i810_audio
was changed to
alias sound-slot-0 nvaudio

and once I try to make red hat 9 autodetect the sound, it says that it can't load i810_audio module, if I skip this thing and try to play some music, I get no sound, what could be the problem?

The stepts I used to install the modules...

1.Downloaded the Kernel Source 2.40.20-30.9 [same as my kernel version],
2.Extracted the tar.gz file
3.cd /nvidia
4. make install
5. goto /usr/src/linux-2.40.20-30.9
6. copy /boot/config-2.40.20-30.9 to /usr/src/linux-2.40-20-30.9/config
7. make mrproper
8. make oldconfig
9. make dep
10. make install
11. edit /etc/modules.conf according to the HTML readme found at NVIDIA's website
12. rebooted the computer [everything was showing up [OK] at startup ]

and I get no sound....but I get sound under winxp, what am I missing?



Sinerely
Robert B
hughesjr
In the kernel source directory, you need to do things in this order (this is the procedure for any RedHat / Fedora / Mandrake 2.4.xx Kernel):

make mrproper <---erases the effects of any previous makes ... so if you do it after make oldconfig, it erases the configuration info

copy the config down from the /boot directory

make oldconfig

edit the Makefile in the KernelSource directory and remove the custom from the EXTRAVERSION line ... if it is there.

make dep

(don't do make install from kernel source)
-----------------------
Go to the nforce directory

do the command:

make

then do the command:

make install

then make sure nvaudio.o and nvnet.o are in under /lib/modules/`uname -r`/ and not /lib/modules/`uname -r`custom/

then do modprobe nvaudio and see if it loads.... you might have to do modprobe soundcore first.

You can also probably use the nvnet card now as well ... do modprobe nvnet, if it loads, change the alias in /etc/modules.conf for eth0 to nvnet...
hughesjr
@Termina...

the kernel patch for the agpgart is so you can load 3D graphic drivers .... make and make install of the nforce_tar_file doesn't install the agpgart kernel patch, just network and audio.

The agpgart patch is already included in many new kernels (should already be in 2.4.21 and higher ... may be backported into some other kernels, like RedHat 9) ... look in the kernel config file for the text:

CONFIG_AGP_NVIDIA

it is in the kernel and turned on if

CONFIG_AGP_NVIDIA=y
------------------------------------------------------------
Nforce 2 support for sound, video, and network is built in to the 2.6.x kernel (at least it's in 2.6.3)
-------------------------------------------------------------------
Robert83
Thank you very much, now I get sound,


I will do this for the Radeon videocard now, I think It'll be enought to do the videostuff only, since the audio/network part is already installed.




Thank you again, for you're help! smile.gif


Sincerely
Robert B
cdfusion
Hey I have been having alot of problems getting the nvaudio module to work

After I run and make install then run modprobe nvaudio i get this message
CODE
[root@localhost nvaudio]# modprobe nvaudio
/lib/modules/2.4.20-30.9/kernel/drivers/sound/nvaudio.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
     You may find more information in syslog or the output from dmesg
/lib/modules/2.4.20-30.9/kernel/drivers/sound/nvaudio.o: insmod /lib/modules/2.4.20-30.9/kernel/drivers/sound/nvaudio.o failed
/lib/modules/2.4.20-30.9/kernel/drivers/sound/nvaudio.o: insmod nvaudio failed


and when I run insmod i get this
CODE
[root@localhost nvaudio]# insmod nvaudio
Using /lib/modules/2.4.20-30.9/kernel/drivers/sound/nvaudio.o
/lib/modules/2.4.20-30.9/kernel/drivers/sound/nvaudio.o: unresolved symbol ac97_set_adc_rate_R895c54b6
/lib/modules/2.4.20-30.9/kernel/drivers/sound/nvaudio.o: unresolved symbol ac97_probe_codec_R83a75e83
/lib/modules/2.4.20-30.9/kernel/drivers/sound/nvaudio.o: unresolved symbol ac97_set_dac_rate_R9120062b


can anyone help me get this to work? (BTW the nvnet module does work correctly and the kernel is 2.4.20-30.9) Thanx in advance
hughesjr
Make sure that the audio card is not disabled in your BIOS.

what is your motherboard and manufacturer?
cdfusion
it is enabled, and it does work in Windows XP. The mobo is FIC
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.