Help - Search - Members - Calendar
Full Version: Ati Radeon 9600pro
Linuxhelp > Support > Technical Support
Robert83
Hi,

I switched my video card to a Ati Radeon 9600Pro, and when I select the Radeon 9600Pro driver in linux and enable 3d acceleration , then after the restart X freezes along with the computer, the monitor turns off, and back on, the computer works for another 3-4 seconds and game-over.

[Under Windows it works ok, after I did a bios update for my Gigabyte Nforce2 Ultra Pro2 mb now it's bios ver is F6]

Any ideas?

Sincerely
Robert B
hughesjr
With Nforce 2 type boards on a 2.4 kernel there are problems with the agpgart. (see the GART Patch Installation on this page).

That patch only is designed to work on a vanilla 2.4.20 kernel from kernel.org ... it doesn't always work on other kernels (even redhat 9's 2.4.20-xx.x kernels).

Did you try the ati driver from here (you should need the 4.3.0 version) (instructions ... do the 2.4 Generating a customized kernel module section after installing the RPM)

If that doesn't work ... you might try a 2.6 kernel (for RH9).
------------------------------------------------------------------------------------------
Is this on a whitebox or RedHat 9 install?
------------------------------------------------------------------------------------------
If RH 9, you can try using the 2.6 kernel, by adding this to your apt-get sources:

CODE
# Arjan's 2.6 series kernel repository
rpm http://people.redhat.com arjanv/2.5 kernel
rpm-src http://people.redhat.com arjanv/2.5 kernel


Here is the readme for putting the 2.6 kernel on RH9.

Basically, I did:

apt-get update
apt-get dist-upgrade


then after that, I downloaded the correct kernel and kernel source:

apt-get install kernel#2.6.3-2.1.254 kernel-source#2.6.3-2.1.254

reboot and boot off the new kernel

Make sure the link for /usr/src/linux is pointing to the new kernel source ...
cd /usr/src
ls -al[b]

If linux not pointing to the right place...
[b]rm linux


then link it to the correct source directory:
ln -s linux-2.6.3-2.1.254 linux
(the kernel-source directory might have a different name ... I don't have my RH9 pc avialable right now).

If no sound and network, Download and install the Nforce drivers on the new kernel and see if it works. (instructions ... look at the Tar File Installation

Then when all that is working, do the ATI video drivers with this kernel per the link above if it isn't working

I haven't tried this with an NForce2 motherboard .... but it should work
Robert83
Hi,
it's a whitebox install

Sincerely
Robert B
Robert83
Hi,

I get the following error when trying to install any of Ati drivers [from www.ati.com]

[root@robi2k root]# rpm -Uvh fglrx-glc22-4.3.0-3.7.0.i386.rpm
Preparing... ########################################### [100%]
file /usr/X11R6/lib/libGL.so.1.2 from install of fglrx-glc22-4.3.0-3.7.0 conflicts with file from package XFree86-Mesa-libGL-4.3.0-55.EL
[root@robi2k root]#


Sincerely
Robert B
Robert83
Hi,

found it,

the ati drivers includes a custom built version of that thing...doing it now with -e then Uvh


Sincerely
Robert B
hughesjr
WhiteBox has a bunch of backported 2.6 kernel stuff in it ...

I haven't generated a custom kernel for whitebox ... but I looked in the standard config file and WhiteBox has AGPGART Nvidia Chipset support built in, so you shouldn't have to worry about any of the NVIDIA Nforce drivers.

You should be able to install the propreitary ATI driver. (instructions ... install the 4.3.0 rpm and then do the 2.4 Generating a customized kernel module section of the instructions).
hughesjr
You are fast!
Robert83
Hi,

Another problem when generating custom kernel for ati...

[root@robi2k build_mod]# ./make.sh
ATI module generator V 2.0
==========================
initializing...
kernel includes at /usr/src/linux/include not found or incomplete
file: /usr/src/linux/include/linux/version.h
[root@robi2k build_mod]#


what to do?

Sincerely
Robert B
hughesjr
If you have the latest whitebox kernel, go to the /usr/src directory and create a link like this:

cd /usr/src
ln -s linux-2.4.21-9.0.1.EL linux


The ls -al should thne show:
CODE
lrwxrwxrwx    1 root     root           21 Feb 21 10:15 linux -> linux-2.4.21-9.0.1.EL
Robert83
Hi,

still the same error, what did I do wrong?

[got the latest kernel, with Yum]


Sincerely
Robert B
Robert83
Sorry
Now it's there, did it again...there was a glitch in the matrix smile.gif


Sincerely
Robert B
Robert83
But I still get the same error when runing ./make.sh


anything else?


Sincerely
Robert B
Robert83
I've got no /usr/src/linux only /usr/src.... that could be a problem right?


what should I do to get the source?


Sincerely
Robert B
hughesjr
yum install kernel-source ...

then there should be a directory called:

/usr/src/linux-2.4.21-9.0.1.EL

then issue the ln -s command above from within the /usr/src directory:
hughesjr
If the kernel-source is installed properly and the link exists, and you have the same problem .... try this:

go to /usr/src/linux

(that should be the same as /usr/src/linux-2.4.21-9.0.1.EL if the link is set up correctly).

copy the config file from the /boot to /usr/src/linux/.config like this (you must be inside the /usr/src/linux directory to do this):

cp /boot/config-2.4.21-9.0.1.EL .config

Now make the old configuration the current one ... issue the command:

make oldconfig

then edit the file Makefile in /usr/src/linux ... look for the line:

EXTRAVERSION = -9.0.1.ELcustom

and change it to:

EXTRAVERSION = -9.0.1.EL

save the Makefile

then run the command:

make dep
--------------------
note: do a uname -r and if you are using the 2.4.21-9.0.1.ELsmp then the config file would be /boot/config-2.4.21-9.0.1.ELsmp and you would change the line in the Makefile to say EXTRAVERSION = -9.0.1.ELsmp
Robert83
Hi,

when I did that config copy thing and changed everything, and did that make dep, I get the following two errors :

[root@robi2k linux-2.4.21-9.0.1.EL]# make dep
make[1]: Entering directory `/usr/src/linux-2.4.21-9.0.1.EL/arch/i386/boot'
make[1]: Nothing to be done for `dep'.
make[1]: Leaving directory `/usr/src/linux-2.4.21-9.0.1.EL/arch/i386/boot'
rm -f .depend .hdepend
make _sfdep_kernel _sfdep_drivers _sfdep_mm _sfdep_fs _sfdep_net _sfdep_ipc _sfdep_lib _sfdep_crypto _sfdep_arch/i386/kernel _sfdep_arch/i386/mm _sfdep_arch/i386/lib _sfdep_arch/i386/oprofile _FASTDEP_ALL_SUB_DIRS="kernel drivers mm fs net ipc lib crypto arch/i386/kernel arch/i386/mm arch/i386/lib arch/i386/oprofile"
make[1]: Entering directory `/usr/src/linux-2.4.21-9.0.1.EL'
make -C kernel fastdep
make[2]: Entering directory `/usr/src/linux-2.4.21-9.0.1.EL/kernel'
make[2]: *** No rule to make target `/usr/src/linux-2.4.21-9.0.1.EL/include/linux/autoconf.h', needed by `/usr/src/linux-2.4.21-9.0.1.EL/include/linux/modules/signal.ver'. Stop.
make[2]: Leaving directory `/usr/src/linux-2.4.21-9.0.1.EL/kernel'
make[1]: *** [_sfdep_kernel] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.21-9.0.1.EL'
make: *** [dep-files] Error 2
[root@robi2k linux-2.4.21-9.0.1.EL]# mc


what to do?

Sincerely
Robert B
hughesjr
Looks like you are in the correct directory ...

1. do this:

make mrproper

copy the config file back down:
CODE
cp /boot/config-2.4.21-9.0.1.EL .config

(there is a space between .EL and .config)

2. do:

uname -r

If you have 2.4.21-9.0.1.EL then check the line in the Makefile (in the current directory)... make sure it says:

EXTRAVERSION = -9.0.1.EL
(if the uname -r said 2.4.21-9.0.1.ELsmp, use EXTRAVERSION = -9.0.1.ELsmp instead)

3. then do:

make oldconfig

4. then do:

make dep
Robert83
Hi,

I did every step, just like it was written in that readme, now opengl seems to be working, but its really-really slllloooow smile.gif, is there any step at fglrxconfig that I should look after? [I used the internal agp drivers, since the agpgart external didn't work at all with ait],

any ideas?


I guess Nvidia is way better with their drivers then Ati,....If I can do anything else, perhaps try the new kernel 2.6 or something, since I would really hate to move 2 feet to the right, and install linux on a new computer smile.gif, can I download 2.6 kernel for Whitebox, is there any reason to do so?, it's strange though , Ati states on it's website that this driver support Red Hat Enterprise Linux, maybe I'm doing something wrong?

Please help

Sincerely
Robert B
hughesjr
run the program:

glxgears

what is the output (in frames per sec)
Robert83
Hi,

[root@robi2k root]# glxgears
508 frames in 5.0 seconds = 101.600 FPS
560 frames in 5.0 seconds = 112.000 FPS
5688 frames in 5.0 seconds = 1137.600 FPS
324 frames in 5.0 seconds = 64.800 FPS
583 frames in 5.0 seconds = 116.600 FPS
513 frames in 5.0 seconds = 102.600 FPS
1026 frames in 5.0 seconds = 205.200 FPS
1368 frames in 5.0 seconds = 273.600 FPS
1111 frames in 5.0 seconds = 222.200 FPS
750 frames in 5.0 seconds = 150.000 FPS
508 frames in 5.0 seconds = 101.600 FPS
1120 frames in 5.0 seconds = 224.000 FPS
558 frames in 5.0 seconds = 111.600 FPS
3693 frames in 5.0 seconds = 738.600 FPS
2083 frames in 5.0 seconds = 416.600 FPS


I guess something is wrong then...

Sincerely
Robert B
hughesjr
You are still using the 2D driver...

There is a brand new driver here now.

It will install as is .... just use:

first uninstall the other driver:

rpm -e fglrx

the install the new driver

rpm -Uvh fglrx-4.3.0-3.7.6.i386.rpm

(if you have the kernel source installed and edited like I posted before with the proper line

EXTRAVERSION = -9.0.1.EL
-------------------------------------------------------------------------------------------------------
If you need to rebuild the driver in the future (you will if you upgrade your kernel) ... make sure you have the latest kernel source (it's version matches uname -r) and that you edited it's EXTRAVERSION line to match your uname -r, that you did make mrproper, that you copied the proper config file down form /boot ... did make oldconfig ... and did make dep...

then go to /lib/modules/fglrx/build_mod and do this:

chmod 755 make.sh

./make.sh


It should complete without problems...

then go to /lib/modules/fglrx and do this:

chmod 755 make_install.sh

./make_install.sh

Then you should be able to use the new driver....
----------------------------------------------------------------
You need to do this after the install of the rpm....

Go into your current /etc/X11/XF86Config file, and find the driver line and change it to this:

Driver "fglrx"
Robert83
Hi,

I've got the lates drivers,

installed everything

when I do modprobe fglrx no error comes up


I've configured the video card with fglrxconfig from console [wich came with the Ati driver],

it created a /etc/X11/X11Config4 file [and renamed the XConfig to XConfig.old], I've rebooted the computer,

started glxgears it started up and was really-really fast for a few seconds , then when I moved it's window to see what FPS do I get, it slowed down , and now I only get 100-120FPS, rebooted again, still nothing, is there any hope left for me with this Radeon9600Pro card?
[Red Hat9 now, NOT Whitebox]

Sincerely
Robert B
Robert83
Hi,

I've deleted the X86Config4
renamed the old X86Config.old to X86Config
changed the driver to fglrx

rebooted


ran glxgears , it is faster now I mean I see those cogs almos like full circles, but glxgears show this in console :

1521 frames in 5.0 seconds = 304.200 FPS
1326 frames in 5.0 seconds = 265.200 FPS
1560 frames in 5.0 seconds = 312.000 FPS
1482 frames in 5.0 seconds = 296.400 FPS
X connection to :0.0 broken (explicit kill or server shutdown).

this means that I still don't have 3D, what on earth am I missing? [strange GL screensavers actaly run all of them, but not fast, nor slow, something beetween,...not good...awww sad.gif ]


Sincerely
Robert B
hughesjr
Make sure you have:

dri

loading...
Robert83
Hi,

this is how my X86Config looks like :

# XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"
# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.

RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "C1770FNST"
DisplaySize 320 240
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 160.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "fglrx"
VendorName "Videocard vendor"
BoardName "VESA driver (generic)"
VideoRam 131072
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection


so I guess dri is loaded, what else do I miss?

Sincerely
Robert B
hughesjr
I just checked the kernel source for RH9 (I installed it on my test machine) and the nforce2 agpgart patch is not installed on the 2.4.20-30.9 kernel...

I am seeing if the patch installs properly right now ... if the kernel compiles correctly after the patch, I'll post how to do it....
hughesjr
I had the same error as here when trying to compile ...

How do you fell about trying a 2.6.3 kernel?
Robert83
Hi,

thanx for you're help, so ummm, where to get 2.6.3 kernel, and how to install it? [can apt-get be used?] or something?


Sincerely
Robert B
Robert83
Hi,


I've downloaded the latest 2.6.4 kernel [stable], and extracted it to /home/kernel-2.6.4 , only because it is written in the kernel readme that it's not recomended to extract it to /usr/src/linux-2.6.4 because some problems might arise, is this really that serious? [since apt-get downloaded and extracted the kernel there].

Okay, so I've read that I can use my old config file, and during the configuration it will only ask for questions that are not in my config file.

Okay so I guess I should begin with something like go to /home/kernel-2.6.4 [in my case], do :

1.make mrproper
2.copy the old config file from /boot/config-xxxxxxx to /home/kernel-2.6.4
3.make oldconfig
4.make dep
5.install nvidia stuff
6.install ati radeon stuff
7.make install

if I do make install in /home/kernel-2.6.4 then it'll install the 2.6.4 kernel, not something else from /usr/src...right?


Sincerely
Robert B
Robert83
hmmm...can't seem to get those modules to install into the right place

though I did a ls -all , and a ln -s Kernel linux


they all install with make install into /usr/src/linux-2.4.20-30.9


please help, what to do?


when I configure the new kernel, those [NEW] features, is it safe to just press enter on every one of them...

Sincerely
Robert B
hughesjr
OK,

There are pre-built 2.6.4 kernels for RH9 here.

The easiest way to get them is by using apt-get install yum and replacing the default /etc/yum.conf file with this one:

CODE
[main]
cachedir=/var/cache/yum
debuglevel=2
logfile=/var/log/yum.log
pkgpolicy=newest

[os]
name=Red Hat Linux 9 OS
baseurl=http://ayo.freshrpms.net/redhat/9/i386/os

[updates]
name=Red Hat Linux 9 Updates
baseurl=http://ayo.freshrpms.net/redhat/9/i386/updates

[at-testing]
name=Red Hat Linux 9 ATrpms Testing
baseurl=http://apt.physik.fu-berlin.de/redhat/9/en/i386/at-testing

[at-bleeding]
name=Red Hat Linux 9 ATrpms Bleeding
baseurl=http://apt.physik.fu-berlin.de/redhat/9/en/i386/at-bleeding

[at-good]
name=Red Hat Linux 9 ATrpms Good
baseurl=http://apt.physik.fu-berlin.de/redhat/9/en/i386/at-good

[at-stable]
name=Red Hat Linux 9 ATrpms Stable
baseurl=http://apt.physik.fu-berlin.de/redhat/9/en/i386/at-stable

[freshrpms]
name=Red Hat Linux 9 FreshRPMs
baseurl=http://freshrpms.atrpms.net/redhat/9/i386/freshrpms
    http://ayo.freshrpms.net/redhat/9/i386/freshrpms

[newrpms.sunsite.dk]
name=Red Hat Linux 9 NewRPMs
baseurl=http://newrpms.atrpms.net/apt/redhat/en/i386/9.0
    http://newrpms.sunsite.dk/apt/redhat/en/i386/9.0

[dag]
name=Red Hat Linux 9 Dag Wieers repository
baseurl=http://dag.atrpms.net/redhat/9/en/i386/dag
    http://apt.sw.be/redhat/9/en/i386/dag

[2.6testkernels]
name=Test Linux 2.6-test kernels for RHL9
baseurl=http://people.redhat.com/arjanv/2.5


Then run:

yum update

It will take quit some time to download all the headers ... but it should update all the files including kernel to 2.6.4.

Then I did all the steps on this page in these sections:

Hotplug
Sysfs file system
USB
Sound


Before you reboot, edit your /etc/X11/XF86Config and change your mouse options to these:

CODE
       Option      "Protocol" "ExplorerPS/2"
       Option      "Device" "/dev/input/mice"


Edit the file /etc/sysconfig/gpm (if you have it) and set:

CODE
DEVICE="/dev/input/mice"
Robert83
Hi,

started the update with yum, and it stopped after a while...and when I restart the yum update the same problem occurs...

[root@demon etc]# yum update
Gathering header information file(s) from server(s)
Server: Test Linux 2.6-test kernels for RHL9
Server: Red Hat Linux 9 ATrpms Bleeding
Server: Red Hat Linux 9 ATrpms Good
Server: Red Hat Linux 9 ATrpms Stable
Server: Red Hat Linux 9 ATrpms Testing
Server: Red Hat Linux 9 Dag Wieers repository
Server: Red Hat Linux 9 NewRPMs
Server: Red Hat Linux 9 NewRPMs
Server: Red Hat Linux 9 OS
Server: Red Hat Linux 9 - i386 - updates
Finding updated packages
Downloading needed headers
Resolving dependencies
.......identical dependency loop exceeded
package mozilla-psm needs mozilla = 38:1.5-2.rh90.dag (not provided)
package mozilla-psm needs mozilla-nss = 38:1.5-2.rh90.dag (not provided)

what can be done here?

Sincerely
Robert B
Robert83
Hi,

I had some problems in the file, mistyped a few things , now a did a copy paste from here to a clean yum.conf file

downloaded some more packages...but It still has the same error :

[root@demon /]# yum update
Gathering header information file(s) from server(s)
Server: Test Linux 2.6-test kernels for RHL9
Server: Red Hat Linux 9 ATrpms Bleeding
Server: Red Hat Linux 9 ATrpms Good
Server: Red Hat Linux 9 ATrpms Stable
Server: Red Hat Linux 9 ATrpms Testing
Server: Red Hat Linux 9 Dag Wieers repository
Server: Red Hat Linux 9 FreshRPMs
Server: Red Hat Linux 9 NewRPMs
Server: Red Hat Linux 9 OS
Server: Red Hat Linux 9 Updates
Finding updated packages
Downloading needed headers
getting /var/cache/yum/at-bleeding/headers/yum-0-2.0.5-1_30.rh9.at.noarch.hdr
yum-0-2.0.5-1_30.rh9.at.n 100% |=========================| 3.5 kB 00:00
getting /var/cache/yum/2.6testkernels/headers/kernel-0-2.6.4-1.270.i686.hdr
kernel-0-2.6.4-1.270.i686 100% |=========================| 170 kB 00:11
Resolving dependencies
.......identical dependency loop exceeded
package mozilla-psm needs mozilla = 38:1.5-2.rh90.dag (not provided)
package mozilla-psm needs mozilla-nss = 38:1.5-2.rh90.dag (not provided)


sincerely
robert b
Robert83
Hi,

problem was solved once yum install mozilla was done, it updated the nss and the rest of the needed files...


Sincerely
Robert B
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.