Help - Search - Members - Calendar
Full Version: Hardware Issues
Linuxhelp > Support > Technical Support
mianve
I am clueless and totally new to linux, however I know that what I can do with it is awesome. I have what I think is a graphics acceleration issue, reason being the graphics on all non graphic intense apps work fine but the graphics for games are soooooooooo slooooow it is ridiculous. I have installed on my pc an "Nvidia GeForce2 MX" card. I am also runnin Mandrake9.2 w/ all current updates. Can someone show me ( Hold my hand ) in baby steps how to correct this. I really don't want to go back to winsucks, I hate it so much.
Robert83
Hi,

1) first you'll need to get the latest drivers from nvidia for you're video card.

start at this website http://www.nvidia.com/object/linux_display...2_1.0-5336.html please read the notes about the driver installation it should not be hard to install.


You can use nautilus or mc to edit the files that are mentioned in the notes for the driver installation on nvidias website.


You should download apt-get or yum and use it to update you're system.
http://apt.freshrpms.net/

You change runlevel by editing /etc/inittab and look for a line at the beggining of the file id:5:initdefault:
just change 5 to 3 to start the system in runlevel 3 [without x11 that is], and switch back after driver installation
the same way, just change back to runlevel 5


Sincerely
Robert B
mianve
Thanks so much Robert!! I'm glad that you took the time to help. I have to admit that I don't know what nautilus or mc is. I have been using Linux for two days and have reinstalled it three times. I just don't know what to do. I am so used to windows that my brain thinks "windows" I know that's probably the wrong thing to do.
mianve
I still don't know what to do,
Robert83
Hi,

OK, I'll try again this time, step-by-step smile.gif [hope this will help you]
!!MAKE SURE YOU READ THE README ON THE NVIDIA WEBSITE!!!
Expecialy the part about things you should change in the X11 config file
http://download.nvidia.com/XFree86/Linux-x86/1.0-5336/

1.You go to the nvidia webpage and download this driver NVIDIA-Linux-x86-1.0-5336-pkg1.run
http://download.nvidia.com/XFree86/Linux-x86/1.0-5336/
You should download it somewhere for example /home [in this step-by-step guide I will asume you downloaded it to /home ]

2. Now you need to edit the /etc/inittab file , this can be done in various ways :
! Open up the console [Suse Symbol] sytem[or something] and search for Terminal [or Console].
* now try the following in the console, type
mc [if you've got midnight commander installed it should show up , blue screen , sorta norton commander]
if nothing try
pico if something shows up, then just

cd /etc/
pico inittab

and change the line id:5:initdefault
to id:3:initdefault

this will change you're runlevel to 3,...note that if you don't have any of the above, you could try using a text editor to open up that file /etc/inittab and edit it.
-----------------------------------------------------------------------------------------------
Or! you can try rebooting the system and if you use grub, at the point where it waits for 10 sec
there is a option to start linux with custom or something like that parameters try
typing linux init3 [or?] linux init 3 [sorry I'm on Win right now]
------------------------------------------------------------------------------------------------

3.Now If you finaly made it to the non gui mode smile.gif, just :
a) cd /home
cool.gif ls
c) ./NVIDIA-Linux-x86-1.0-5336-pkg1.run
[and follow the instructions]
d) reboot the computer and if the NVIDIA logo shows up when X11 starts you did it smile.gif

Sincerely
Robert B
mianve
Thanks again Robert, I will try that when I get home. I'm at work, lol. I really apreciate the help. It feels so good to be able to find help with linux. You are great!!!
mianve
I think that it is the terminal that I am so afraid of. I wasn't used to using it or the numerous linux commands. There is so much to learn. I feel like I'm standing at the base of Mt. Everest, lol. But I know it is worth it. I can't to get back to it.
hughesjr
actually, the console is pretty easy ... no mouse to click. Just type stuff. smile.gif

I find myself opening terminal windows all the time and typing console commands instead of using the menus...even for graphical stuff I usually start them inside a terminal window.
mianve
Robert,

Ok, I opened a terminal, the ran "mc", found the "etc/inittab", opened it to edit it, found & changed the line id:5:initdefault
to id:3:initdefault. But I must be missing a step.

The nvidia readme says to first exit or stop x so that I am no longer running in a GUI. How do I do that? Next question.......After I change the value from 5 to 3, do I save it?
hughesjr
Got to be the root user to change the file ....

after you save it, reboot and you will be in console mode.
------------------------------------------------------------------------------------
or as the root user in a terminal window, you can just type:

init 3
------------------------------------------------------------------------------------
mianve
and to go back to gui after the install I type <init 5>?
mianve
QUOTE (mianve @ Mar 10 2004, 08:20 AM)
and to go back to gui after the install I type <init 5>? How do I switch from user to root?

How do I switch from user to root?
Robert83
Hi,

type su <press ENTER>
type in youre root password <ENTER>

Sincerely
Robert B
hughesjr
after you are done with the install, reboot.

Before you start, you need to have the kernel-source package installed that matches your current kernel.
mianve
Thanks,

So here is what I do

1) Start computer
2) Open terminal
3) Type <su> hit enter
4) Type <root password> hit enter
5) Type <init 3> hit enter
6) Go to CD/Home
7) Run Nvidia driver app
8) Edit xfree86 as per Nvidia readme
9) Reboot computer and enjoy!!

Last question I hope, Do I need to change back to init 5 after the install?

I feel so ignorant, but I read the manuals every night, lol
One things for sure though, I hate ms win passionatly, argh!

Thanks for being so helpful!
hughesjr
for # 3, I recommend:

su - root

After the reboot (step 9), login to the console as root ... then type startx

if X starts and works, then edit the file:

/etc/initab and change the 3 back to a 5 in the line:
id:3:initdefault
mianve
I did it!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Robert83
Congratulations ! ! ! smile.gif smile.gif smile.gif


Sincerely
Robert B
mianve
l LOVE LINUX!!!!!!! YEAH, I FEEL LIKE A KID AGAIN, LOL. LINUX MAKES COMUTERS FUN AGAIN, DOESN'T IT?
Robert83
Yes,

except when it $#@$@ me around while installing Ati drivers smile.gif smile.gif, why? why? me? why?


Sincerely
Robert B
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.