OK .... I have had this problem with all 2.6 Kernels that I have tried to use, and I finally found the solution to the problem. biggrin.gif

Problem: When I add the option to make the mouse wheel scroll in /etc/X11/XF86Config like this:

CODE
Option      "ZAxisMapping" "4 5"


Everything works great, until I switch to another channel on my KVM and switch back. After switching back, scrolling down works ... but scrolling up instead acts like a right click or a right click and center click combined. The only way to make the scroll wheel work again is to reboot the computer or unplug and replug the mouse back into the KVM switch.

The Solution: Add this to the end of your kernel line in /boot/grub/grub.conf:

CODE
psmouse.proto="ExplorerPS/2"


Change the protocol line in your /etc/X11/XF86Config file to this:

CODE
       Option      "Protocol" "ExplorerPS/2"