Help - Search - Members - Calendar
Full Version: Can't Seem To Get Onto My Network?
Linuxhelp > Support > Technical Support
wayerst
Hey guys -I've just set up a sub-distro of Slackware called VectorLinux on my P3 laptop, and I'm having trouble getting on to my home network.

Basically, the gateway is at 192.168.0.1 , and another is at 192.168.0.5

I've configured my laptop to 192.168.0.8 , and with the Network PCMCIA card inserted, I can ping that IP add. (obviously) and 127.0.0.1 no problems. If I remove the card, I can't - thefore I must assume the card is being detected fine.

The only thing I'm not sure about in netconfig - is the "domain" setup? I don't have a domain on my network, but I can't bypass this step? (I just set it as MSHOME, the current Workgroup on the network)

pinging .0.1 results in "100% sent, 0% recied, 100% packet loss" , and vice-versa!

please help! Any extra information that I can provide, please ask!

Thankyou!!
Robert83
Hi,

that is ok I think, just make sure that you don't give you're computer a domain name like microsoft.com or something like that, wich is already registered, use names like you use with other windows computers , like Family.Laptop or something like that.


Sincerely
Robert B
wayerst
Well, I still can't get onto my network, that's the problem!

It can see itself using a non-local IP, but nothing else can see it.... ifconfig gives this:

Eth0
Link encap:Ethernet HW Addr xxx
inet addr: 192.168.0.8 Bcast: 192.168.0.255 Mask: 255.255.255.0
Up Broadcast Running Multicast MTU: 1500 Metric: 1
RX/TX packets: 0
IRQ: 3 Base Addr: 0x0300
hughesjr
I use home.local as a DNS address for all my local machines ... but the domain name won't make any difference on pinging other machines using the IP Addresses directly.

If you can't ping 192.168.0.1 from the laptop, but you can from other PC's on the network, then there is something wrong with the network card setup of the laptop.
wayerst
Sorry.. let me clarify one last time -

the laptop's IP is 192.168.0.8
the Gateway's IP is 192.168.01
another PC on my hub is 192.168.0.5

the laptop can ping itself on .0.8 and on 127.0.0.1 with the NIC inserted.
Without the NIC, it can't ping anything, thefore the NIC is fine, yes?
the laptop cannot ping anything else on my hub, or the gateway PC.
the other PC, or the Gateway, cannot ping the laptop.

I thought maybe the domain had something to do with it, but obviously not!

Thanks!!
wayerst
hughesjr - Thanks! Is there some logical route I can go through checking to find out?
hughesjr
What is the output of the command:

route

It should look something like this:
CODE
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.0.0     *                      255.255.255.0   U        0      0        0 eth0
127.0.0.0         *                       255.0.0.0            U        0      0        0 lo
default         192.168.0.1        0.0.0.0               UG      0      0        0 eth0
wayerst
This is what I get:

CODE
destination     gateway     genmask       flags   metric  ref   use  Iface
localnet        *               255.255.255.0 U       0       0     0     eth0
localnet        *               255.0.0.0       U        0       0     0     lo
default         192.168.0.1 0.0.0.0          UG      1       0     0     eth0
hughesjr
I can't tell what localnet is ... sorry ... do:

route -n
wayerst
make the middle one 'loopback'

route -n gives me:

CODE
destination     gateway     genmask          flags   metric  ref   use  Iface
192.168.0.0             0.0.0.0        255.255.255.0   U       0       0     0     eth0
127.0.0.0                0.0.0.0        255.0.0.0         U        0       0     0     lo
0.0.0.0                   192.168.0.1   0.0.0.0            UG      1       0     0     eth0


Does that help?
hughesjr
that is the correct route table ....

you should be able to ping any address that is on the 192.168.0.0 network directly ... is there a firewall on the laptop?

The command:

iptables -L

should tell you if there is.....
wayerst
that gives me:
CODE
Chain INPUT (policy ACCEPT)
target   prot opt source destination


Chain FORWARD (policy ACCEPT)
target   prot opt source destination

Chain OUTPUT (policy ACCEPT)
target   prot opt source destination


Is there something else I may be doing wrong? sad.gif Thanks!
Robert83
hm....

is you're windows computer enabled to share you're internet connection?


Sincerely
Robert B


ps.: if yes, try another network card.
linuxwolf069
Let's break this down real simple...

You have a nic right???

You configure the ip address right???

You cannot ping anything on the local network right???


Have you tried a different cable? Say the one on the windows desktop that is working? That would be the first thing I would suggest...


Is it a wireless card by chance? I didn't notice that it was, but thought maybe something got left out.

Is there only 1 nic in the laptop? Or 2? I know some have an onboard is why I ask.
wayerst
Right, I ripped out all the cabling in my house, apart from the hub, gateway and laptop - and now it can see it. Unbeknownst to myself, there was an extra hub between the laptop and the 'main' hub, and it wasn't seeing anything through there - now it's fine though, it can ping the gateway now.

HOWEVER! If anyone can explain why it's not letting me access the internet, I'd be much obliged - I've stuck in 192.168.0.1 as the internet gateway, but I'm not sure which port to use?

Thanks again, guys -I really appreciate the help!
Robert83
enable internet sharing on gateway computer


sincerely
Robert B
wayerst
can you believe that the only reason the above didn't work, was that my ISP's primary DNS server was down? I exchanged for the 'backup' server and it worked a treat.

Thanks again, I really really do appreciate the help!
Robert83
yeah that happened to me to when 62.108.117.6 went down and was switched for 217.26.64.130

Sincerely
Robert B
linuxwolf069
glad you were able to get it working...

Glad I could help.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.