Help - Search - Members - Calendar
Full Version: Samba Trouble
Linuxhelp > Support > Technical Support
Robert83
Hi,

I've got Samba 3.0.2a installed as a file server , and when I issue the command smbstatus [wich should who is connected to the system, and what files did he/she open], this comes out sesionid.tdb not initialised, what is wrong?


How can I make smbstatus work in real time?, I mean you always have to type in the command to see if somebody is online, could this possibly work with a script? I mean, the script would start it up ... with these options * * * * * /usr/bin smbstatus ?

Sincerely
Robert B
hughesjr
If someone is connected to the share, you should be able to see it.

If you have samba-swat running, you can get a status via the status icon ... go to :

http://127.0.0.1:901/

from the server to see if you have swat running
Robert83
Thank's I think this could be the problem will try it later :

status

This global option indicates whether Samba should log all active connections to a status file. This file is used only by the smbstatus command. If you have no intentions of using this command, you can set this option to no, which can result in a small increase of speed on the server. The default value for this option is yes. You can override it as follows:

[global]
status = no

[wonder how did it check to no ? if default is yes? and I'm pretty sure that I haven't given any status = something[yes or no] line to my smb.conf]

Well anyway I'll try this, perhaps this thingie creates that *.tdb file wich smbstatus requires.


Sincerely
Robert B
hughesjr
That would be why it isn't working .... my status is set to yes...
Robert83
Yes, I guess so smile.gif [it pays to read really long online manuals about Samba and other stuff smile.gif, atleast some info sticks on me, [or how you say this in english ] smile.gif smile.gif ]


Thank you anyway, for you're response.

Sincerely
Robert B
Robert83
Hi,

well I was trying this for a while, and still no success...

when I instert
status = yes into the global sections

testparm shows that status is ignored , as it is a unknown program...

still getting that sessionid.tdb not initialized error...

any ideas?

oh and by the way, maybe the error is service related, what are the MUST RUN service for a samba server? [just askin, cause I might have that configured improperly]

Please help me.

Sincerly
Robert B
hughesjr
The service that needs to start is /etc/init.d/smb (for RedHat / FedoraCore / WhiteBox).
Robert83
Hi,

that is starting and is working...clients can connect...but that sessionid.tdb is still not initialised...

Sincerely
Robert B
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.