Hi,

Ok, trying to setup apache with ssl on Red Hat 9.0, I have recieved my Thawte cert already. I was given instructions on what to do to get apache running with ssl support, I have followed them to a tee but have had no joy. I installed the apache and mod_ssl rpms that come on with the Red hat CD. When I test the default configuration I am able to see http://localhost and https://locahost. I try and change the ssl.conf, the only changes I make are the following:

<VirtualHost domain name:443>

# General setup for the virtual host
DocumentRoot "/var/www/html"
ServerName domain name:443
ServerAdmin you@your.address
ErrorLog logs/ssl/ssl_error_log
TransferLog logs/ssl/ssl_access_log

# Server Certificate:
# Point SSLCertificateFile at a PEM encoded certificate. If
# the certificate is encrypted, then you will be prompted for a
# pass phrase. Note that a kill -HUP will prompt again. A test
# certificate can be generated with `make certificate' under
# built time. Keep in mind that if you've both a RSA and a DSA
# certificate you can configure both in parallel (to also allow
# the use of DSA ciphers, etc.)
SSLCertificateFile /etc/httpd/conf/ssl.crt/name of thawte cert
#SSLCertificateFile /etc/httpd/conf/ssl.crt/server-dsa.crt

# Server Private Key:
# If the key is not combined with the certificate, use this
# directive to point at the key file. Keep in mind that if
# you've both a RSA and a DSA private key you can configure
# both in parallel (to also allow the use of DSA ciphers, etc.)
SSLCertificateKeyFile /etc/httpd/conf/ssl.key/name of key I got with thawte cert
#SSLCertificateKeyFile /etc/httpd/conf/ssl.key/server-dsa.key

I add the thawte cert and the key into the appropiate directories. I do not touch the httpd.conf file, when I restart apache it restarts ok. I am able to go to http://locahost fine, but when I try and go to https://locahost, I get the following error in my browser "The connection to localhost has terminated unexpectedly. Some data may have been transferred"

When I check the log files the following is in there:
[Tue Mar 02 15:13:50 2004] [error] [client 127.0.0.1] Directory index forbidden by rule: /var/www/html/
[Tue Mar 02 15:13:53 2004] [error] [client 127.0.0.1] Invalid method in request !F!!

I have done a bit of googling on this and the problem seems to be related to the Virtual host settings, however I can not see where I am going wrong.

Thanks
Gareth