Help - Search - Members - Calendar
Full Version: Installation Of Lm Sensors
Linuxhelp > Support > Technical Support
I am extremely new to Linux (I have been a Windows user all my life until now) and recently, have sucessfully installed Redhat 9.0. I am trying to install the Hardware Monitoring software, LM_sensors,(downloaded from ""), but the having problem understanding the installation instruction provided on the website. It mentioned that I need to re-compile certain files, check kernel version, making some patches to certain modules, etc.... I have no idea what to do, it sounded so alien to me. Is there anybody who have successfully installed this software before and could help guide me thru step by step, and I will be eternally greatful.

Thank you very much.
RedHat 9 has lm_sensors as a builtin package .... use the command (all commands must be done as root from a terminal window (or the console):

rpm -qa | grep sensors

If you have both lm_sensors and lm_sensors-devel, skip to Setting up lm_sensors, otherwise:

Install via one of these methods if not already installed:

1. if you are using apt to do updates, use the command:

apt-get update
apt-get install lm_sensors lm_sensors-devel


2. if you use up2date to get your updates do this

up2date lm_sensors lm_sensors-devel


3. download them from here:

and install via the command:

rpm -Uvh lm_sensors-2.6.5-5.i386.rpm lm_sensors-devel-2.6.5-5.i386.rpm
Setting up lm_sensors

do the command:

modprobe i2c-proc

run the program:


You can normally accept the default detection ... and you normally don't need to add anything to any of the recommended files ... just generate the /etc/sysconfig/lm_sensors file.

then go to Menu - System Settings - Server Settings - Services (or run the command redhat-config-services from a terminal window) and make sure the box beside lm_sensors is checked for runlevel 3 and runlevel 5...

reboot and everything should be working....
Thank you so much for coming to my rescue. However, I am still having problem.

When I type "rpm -qa | grep sensors", I only have "lm_sensors-2.6.5-5" as return. As such, assuming I dont have both "lm_sensors" and "lm_sensors-devel", I downloaded the rpm files from the ftp site indicated.

Upon running "rpm -Uvh lm_sensors-2.6.5-5.i386.rpm lm_sensors-devel-2.6.5-5.i386.rpm", it states that "lm_sensors already installed".

Then, when I run "modprobe i2c-proc", it return "i2c-core.o: i2c core module" and "i2c-proc.o version 2.6.1 (20010825)".

After which, I ran "sensors-detect", a whole lot of questions pop up and I just hit <Enter> assuming using all default setting. However I noticed that when it is probing for sensors, all different type of sensors from different manufacturer failed.

Next, I startx and goto "Menu - System Settings - Server Setting - Service", but I dont see any "lm_sensors".

Appreciate if you could help shed some light on my problem, please.

The sensor on my motherboard is VIA, VT1211, and according to the lm_sensors website, it should be supported by version 2.6.4.

What have I done wrong?

Thank you very much.
OK ... all the lm_sensors stuff I told you doesn't work with the default redhat packages ...

but it does work with the newer packages from apt-get that were written by axel thimm ...

apt-get is a way to keep your packages updated and gain access to rpms written by 3rd party people ... I use it on all RH9 machines.

If you want to intstall apt-get and update your system, the lmsensors stuff I told you will work.

(the sensors-detect and the services)

To get apt-get (for redhat 9) you would go here and download the first RPM ...


rpm -Uvh apt-0.5.5cnc6-fr1.i386.rpm

then backup the file /etc/apt/sources.list like this:

cp /etc/apt/sources.list /etc/apt/sources.list.bak

then replace the original file /etc/apt/sources.list with this information (edit the file, delete all the lines, add this instead):
# List of available apt repositories available from
# This file should contain an uncommented default suitable for your system.
# See for a list of other repositories and mirrors.
# $Id: sources.list,v 1.8 2003/04/16 09:59:58 dude Exp $
#For RedHat 9
rpm redhat/en/i386/9.0 newrpms
#rpm-src redhat/en/i386/9.0 newrpms

rpm redhat/9/i386 os updates freshrpms
#rpm-src redhat/9/i386 os updates freshrpms

#Alex Thimm's
rpm redhat/9/en/i386 at-good at-stable at-testing
#rpm-src redhat/9/en/i386 at-good at-stable at-testing

#Dag Wieers's
rpm redhat/9/en/i386 dag
#rpm-src redhat/9/en/i386 dag

Then do the commands:

apt-get update
apt-get dist-upgrade

then when everything is updated, reboot

then do:

apt-get install lm_sensors lm_sensors-devel

then do the the things from the original post starting with

modprobe i2c-proc
I successfully downloaded the rpm, and replace the "sources.list" file. However, when I tried to "apt-get update", I realised that my server has a proxy and it needs a user name and password. As such, I get the error "401 Authentication required".

Can you please tell me what file, and where to edit, to include the proxy server, user name, and password, so that "apt-get" can access the internet.

Thank you so much.
In the file /etc/apt/apt.conf add this:

// Options for the downloading routines
Acquire {
   Retries "0";
   Http {
       Proxy "http://username:password@proxy_name:port/";
    // ftp {
    //   Proxy "ftp://username:password@proxy_name:port/";
    // }

Replace the proxy_name with the ip_address or name of the proxy server, the port with the port_number for the proxy. If you also need a proxy for ftp, remove the // from in front of those lines. You can try to leave the proxy username and password as they are and see if it prompts you for them ... if it doesn't, you will need to include the actual username and password in the file...
And for Gentoo users:

How to use your Hardware Sensors with Kernel 2.6


Monitor CPU Temperature with lm_sensors and gkrellm

The second guide helped me to get mine working for the first time in the 3 years i've had my motherboard smile.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.