Help - Search - Members - Calendar
Full Version: Nvidia Driver Problems
Linuxhelp > Support > Hardware Support
GwarTime
Im pretty new to linux, I spent all weekend reading how tos to get red hat 9 running to my liking.

One thing I really need help on, is the nvidia drivers for my video card. I already tried running it in init 3 but it says it doesnt recognize my kernel, and wants the kernel developement files(??)

I tried to get it off the redhat cd and it says im missing krb5-libs = 1.2.7-10 and openssl = 0.9.7a-2 I dont have the slightest clue where these are.

Also, I read about the various problems people are having with nvidia drivers and the newer kernel, should I wait it out for new drivers to be released? and are there any alternatives to the nvidia drivers (with 3D acceleration)

System specs
Red Hat 9
20gb Maxtor
Some MSI via chipset MB
Athlon 1.33 ghz
512 mb SDram
Geforce2 MX (Im a student, im poor)
Soundblaster LIVE! 5.1

EDIT: clarity, im tired
hughesjr
you need to install the kernel-source package .... then follow the directions on the nvidia site ...
mianve
I had the same problem but got help, this reall works. Just remember "Linux is Case sensitive, I can't stress this enough!!! try this it worked for me on my Mandrake 9.2 system which is Red Hat based.


1. Make sure you have your kernel-source installed:

- open a konsole (ALT-F2 and type 'konsole') then do:

# rpm -qa|grep kernel

If kernel-source is not listed, install it with:

# su (hit enter and type your root password)
# urpmi kernel-source (hit enter and say 'y' to any questions)

2. Download the Linux driver from NVIDIA:
http://download.nvidia.com/XFree86/Linux-x...0-5336-pkg1.run

3. Exit out of X when you done downloading (Right click on the desktop and
select 'logout', and logout of the session).

4. This should bring you back to the login screen. Switch to a console
(press CTRL-ALT-F1) and login with 'root' and your root password.

5. Turn off X by typing:

# init 3

6. Run the NVidia installer, by changing to the directory you downloaded it
to, and doing:

# sh NVIDIA-Linux-x86-1.0-5336-pkg1.run

7. Agree to everything it says, unless you don't want to smile.gif

8. When it is done, edit '/etc/X11/XF86Config-4':

# vi /etc/X11/XF86Config-4

Find the line with

Driver "nv"

and change it to

Driver "nvidia"

(to edit in vi, press the 'insert' key. to stop editing, press 'Esc'. When
you are done, press :wq to write and quit.)

8. Reboot your computer (type 'reboot' at the console) and it should come
up with the NVidia driver.
veris2040
Something nobody ever says when they fix their Nvidia drivers for Linux:

If your Nvidia Card is AGP need to configure your XF86Config-4 to accomodate this:

In the same section where you changed "nv" to "nvidia" create a new option:

Option "NvAGP" "3"

this will allow you to gain the 3d acceration from the card

another Option of significance:

Option "NoLogo" "1"

This will allows you to turn off the Nvida Logo when X-Server starts up on your computer
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.