Help - Search - Members - Calendar
Full Version: Problems With Pinnacle Pctv Stereo (saa7134)
Linuxhelp > Support > Technical Support
Koopa Troopa
My Problem : trying to get a Pinnacle PCTV Stereo tv tuner card (for PAL BELGIUM) to work under linux

Details: I'm trying to build my pvr system with mythtv. But first is thing to get my hardware running. The only problem I can't solve myself is the tv card setup. To test things simply I started with xawtv and tvtime. tvtime gave me info about VideoOverlay to be used instead of OpenGLOverlay in my XFree86 config. After changing this tvtime runs but gives me a blue screen with a No Signal message.I ran tvtime-scanner and I actually got sound from a channel on tvtime,but no picture, so that did seem to indicate that I must be on the right track (alas sound had 'magically disappeared' on next boot)

Anyway here is some info about my setup :
lsmod reports the following:
CODE
tda9887                 3168   1  (autoclean)
tuner                  13128   1  (autoclean)
saa7134                70724   0  (autoclean)
tvaudio                14408   0  (unused)
video-buf              13328   0  (autoclean) [saa7134]
i2c-core               13924   0  (autoclean) [tda9887 tuner saa7134 tvaudio]
ir-common               2500   0  (autoclean) [saa7134]
...


/dev/video0 seems to be ok:xawtv -hwscan reports the following :
CODE
port 59-59
   type : Xvideo, image scaler
   name : ATI Radeon Video Overlay

/dev/video0: OK                         [ -device /dev/video0 ]
   type : v4l2
   name : Pinnacle PCTV Stereo (saa7134)
   flags: overlay capture tuner


Concerned Hardware :
-Creative labs Audigy 2 ZS
-Ati Radeon 9700 PRO (Ati Display 3.07 + 1.3 Mesa 4.0.4 Drivers)
-Pinnacle PCTV Stereo (Philips saa7134 chip, at first I was mislead because other Pinnacle PCTV cards use bt878 chips, but saa7134 is what it says on my chip).

PAL B/G --> Belgium : I believe that frequencies are the same as standard Western-europe
3 first and last channels for Belgium are :
CODE
E2 48.25 NOS 1 Stereo
E3 55.25 KETNET-CANVAS Stereo Nicam
E4 62.25 RTBF LA UNE Stereo Nicam
...
E23 487.25 CARTOON NETWORK / TCM Stereo Nicam
E24 495.25 TRT Mono
E25 503.25 RTM Mono


Distro : Debian unstable (sid) from Knoppix hd-install
Kernel 2.4.24 : recompiled with alsa, v4l2, saa7134 support after patching with patch-2.4.24-rc1-kraxel (from bytesex.org)
Installed saa7134 0.2.9 drivers (from bytesex.org) with insmod options card=26 tuner=33

Other details: all the hardware runs fine on the same machine under Win XP Pro, so I'm not considering broken hardware.

Any pointers are welcome, being new to linux I might of forgotten something major.
Corey
Run 'dmesg' and look for what the tuner module auto-detected your tvcard as.

Also, when you run tvtime, did you go into the configuration to setup your frequency list (press F1 to display the menu in >0.9.10) before running the scanner.

If everything checks out, you may want to check out the TVtime chat channel on irc.freenode.org in #livid .

Or, just reply here smile.gif
Koopa Troopa
dmesg gives this
CODE
i2c-core.o: i2c core module
tvaudio: TV audio decoder + audio/video mux driver
tvaudio: known chips: tda9840,tda9873h,tda9874h/a,tda9850,tda9855,tea6300,tea6420,tda8425,pic16c54 (PV951),ta8874z
i2c-core.o: driver generic i2c audio driver registered.
saa7130/34: v4l2 driver version 0.2.9 loaded
saa7134[0]: found at 02:0c.0, rev: 1, irq: 20, latency: 64, mmio: 0xfeafb400
saa7134[0]: subsystem: 11bd:002b, board: Pinnacle PCTV Stereo (saa7134) [card=26,insmod option]
saa7134[0]: board init: gpio is 0
i2c-core.o: adapter saa7134[0] registered as adapter 0.
saa7134[0]: i2c eeprom 00: bd 11 2b 00 f8 f8 1c 00 43 43 a9 1c 55 d2 b2 92
saa7134[0]: i2c eeprom 10: 00 00 19 0e ff 20 ff ff ff ff ff ff ff ff ff ff
saa7134[0]: i2c eeprom 20: 01 40 01 03 03 ff 03 01 08 ff 00 53 ff ff ff ff
saa7134[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
i2c-core.o: driver i2c TV tuner driver registered.
tuner: chip found @ 0xc0
tuner: type set to 33 (MT20xx universal)
tuner: microtune: companycode=3cbf part=42 rev=2f
tuner: microtune MT2050 found, OK
i2c-core.o: client [MT20xx universal] registered to adapter [saa7134[0]](pos. 0).
i2c-core.o: driver i2c tda9887 driver registered.
tda9887: chip found @ 0x86
tuner: type already set (33)
i2c-core.o: client [tda9887] registered to adapter [saa7134[0]](pos. 1).
saa7134[0]: registered device video0 [v4l2]
saa7134[0]: registered device vbi0
saa7134[0]: registered device radio0
saa7134[0]: registered device dsp1
saa7134[0]: registered device mixer1
tuner: TV freq (0.00) out of range (44-958)
saa7134[0]/audio: audio carrier scan failed, using 5.500 MHz [default]
saa7134[0]/audio: audio carrier scan failed, using 5.500 MHz [default]


and lspci states :
CODE
02:0c.0 Multimedia controller: Philips Semiconductors SAA7134 (rev 01)


I tried several combinations with tvtime using either European or custom but I can't seem to reproduce my 1 partial success
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.