Help - Search - Members - Calendar
Full Version: Enabling Dma For Hdc In Red Hat 7.3
Linuxhelp > Support > Technical Support
I'm trying to enable DMA on the device /dev/hdc and am not able
to do it.
I'm running RedHat 7.3 with the 2.4.18-3 kernel.
My computer is a Sager Notebook 888E.

Running hdparm gives me the following

# hdparm -d 1 /dev/hdc
setting using_dma to 1 (on)
HDIO_SET_DMA failed: Operation not permitted
using_dma = 0 (off)

# hdparm /dev/hdc
HDIO_GET_MULTCOUNT failed: Input/output error
I/O support = 1 (32-bit)
unmaskirq = 1 (on)
using_dma = 0 (off)
keepsettings = 0 (off)
HDIO_GET_NOWERR failed: Input/output error
readonly = 0 (off)
BLKRAGET failed: Input/output error
HDIO_GETGEO failed: Invalid argument
busstate = 1 (on)

# hdparm -i /dev/hdc
Model=TOSHIBA DVD-ROM SD-R2212, FwRev=1013, SerialNo=92KC903022
Config={ Fixed Removeable DTR<=5Mbs DTR>10Mbs nonMagnetic }
RawCHS=0/0/0, TrkSize=0, SectSize=0, ECCbytes=0
BuffType=unknown, BuffSize=2048kB, MaxMultSect=0
(maybe): CurCHS=0/0/0, CurSects=0, LBA=yes, LBAsects=0
IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
PIO modes: pio0 pio1 pio2 pio3 pio4
DMA modes: sdma0 sdma1 sdma2 mdma0 mdma1 mdma2 udma0 udma1 *udma2
Drive Supports : ATA/ATAPI-5 T13 1321D revision 3 : ATA-2 ATA-3 ATA-4 ATA-5

How can I enable DMA on the drive?
# hdparm -d 1 /dev/hdc

should be

hdparm -d1 /dev/hdc (no space between -d and 1)
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.