After compiling (successfuly) a new 2.6.2 kernel from scratch I run mkinitrd but get the following error:

max3d:/usr/src/linux# mkinitrd -i /lib/modules/2.6.2 /boot/initrd-2.6.2.img
Using kernel_version from devices.inf 2.4.22-x1
Modules in ramdisk: jbd.o ext3.o /lib/modules/2.6.2
Modules: jbd.o ext3.o /lib/modules/2.6.2
Preload:
Could not copy modules! at /sbin/mkinitrd line 324.

FYI- my old kernel is 2.4.22. I tried compiling ext3 directly into the new kernel as opposed to a module but still had problems. Apparently it keeps trying to use the old kernel stuff because it can't find these 2 modules. Here's some more info

max3d:/usr/src/linux# ls /lib/modules/2.6.2/
build modules.generic_string modules.parportmap modules.usbmap
kernel modules.ieee1394map modules.pcimap
modules.dep modules.isapnpmap modules.pnpbiosmap

max3d:/usr/src/linux# ls /lib/modules/2.6.2/kernel/fs/
autofs ext3 msdos smbfs
binfmt_aout.ko fat nfs vfat
binfmt_misc.ko jbd nfsd
exportfs lockd nls

max3d:/usr/src/linux# ls /lib/modules/2.6.2/kernel/fs/ext3/
ext3.ko

max3d:/usr/src/linux# ls /lib/modules/2.6.2/kernel/fs/jbd/
jbd.ko

Any help would be appreciated smile.gif