Help - Search - Members - Calendar
Full Version: Su -
Linuxhelp > Support > Technical Support
fmagoufis
All of a sudden, i cannot use the su - comman. When i run it and type in the correct superuser password, it says password incorrect.

Why wink.gif
Joey
Out of sheer curiousity, why on earth are you using telnet?

SSH is a wonderful thing.

http://www.ssh.org
http://www.openssh.org
fmagoufis
Even if i use ssh to connect i still cannot do a su -. The server is at my work in another office.

Any help would be appreciated.
Corey
Well, I'm not sure with telnet (because I use mostly SSH), but you may have to set telnet up to allow for remote root login. I know with ssh, you have to set it in the config file in order for you to ssh -l root .
fmagoufis
i tried fixing the config file, but anytime i run su - , I get wrong password.
chrisw
It could be that you are not in the group: wheel
this group is used for people who can su -
to root. Therefore if you are not in the group wheel
you can not su - to root. Check the group file
and see if there is a list of names besides root,
if root is even listed..and if there is a list of
user names...see if you are in that list....if not
you wont be able to su to root
if you are not in the list try getting someone
who can su to root and add you to the group
fmagoufis
i am on the group. what next?
could it be a rights issue?
chrisw
if you are in the group wheel then
you should be able to su - to root

check to see if the file "su" which
is in /etc/pam.d/
directory has the group set to wheel
just look for a line that has
the following

10
- or -
wheel

if so,
i dont know of anything off hand that is
keeping you from su'ing to root.
fmagoufis
everything looks good.

Where to look next?
chrisw
im not sure where to look next....
you sure you are typing in the correct
password for root?
fmagoufis
absolutely typing in the correct password.
Corey
The only other thing I can think of is, try to type your password just in plain site on the command line before you "su -". Make sure that it appears right there, the only thing I can think of is that your keyboard is mapped wrong through your telnet(ssh) program. Have you tried just typing "su" rather then "su -" ? As well, have you tried to enable remote root login, and just logged in as root rather then su'in?
fmagoufis
how do I enable remote root login?
chrisw
if you are running redhat
you enable remote root login by editing the sshd.config file
in /etc/sshd folder

change permit root login from no to yes

the save the file...then restart ssh

by typing

/etc/rc.d/init.d/sshd restart
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.